summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-07-30 00:14:55 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-07-30 00:14:55 +0000
commitc83b876cd5e3a755091149f0a4af2e36ef155041 (patch)
tree8e11758aa3581d71b2a3196c07a382322a0700cf /net-www/mozilla
parentfew clean-ups (diff)
downloadgentoo-2-c83b876cd5e3a755091149f0a4af2e36ef155041.tar.gz
gentoo-2-c83b876cd5e3a755091149f0a4af2e36ef155041.tar.bz2
gentoo-2-c83b876cd5e3a755091149f0a4af2e36ef155041.zip
gcc-3 fixes
Diffstat (limited to 'net-www/mozilla')
-rw-r--r--net-www/mozilla/ChangeLog8
-rw-r--r--net-www/mozilla/mozilla-1.1_beta.ebuild10
2 files changed, 12 insertions, 6 deletions
diff --git a/net-www/mozilla/ChangeLog b/net-www/mozilla/ChangeLog
index 06721ba1f164..461dc4c554e2 100644
--- a/net-www/mozilla/ChangeLog
+++ b/net-www/mozilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mozilla
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.29 2002/07/25 15:39:55 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.30 2002/07/30 00:14:55 azarah Exp $
+
+*mozilla-1.1_beta (30 Jul 2002)
+
+ 30 Jul 2002; Martin Schlemmer <azarah@gentoo.org> mozilla-1.1_beta :
+ Enable the mozilla-1.0-asm-fixes.patch again, as it fixes some
+ build problems with gcc-3.x.
*mozilla-1.0-r4 (25 Jul 2002)
25 Jul 2002; Spider <spider@gentoo.org> mozilla-1.0-r4.ebuild:
diff --git a/net-www/mozilla/mozilla-1.1_beta.ebuild b/net-www/mozilla/mozilla-1.1_beta.ebuild
index 1ca713e92755..c054ba89e637 100644
--- a/net-www/mozilla/mozilla-1.1_beta.ebuild
+++ b/net-www/mozilla/mozilla-1.1_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.1_beta.ebuild,v 1.4 2002/07/29 03:42:29 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.1_beta.ebuild,v 1.5 2002/07/30 00:14:55 azarah Exp $
# NOTE: to build without the mail and news component: export NO_MAIL="YES"
inherit makeedit
@@ -68,7 +68,7 @@ src_unpack() {
[ -z "${CC}" ] && CC=gcc
if [ "`${CC} -dumpversion | cut -d. -f1,2`" != "2.95" ] ; then
# Fix bogus asm (from Mandrake .spec)
-# patch -p1 < ${FILESDIR}/${P}-asmfixes.patch || die
+ patch -p1 < ${FILESDIR}/mozilla-1.0-asmfixes.patch || die
# patch -p1 < ${FILESDIR}/${P}-gcc3-java-plugin.patch || die
@@ -175,11 +175,11 @@ src_compile() {
export BUILD_OPT=1
# Currently gcc-3.1.1 dont work well if we specify "-march"
- # and other optimizations
+ # and other optimizations for pentium4.
[ -z "${CC}" ] && CC=gcc
if [ "`${CC} -dumpversion`" = "3.1.1" ] ; then
- export CFLAGS=""
- export CXXFLAGS=""
+ export CFLAGS="${CFLAGS/pentium4/pentium3}"
+ export CXXFLAGS="${CXXFLAGS/pentium4/pentium3}"
fi
# Crashes on start when compiled with -fomit-frame-pointer