summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-07-30 18:30:13 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-07-30 18:30:13 +0000
commitc7e98a6f96ceae4a09cef9480192bde523b9cb83 (patch)
tree1a867235da3d73d91cc03dcad84e45c86fb68ea1 /net-www/mozilla
parentDisabled socks5 support. also fixes bug #3775 (diff)
downloadgentoo-2-c7e98a6f96ceae4a09cef9480192bde523b9cb83.tar.gz
gentoo-2-c7e98a6f96ceae4a09cef9480192bde523b9cb83.tar.bz2
gentoo-2-c7e98a6f96ceae4a09cef9480192bde523b9cb83.zip
pentium 4 fixes.
Diffstat (limited to 'net-www/mozilla')
-rw-r--r--net-www/mozilla/ChangeLog6
-rw-r--r--net-www/mozilla/mozilla-1.0-r3.ebuild10
-rw-r--r--net-www/mozilla/mozilla-1.1_beta.ebuild6
3 files changed, 15 insertions, 7 deletions
diff --git a/net-www/mozilla/ChangeLog b/net-www/mozilla/ChangeLog
index 461dc4c554e2..7e3919082d66 100644
--- a/net-www/mozilla/ChangeLog
+++ b/net-www/mozilla/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/mozilla
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.30 2002/07/30 00:14:55 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.31 2002/07/30 18:30:13 azarah Exp $
+
+ 30 Jul 2002; Martin Schlemmer <azarah@gentoo.org> mozilla-{1.0-r3,1.1_beta} :
+
+ Some gcc-3 fixes for pentium 4.
*mozilla-1.1_beta (30 Jul 2002)
diff --git a/net-www/mozilla/mozilla-1.0-r3.ebuild b/net-www/mozilla/mozilla-1.0-r3.ebuild
index 7753f8ca43f6..1dbcaca201c2 100644
--- a/net-www/mozilla/mozilla-1.0-r3.ebuild
+++ b/net-www/mozilla/mozilla-1.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.0-r3.ebuild,v 1.6 2002/07/25 01:16:08 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.0-r3.ebuild,v 1.7 2002/07/30 18:30:13 azarah Exp $
# NOTE: to build without the mail and news component: export NO_MAIL="YES"
@@ -181,9 +181,11 @@ src_compile() {
# Currently gcc-3.1.1 dont work well if we specify "-march"
# and other optimizations
[ -z "${CC}" ] && CC=gcc
- if [ "`${CC} -dumpversion`" = "3.1.1" ] ; then
- export CFLAGS=""
- export CXXFLAGS=""
+ if [ "`${CC} -dumpversion`" = "3.1.1" ] || \
+ [ "`${CC} -dumpversion`" = "3.2" ]
+ then
+ export CFLAGS="${CFLAGS/pentium4/pentium3}"
+ export CXXFLAGS="${CFLAGS/pentium4/pentium3}"
fi
# Crashes on start when compiled with -fomit-frame-pointer
diff --git a/net-www/mozilla/mozilla-1.1_beta.ebuild b/net-www/mozilla/mozilla-1.1_beta.ebuild
index c054ba89e637..3d801834234b 100644
--- a/net-www/mozilla/mozilla-1.1_beta.ebuild
+++ b/net-www/mozilla/mozilla-1.1_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.1_beta.ebuild,v 1.5 2002/07/30 00:14:55 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.1_beta.ebuild,v 1.6 2002/07/30 18:30:13 azarah Exp $
# NOTE: to build without the mail and news component: export NO_MAIL="YES"
inherit makeedit
@@ -177,7 +177,9 @@ src_compile() {
# Currently gcc-3.1.1 dont work well if we specify "-march"
# and other optimizations for pentium4.
[ -z "${CC}" ] && CC=gcc
- if [ "`${CC} -dumpversion`" = "3.1.1" ] ; then
+ if [ "`${CC} -dumpversion`" = "3.1.1" ] || \
+ [ "`${CC} -dumpversion`" = "3.2" ]
+ then
export CFLAGS="${CFLAGS/pentium4/pentium3}"
export CXXFLAGS="${CXXFLAGS/pentium4/pentium3}"
fi