summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-07-28 06:58:38 +0000
committerTravis Tilley <lv@gentoo.org>2004-07-28 06:58:38 +0000
commitf730a9da650e03c39234f97b08fe415ac99baa6e (patch)
tree11e2a371a090a05031191fc774f7eb370deb487e /net-www/mozilla-firefox
parentversion bump. 0.4.0 - x86 stable. Removed old version. (Manifest recommit) (diff)
downloadgentoo-2-f730a9da650e03c39234f97b08fe415ac99baa6e.tar.gz
gentoo-2-f730a9da650e03c39234f97b08fe415ac99baa6e.tar.bz2
gentoo-2-f730a9da650e03c39234f97b08fe415ac99baa6e.zip
added a patch that fixes a 64bit specific autocomplete crash
Diffstat (limited to 'net-www/mozilla-firefox')
-rw-r--r--net-www/mozilla-firefox/ChangeLog7
-rw-r--r--net-www/mozilla-firefox/files/firefox-0.9-nsFormHistory-crash-fix.patch47
-rw-r--r--net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild6
3 files changed, 58 insertions, 2 deletions
diff --git a/net-www/mozilla-firefox/ChangeLog b/net-www/mozilla-firefox/ChangeLog
index 2c1757544028..097b79d20a19 100644
--- a/net-www/mozilla-firefox/ChangeLog
+++ b/net-www/mozilla-firefox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mozilla-firefox
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.51 2004/07/20 01:39:33 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.52 2004/07/28 06:58:38 lv Exp $
+
+ 28 Jul 2004; Travis Tilley <lv@gentoo.org>
+ +files/firefox-0.9-nsFormHistory-crash-fix.patch,
+ mozilla-firefox-0.9.1.ebuild:
+ added a patch that fixes a 64bit specific autocomplete crash
19 Jul 2004; Travis Tilley <lv@gentoo.org> mozilla-firefox-0.9.1.ebuild:
stable on amd64
diff --git a/net-www/mozilla-firefox/files/firefox-0.9-nsFormHistory-crash-fix.patch b/net-www/mozilla-firefox/files/firefox-0.9-nsFormHistory-crash-fix.patch
new file mode 100644
index 000000000000..afd4e1691689
--- /dev/null
+++ b/net-www/mozilla-firefox/files/firefox-0.9-nsFormHistory-crash-fix.patch
@@ -0,0 +1,47 @@
+Index: toolkit/components/satchel/src/nsFormHistory.cpp
+===================================================================
+RCS file: /cvsroot/mozilla/toolkit/components/satchel/src/nsFormHistory.cpp,v
+retrieving revision 1.13
+diff -u -9 -p -w -r1.13 nsFormHistory.cpp
+--- toolkit/components/satchel/src/nsFormHistory.cpp 17 Jun 2004 00:13:16 -0000 1.13
++++ toolkit/components/satchel/src/nsFormHistory.cpp 24 Jun 2004 06:56:29 -0000
+@@ -734,35 +734,38 @@ nsFormHistory::AutoCompleteSearch(const
+ if (RowMatch(row, aInputName, aInputValue, &value)) {
+ matchingRows.AppendElement(row);
+ matchingValues.AppendElement(value);
+ }
+ } while (row);
+
+ // Turn auto array into flat array for quick sort, now that we
+ // know how many items there are
+ PRUint32 count = matchingRows.Count();
++
++ if (count > 0) {
+ PRUint32* items = new PRUint32[count];
+ PRUint32 i;
+ for (i = 0; i < count; ++i)
+ items[i] = i;
+
+- NS_QuickSort(items, count, sizeof(nsIMdbRow*),
++ NS_QuickSort(items, count, sizeof(PRUint32),
+ SortComparison, &matchingValues);
+
+ for (i = 0; i < count; ++i) {
+ // Place the sorted result into the autocomplete result
+ result->AddRow((nsIMdbRow *)matchingRows[items[i]]);
+
+ // Free up these strings we owned.
+ delete (PRUnichar *) matchingValues[i];
+ }
+
+ delete[] items;
++ }
+
+ PRUint32 matchCount;
+ result->GetMatchCount(&matchCount);
+ if (matchCount > 0) {
+ result->SetSearchResult(nsIAutoCompleteResult::RESULT_SUCCESS);
+ result->SetDefaultIndex(0);
+ } else {
+ result->SetSearchResult(nsIAutoCompleteResult::RESULT_NOMATCH);
+ result->SetDefaultIndex(-1);
diff --git a/net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild b/net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild
index 5374ca1d38bf..64cc46f2ed22 100644
--- a/net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild
+++ b/net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild,v 1.5 2004/07/20 01:39:33 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild,v 1.6 2004/07/28 06:58:38 lv Exp $
inherit makeedit flag-o-matic gcc nsplugins eutils mozilla-launcher
@@ -51,6 +51,10 @@ src_unpack() {
# alpha stubs patch from lfs project.
# <taviso@gentoo.org> (26 Jun 2003)
use alpha && epatch ${FILESDIR}/mozilla-1.3-alpha-stubs.patch
+
+ # this patch fixes upstream bug 248442 "Crash in form autocomplete
+ # (64-bit arch only)".
+ epatch ${FILESDIR}/firefox-0.9-nsFormHistory-crash-fix.patch
}
src_compile() {