summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2005-01-07 19:39:38 +0000
committerMichael Stewart <vericgar@gentoo.org>2005-01-07 19:39:38 +0000
commit22a9c19dee7aaaa59d32f1d7acb72fa31aed60ae (patch)
tree0a3d030aa333d67834a951c65fa58ba7ad1f2d2a /net-www/mod_throttle/mod_throttle-3.1.2-r2.ebuild
parentApache herd package refresh (Manifest recommit) (diff)
downloadgentoo-2-22a9c19dee7aaaa59d32f1d7acb72fa31aed60ae.tar.gz
gentoo-2-22a9c19dee7aaaa59d32f1d7acb72fa31aed60ae.tar.bz2
gentoo-2-22a9c19dee7aaaa59d32f1d7acb72fa31aed60ae.zip
Apache herd package refresh
Diffstat (limited to 'net-www/mod_throttle/mod_throttle-3.1.2-r2.ebuild')
-rw-r--r--net-www/mod_throttle/mod_throttle-3.1.2-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-www/mod_throttle/mod_throttle-3.1.2-r2.ebuild b/net-www/mod_throttle/mod_throttle-3.1.2-r2.ebuild
new file mode 100644
index 000000000000..70ea3a3e2e0e
--- /dev/null
+++ b/net-www/mod_throttle/mod_throttle-3.1.2-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_throttle/mod_throttle-3.1.2-r2.ebuild,v 1.1 2005/01/07 19:39:38 vericgar Exp $
+
+inherit apache-module
+
+# test target in Makefile isn't sane
+RESTRICT="maketest"
+
+MY_PV=${PV//./}
+
+DESCRIPTION="Bandwidth and request throttling for Apache"
+HOMEPAGE="http://www.snert.com/Software/mod_throttle/"
+
+KEYWORDS="~x86 ~sparc ~ppc"
+SRC_URI="http://www.snert.com/Software/${PN}/${PN}${MY_PV}.tgz"
+DEPEND=""
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+
+APACHE1_MOD_CONF="10_${PN}"
+APACHE1_MOD_DEFINE="THROTTLE"
+
+need_apache1
+
+src_install() {
+
+ apache1_src_install
+
+ sed 's/Img\///g' < index.shtml > index.html
+ dodoc CHANGES.txt LICENSE.txt
+ dohtml -r index.html Img/
+
+}