summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-04-22 22:20:49 +0000
committerChuck Short <zul@gentoo.org>2004-04-22 22:20:49 +0000
commit1bf88b853130361a0697a777c6917eec00ffb687 (patch)
tree512e5657de7370408597340139cb91754665fc7f /net-www/mod_mp3
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-1bf88b853130361a0697a777c6917eec00ffb687.tar.gz
gentoo-2-1bf88b853130361a0697a777c6917eec00ffb687.tar.bz2
gentoo-2-1bf88b853130361a0697a777c6917eec00ffb687.zip
Version bump, closes #41674.
Diffstat (limited to 'net-www/mod_mp3')
-rw-r--r--net-www/mod_mp3/ChangeLog7
-rw-r--r--net-www/mod_mp3/Manifest2
-rw-r--r--net-www/mod_mp3/files/digest-mod_mp3-0.401
-rw-r--r--net-www/mod_mp3/mod_mp3-0.40.ebuild58
4 files changed, 67 insertions, 1 deletions
diff --git a/net-www/mod_mp3/ChangeLog b/net-www/mod_mp3/ChangeLog
index 8228844f5240..74c9e570fb14 100644
--- a/net-www/mod_mp3/ChangeLog
+++ b/net-www/mod_mp3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_mp3
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/ChangeLog,v 1.12 2004/04/05 00:39:18 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/ChangeLog,v 1.13 2004/04/22 22:20:49 zul Exp $
+
+*mod_mp3-0.40 (22 Apr 2004)
+
+ 22 Apr 2004; Chuck Short <zul@gentoo.org> mod_mp3-0.40.ebuild:
+ Version bump, closes #41674.
04 Apr 2004; Chuck Short <zul@gentoo.org> metadata.xml,
mod_mp3-0.35-r1.ebuild, mod_mp3-0.35-r2.ebuild:
diff --git a/net-www/mod_mp3/Manifest b/net-www/mod_mp3/Manifest
index 4effffd35b4e..8fc4764037b4 100644
--- a/net-www/mod_mp3/Manifest
+++ b/net-www/mod_mp3/Manifest
@@ -1,9 +1,11 @@
MD5 165775de86d0f4775522cc9c20fea3f5 mod_mp3-0.35-r2.ebuild 1475
MD5 02bffa09e25e56566b6291da7d6e1941 mod_mp3-0.39.ebuild 1576
+MD5 ba6873f26cf7406dd755bf74a1bdbee3 mod_mp3-0.40.ebuild 1578
MD5 4a9919478b5d4f55ad02cc47f09de7b3 mod_mp3-0.35-r1.ebuild 1362
MD5 7d2be0dea6ae131e87a0c5aa243005f9 ChangeLog 1182
MD5 d2da0e45d7e39184d1cb7abbe3879086 metadata.xml 159
MD5 eed7a5bfc98ac86ce87a0e8acc8cc63d files/digest-mod_mp3-0.39 63
+MD5 a87aa3881f9296ed5334e2bccf010ab1 files/digest-mod_mp3-0.40 63
MD5 e00c3a323638f519dda1003c198d0c0f files/mod_mp3.conf 314
MD5 8a7822e7dc0ef7f482a9eea2f2dc7f99 files/digest-mod_mp3-0.35-r1 63
MD5 8a7822e7dc0ef7f482a9eea2f2dc7f99 files/digest-mod_mp3-0.35-r2 63
diff --git a/net-www/mod_mp3/files/digest-mod_mp3-0.40 b/net-www/mod_mp3/files/digest-mod_mp3-0.40
new file mode 100644
index 000000000000..040708f82bae
--- /dev/null
+++ b/net-www/mod_mp3/files/digest-mod_mp3-0.40
@@ -0,0 +1 @@
+MD5 a36b25ee4db268df45a03231993e718d mod_mp3-0.40.tar.gz 55064
diff --git a/net-www/mod_mp3/mod_mp3-0.40.ebuild b/net-www/mod_mp3/mod_mp3-0.40.ebuild
new file mode 100644
index 000000000000..06ed19903813
--- /dev/null
+++ b/net-www/mod_mp3/mod_mp3-0.40.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/mod_mp3-0.40.ebuild,v 1.1 2004/04/22 22:20:49 zul Exp $
+
+IUSE="mysql postgres"
+
+DESCRIPTION="Module for turning Apache into an MP3 or Ogg streaming server"
+HOMEPAGE="http://media.tangent.org/"
+KEYWORDS="~x86 ~sparc"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://software.tangent.org/download/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ =net-www/apache-1*
+ dev-lang/perl
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ postgres? ( dev-db/postgresql )"
+
+LICENSE="as-is"
+SLOT="0"
+
+src_compile() {
+ local myconf
+ use mysql && myconf="${myconf} --with-mysql"
+ use postgres && myconf="${myconf} --with-postgres"
+ ./configure ${myconf} || die
+ make clean
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe src/mod_mp3.so
+
+ dodoc CONTRIBUTORS MANIFEST TODO ChangeLog LICENSE README VERSION
+ dodoc support/{faq.pod,mp3_with_mysql.conf,mysql_schema,pgsql_schema}
+ dohtml faq.html
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_mp3.conf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/mod_mp3.so mod_mp3.c mp3_module \
+ define=MP3 addconf=conf/addon-modules/mod_mp3.conf
+ :;
+}