summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-11-28 20:43:41 +0000
committerDonny Davies <woodchip@gentoo.org>2002-11-28 20:43:41 +0000
commit2716a0fa80df6033d10ea02cdf697c785f6e1296 (patch)
tree2dd3318a3f5a225ee94fecf5fc93660d49d137af /net-www/mod_layout
parentnew Apache2 mod (diff)
downloadgentoo-2-2716a0fa80df6033d10ea02cdf697c785f6e1296.tar.gz
gentoo-2-2716a0fa80df6033d10ea02cdf697c785f6e1296.tar.bz2
gentoo-2-2716a0fa80df6033d10ea02cdf697c785f6e1296.zip
new Apache2 mod
Diffstat (limited to 'net-www/mod_layout')
-rw-r--r--net-www/mod_layout/ChangeLog8
-rw-r--r--net-www/mod_layout/files/15_mod_layout.conf150
-rw-r--r--net-www/mod_layout/files/digest-mod_layout-4.0.1a1
-rw-r--r--net-www/mod_layout/files/mod_layout-4.0.1a-register.patch19
-rw-r--r--net-www/mod_layout/mod_layout-4.0.1a.ebuild34
5 files changed, 212 insertions, 0 deletions
diff --git a/net-www/mod_layout/ChangeLog b/net-www/mod_layout/ChangeLog
new file mode 100644
index 000000000000..7c871d086da9
--- /dev/null
+++ b/net-www/mod_layout/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-www/mod_layout
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_layout/ChangeLog,v 1.1 2002/11/28 20:40:27 woodchip Exp $
+
+*mod_layout-4.0.1a (28 Nov 2002)
+
+ 28 Nov 2002; Donny Davies <woodchip@gentoo.org> :
+ Initial import; created by me.
diff --git a/net-www/mod_layout/files/15_mod_layout.conf b/net-www/mod_layout/files/15_mod_layout.conf
new file mode 100644
index 000000000000..68691e5c7213
--- /dev/null
+++ b/net-www/mod_layout/files/15_mod_layout.conf
@@ -0,0 +1,150 @@
+<IfDefine LAYOUT>
+ <IfModule !mod_layout.c>
+ LoadModule layout_module extramodules/mod_layout.so
+ </IfModule>
+</IfDefine>
+
+<IfModule mod_layout.c>
+
+<Location _REPLACE_ME_>
+AddOutputFilter LAYOUT html
+
+# This directives makes sure that all Layout headers and footers
+# get Cache-Control: no-cache methods in all situations. This
+# directive either takes On or Off."
+# LayoutCacheNeeded
+
+# A URI which prints the header contents.
+LayoutHeader "<p><b>This is the LayoutHeader</b> (included from the config file)</p>"
+
+# A URI which prints the footer contents.
+LayoutFooter "<p><b>This is the LayoutFooter</b> (included from the config file)</p>"
+
+# Add a layout to be inserted when a tag is found, this takes two
+# options, with a third optional parameter. The first is a pattern,
+# the second is the layout and the third is how the layout should be
+# inserts (either prepend, append, or replace). The default is to
+# replace.
+Layout "<-- replace_me -->" "<p>Visit: <a href=http://www.gentoo.org/>Gentoo Linux</a></p>" replace
+
+# Enter either a mime type or a handler type. This type will then be
+# handled by mod_layout.
+# LayoutHandler
+
+# Enter a URI that should be ignored, regular expressions are allowed.
+# LayoutIgnoreURI
+
+# Enter a URI that should be ignored by the header, regular expressions
+# are allowed.
+# LayoutIgnoreHeaderURI
+
+# Enter a URI that should be ignored by the HTTPHeader, regular
+# expressions are allowed.
+# LayoutIgnoreHTTPHeaderURI
+
+# Enter a URI that should be ignored by the footer, regular expressions
+# are allowed.
+# LayoutIgnoreFooterURI
+
+# This can either be On or Off (default it Off). It places HTML comments
+# in the outbound text describing when and where mod_layout has been
+# inserting text.
+LayoutComment On
+
+# This can either be On or Off (default it Off). This is both
+# experimental and probably quite broke.
+# LayoutProxy
+
+# This can either be On or Off (default it On). When off the original
+# document is not displayed.
+# LayoutDisplayOriginal
+
+# Turns On (default) or Off a list of standard types to handle.
+# LayoutDefaultHandlers
+
+# This takes a SSI style timme format that can be used to change the
+# output by mod_layout's internal TIME environmental variables that
+# it introduces.
+# LayoutTimeFormat
+
+# Takes a URI to call for the HTTP Header.
+# LayoutHTTPHeader
+
+# Specify handlers that mod_layout should produce HTTP headers for.
+# LayoutHTTPOverrideHandler
+
+# Specify URI's that mod_layout should produce HTTP headers for.
+# LayoutHTTPOverrideURI
+
+# This takes no arguments. If found it will turn off the footer.
+# LayoutFooterOff
+
+# This takes no arguments. If found it will turn off the header.
+# LayoutHeaderOff
+
+# This takes no arguments. If found it will turn off the http header.
+# LayoutHTTPHeaderOff
+
+# Turns on and off asynchronous POSTs (AKA everything can see the post
+# data).
+# LayoutPostAsync
+
+# This moves the default cache from /tmp to another directory(or a
+# RAM disk).
+# LayoutCache
+
+# Turning this On or Off afffects whether or not headers and footers
+# are appended when creating subsections.
+# LayoutAppend
+
+# Turning this on and off will tell mod_layout to attempt to resolve
+# content (do a merger of the footer, body and header text
+# LayoutMerge
+
+# Use this to change the default begin tag to use during merges (the
+# default string is \<HTML>\
+# LayoutMergeBeginTag
+
+# Use this to change the default end tag to use during merges (the
+# default string is \<\\HTML>\
+# LayoutMergeEndTag
+
+# Use this to change the default end tag to use during merges (the
+# default string is \<\\HTML>\
+# LayoutHeaderAppend
+
+# Use this to change the default end tag to use during merges (the
+# default string is \<\\HTML>\
+# LayoutFooterAppend
+
+# When enabled (it takes on and off flags) mod_layout will not try
+# to wrap any errors. Merge must be enabled for this to work. The
+# default for this is off.
+# LayoutMergeErrorIgnore
+
+# If this tag is found during a merge, no footer or header will be
+# inserted into the document
+# LayoutIgnoreTag
+
+# If this tag is found during a merge, no footer will be inserted
+# into the document
+# LayoutIgnoreTagFooter
+
+# If this tag is found during a merge, no header will be inserted
+# into the document
+# LayoutIgnoreTagHeader
+
+# This turns on mod_layout's own text/html and text/plain handler
+# LayoutHTMLHandler
+
+# If this is enabled and you are doing a merge, the tags used for the
+# merge will be replaced.
+# LayoutReplaceTags
+
+# If you want applications to do notes (a set of directives to control
+# actions inside apache).
+# LayoutNotes
+
+</Location>
+
+</IfModule>
diff --git a/net-www/mod_layout/files/digest-mod_layout-4.0.1a b/net-www/mod_layout/files/digest-mod_layout-4.0.1a
new file mode 100644
index 000000000000..63f3fb3dcbe8
--- /dev/null
+++ b/net-www/mod_layout/files/digest-mod_layout-4.0.1a
@@ -0,0 +1 @@
+MD5 253c4a2c0f44b788648fc7564f246e87 mod_layout-4.0.1a.tar.gz 12674
diff --git a/net-www/mod_layout/files/mod_layout-4.0.1a-register.patch b/net-www/mod_layout/files/mod_layout-4.0.1a-register.patch
new file mode 100644
index 000000000000..989d007ea54a
--- /dev/null
+++ b/net-www/mod_layout/files/mod_layout-4.0.1a-register.patch
@@ -0,0 +1,19 @@
+--- mod_layout.c 2002-10-01 06:23:56.000000000 +0000
++++ mod_layout.c.oden 2002-10-22 20:09:45.000000000 +0000
+@@ -536,7 +536,16 @@
+ return NULL;
+ }
+
++
++static int layout_init_handler(apr_pool_t *p, apr_pool_t *plog,
++ apr_pool_t *ptemp, server_rec *s)
++{
++ ap_add_version_component(p, "mod_layout/4.0.1a");
++ return OK;
++}
++
+ static void layout_register_hooks(apr_pool_t *p) {
++ ap_hook_post_config(layout_init_handler, NULL, NULL, APR_HOOK_MIDDLE);
+ ap_register_output_filter("LAYOUT", layout_filter, NULL, AP_FTYPE_CONTENT_SET);
+ }
+
diff --git a/net-www/mod_layout/mod_layout-4.0.1a.ebuild b/net-www/mod_layout/mod_layout-4.0.1a.ebuild
new file mode 100644
index 000000000000..d59c128c0542
--- /dev/null
+++ b/net-www/mod_layout/mod_layout-4.0.1a.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_layout/mod_layout-4.0.1a.ebuild,v 1.1 2002/11/28 20:40:27 woodchip Exp $
+
+inherit eutils
+
+DESCRIPTION="An Apache2 DSO module for adding custom headers and/or footers"
+HOMEPAGE="http://software.tangent.org/"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://software.tangent.org/download/${P}.tar.gz"
+DEPEND="=net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} || die; cd ${S} || die
+ epatch ${FILESDIR}/mod_layout-4.0.1a-register.patch
+}
+
+src_compile() {
+ apxs2 -c mod_layout.c utility.c layout.c || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/${PN}.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/15_mod_layout.conf
+ dodoc ${FILESDIR}/15_mod_layout.conf
+ #thats all the docs there is right now!
+}