summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-12-04 17:50:19 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-12-04 17:50:19 +0000
commitad724c1b64ecd41de072695ca50f8c89ba8b4ced (patch)
tree756258a9619e91972ab81e633489a131add5d835 /net-www/horde-turba
parentfixing coreutils chown. (diff)
downloadgentoo-2-ad724c1b64ecd41de072695ca50f8c89ba8b4ced.tar.gz
gentoo-2-ad724c1b64ecd41de072695ca50f8c89ba8b4ced.tar.bz2
gentoo-2-ad724c1b64ecd41de072695ca50f8c89ba8b4ced.zip
added webapps-apache
Diffstat (limited to 'net-www/horde-turba')
-rw-r--r--net-www/horde-turba/ChangeLog5
-rw-r--r--net-www/horde-turba/Manifest8
-rw-r--r--net-www/horde-turba/horde-turba-1.2.1.ebuild47
3 files changed, 29 insertions, 31 deletions
diff --git a/net-www/horde-turba/ChangeLog b/net-www/horde-turba/ChangeLog
index 706cf30fca69..e3a99f9611b7 100644
--- a/net-www/horde-turba/ChangeLog
+++ b/net-www/horde-turba/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/horde-turba
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-turba/ChangeLog,v 1.7 2003/10/18 19:03:46 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-turba/ChangeLog,v 1.8 2003/12/04 17:50:14 mholzer Exp $
+
+ 04 Dec 2003; Martin Holzer <mholzer@gentoo.org> horde-turba-1.2.1.ebuild:
+ added webapps-apache
19 Oct 2003; Martin Holzer <mholzer@gentoo.org> horde-turba-1.2.1.ebuild:
marked x86 stable.
diff --git a/net-www/horde-turba/Manifest b/net-www/horde-turba/Manifest
index 05afad0ca855..e06744df97cc 100644
--- a/net-www/horde-turba/Manifest
+++ b/net-www/horde-turba/Manifest
@@ -1,7 +1,7 @@
-MD5 c2f449e87fe1dcae3c73d0a0abf820c1 ChangeLog 891
MD5 7992e6996cbdbeaf5150c6a6029ce1db horde-turba-1.1.ebuild 2420
+MD5 f59b3bb521c1810587d696cd144e2ca0 horde-turba-1.2.1.ebuild 1658
MD5 e2e1b601a163302d2354571982351b43 horde-turba-1.2.ebuild 1924
-MD5 8da2b1bec3450d41c83550306e590600 horde-turba-1.2.1.ebuild 1935
-MD5 f3018d21fa59ceba6a6b2062f16734ed files/digest-horde-turba-1.1 62
-MD5 10da92ad2d67b2b5393a1ce281e74a85 files/digest-horde-turba-1.2 61
+MD5 00a82ee5bf2da42ba0e3005b616c0434 ChangeLog 991
MD5 c040f6dc39be9087c0815f2eb07dbf27 files/digest-horde-turba-1.2.1 63
+MD5 10da92ad2d67b2b5393a1ce281e74a85 files/digest-horde-turba-1.2 61
+MD5 f3018d21fa59ceba6a6b2062f16734ed files/digest-horde-turba-1.1 62
diff --git a/net-www/horde-turba/horde-turba-1.2.1.ebuild b/net-www/horde-turba/horde-turba-1.2.1.ebuild
index 0c6898e5c1ef..5dbdb7a9d256 100644
--- a/net-www/horde-turba/horde-turba-1.2.1.ebuild
+++ b/net-www/horde-turba/horde-turba-1.2.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-turba/horde-turba-1.2.1.ebuild,v 1.2 2003/10/18 19:03:46 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-turba/horde-turba-1.2.1.ebuild,v 1.3 2003/12/04 17:50:14 mholzer Exp $
+
+inherit webapp-apache
DESCRIPTION="Turba ${PV} is the Horde address book / contact management program"
HOMEPAGE="http://www.horde.org"
@@ -14,19 +16,12 @@ RDEPEND=">=net-www/horde-2.2.4"
IUSE=""
S=${WORKDIR}/${MY_P}
-find_http_root() {
- export HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
- if [ -z "${HTTPD_ROOT}" ]; then
- eerror "HTTPD_ROOT is null! Using defaults."
- eerror "You probably want to check /etc/passwd"
- HTTPD_ROOT="/home/httpd/htdocs"
- fi
-
- export REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
- [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
-}
+webapp-detect || NO_WEBSERVER=1
pkg_setup() {
+ webapp-pkg_setup "${NO_WEBSERVER}"
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}."
+
GREPSQL=`grep sql /var/db/pkg/dev-php/mod_php*/USE`
GREPLDAP=`grep ldap /var/db/pkg/dev-php/mod_php*/USE`
if [ "${GREPSQL}" != "" ] || [ "${GREPLDAP}" != "" ] ; then
@@ -35,31 +30,31 @@ pkg_setup() {
eerror "Missing SQL or LDAP support in mod_php !"
die "aborting..."
fi
- find_http_root
+
+ export REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
+ [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
+
[ -f ${REGISTRY} ] || die "${REGISTRY} not found"
}
src_install () {
- # detecting apache usergroup
- GID=`grep apache /etc/group |cut -d: -f3`
- if [ -z "${GID}" ]; then
- einfo "Using default GID of 81 for Apache"
- GID=81
- fi
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/horde/turba
- find_http_root
dodoc COPYING README docs/*
rm -rf COPYING README docs
- dodir ${HTTPD_ROOT}/horde/turba
- cp -r . ${D}/${HTTPD_ROOT}/horde/turba
+
+ dodir ${destdir}
+ cp -r . ${D}${destdir}
+ cd ${D}/${HTTPD_ROOT}/horde
# protecting files
- chown -R apache.${GID} ${D}/${HTTPD_ROOT}/horde/turba
- find ${D}/${HTTPD_ROOT}/horde/turba/ -type f -exec chmod 0640 {} \;
- find ${D}/${HTTPD_ROOT}/horde/turba/ -type d -exec chmod 0750 {} \;
+ chown -R ${HTTPD_USER}:${HTTPD_GROUP} turba
+ find ${D}/${destdir} -type f -exec chmod 0640 {} \;
+ find ${D}/${destdir} -type d -exec chmod 0750 {} \;
}
pkg_postinst() {
find_http_root
- einfo "Please read ${HTTPD_ROOT}/horde/turba/docs/INSTALL !"
+ einfo "Please read /usr/share/doc/${PF}/INSTALL.gz !"
}