summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nall <nall@gentoo.org>2003-03-18 03:25:23 +0000
committerJon Nall <nall@gentoo.org>2003-03-18 03:25:23 +0000
commit5c38dbb9c48829aa6c1f731f670fa787481aaf4c (patch)
tree3e72b524682eb3558301a45f6b5153eb5c486959 /net-www/gplflash/files
parentAdded ~sparc to keywords. (diff)
downloadgentoo-2-5c38dbb9c48829aa6c1f731f670fa787481aaf4c.tar.gz
gentoo-2-5c38dbb9c48829aa6c1f731f670fa787481aaf4c.tar.bz2
gentoo-2-5c38dbb9c48829aa6c1f731f670fa787481aaf4c.zip
Fixed issues with static/shared libs; works on PPC now
Diffstat (limited to 'net-www/gplflash/files')
-rw-r--r--net-www/gplflash/files/digest-gplflash-0.4.10-r21
-rw-r--r--net-www/gplflash/files/gplflash-0.4.10-ppc.diff56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-www/gplflash/files/digest-gplflash-0.4.10-r2 b/net-www/gplflash/files/digest-gplflash-0.4.10-r2
new file mode 100644
index 000000000000..559fd82f09cb
--- /dev/null
+++ b/net-www/gplflash/files/digest-gplflash-0.4.10-r2
@@ -0,0 +1 @@
+MD5 1473f085c599d8076fa866cd91e11598 flash-0.4.10.tgz 358995
diff --git a/net-www/gplflash/files/gplflash-0.4.10-ppc.diff b/net-www/gplflash/files/gplflash-0.4.10-ppc.diff
new file mode 100644
index 000000000000..18107471956b
--- /dev/null
+++ b/net-www/gplflash/files/gplflash-0.4.10-ppc.diff
@@ -0,0 +1,56 @@
+--- Jpeg/Makefile.orig 2003-03-17 21:02:31.000000000 -0600
++++ Jpeg/Makefile 2003-03-17 21:02:37.000000000 -0600
+@@ -20,7 +20,7 @@
+ mandir = $(prefix)/man/man$(manext)
+
+ # You may need to adjust these cc options:
+-CFLAGS= -O2 -I$(srcdir)
++CFLAGS= -O2 -I$(srcdir) -shared -fPIC
+ # Generally, we recommend defining any configuration symbols in jconfig.h,
+ # NOT via -D switches here.
+ # However, any special defines for ansi2knr.c may be included here:
+--- Lib/Makefile.orig 2003-03-17 21:03:38.000000000 -0600
++++ Lib/Makefile 2003-03-17 21:03:17.000000000 -0600
+@@ -1,6 +1,6 @@
+-CPPFLAGS=-I../Jpeg -I../Zlib
++CPPFLAGS=-I../Jpeg -I../Zlib
+ # Comment out the following line if you use egcs :
+-CXXFLAGS=-O3 -Wall -fno-rtti -fno-exceptions
++CXXFLAGS=-O3 -Wall -fno-rtti -fno-exceptions -shared -fPIC
+
+ INCLUDES= adpcm.h cxform.h graphic.h script.h sqrt.h\
+ bitmap.h displaylist.h matrix.h shape.h swf.h\
+--- Zlib/Makefile.orig 2003-03-17 21:03:50.000000000 -0600
++++ Zlib/Makefile 2003-03-17 21:04:07.000000000 -0600
+@@ -2,7 +2,7 @@
+ # Copyright (C) 1995-1998 Jean-loup Gailly.
+ # For conditions of distribution and use, see copyright notice in zlib.h
+
+-CFLAGS=-O3 -DHAVE_UNISTD_H -DUSE_MMAP
++CFLAGS=-O3 -DHAVE_UNISTD_H -DUSE_MMAP -shared -fPIC
+
+ CPP=$(CC) -E
+
+--- Plugin/Makefile.orig 2003-03-17 21:04:15.000000000 -0600
++++ Plugin/Makefile 2003-03-17 21:04:37.000000000 -0600
+@@ -33,9 +33,9 @@
+ # FreeBSD
+ #SHARED=-Bshareable
+ # Linux
+-SHARED=-shared
++SHARED=-shared -fPIC
+
+-CFLAGS= $(OPTIMIZER) $(PLUGIN_DEFINES) -I$(FLASH) -I/usr/X11R6/include
++CFLAGS= $(SHARED) $(OPTIMIZER) $(PLUGIN_DEFINES) -I$(FLASH) -I/usr/X11R6/include
+ LDFLAGS= $(FLASH)/libflash.a $(LIBCXX) ../Jpeg/libjpeg.a ../Zlib/libz.a
+
+ SRC= plugin.c npunix.c
+@@ -46,7 +46,7 @@
+ default all: $(SHAREDTARGET)
+
+ $(SHAREDTARGET): $(OBJ) $(FLASH)/libflash.a
+- $(LD) $(SHARED) -o $(SHAREDTARGET) $(OBJ) $(LDFLAGS)
++ $(CC) $(SHARED) -o $(SHAREDTARGET) $(OBJ) $(LDFLAGS)
+
+ plugin.o: $(FLASH)/flash.h
+