summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2003-01-08 19:45:05 +0000
committerMaik Schreiber <blizzy@gentoo.org>2003-01-08 19:45:05 +0000
commit8a322375099961443b661facc760ac21dca9c16b (patch)
treed5df85508662f1ea4f7a4e75e16e5521d73e7a28 /net-www/elinks
parentfixor (diff)
downloadgentoo-2-8a322375099961443b661facc760ac21dca9c16b.tar.gz
gentoo-2-8a322375099961443b661facc760ac21dca9c16b.tar.bz2
gentoo-2-8a322375099961443b661facc760ac21dca9c16b.zip
initial import (bug #13302)
Diffstat (limited to 'net-www/elinks')
-rw-r--r--net-www/elinks/ChangeLog9
-rw-r--r--net-www/elinks/elinks-0.4.1.ebuild87
-rw-r--r--net-www/elinks/files/digest-elinks-0.4.11
-rw-r--r--net-www/elinks/files/elinks.conf.bz2bin0 -> 4847 bytes
4 files changed, 97 insertions, 0 deletions
diff --git a/net-www/elinks/ChangeLog b/net-www/elinks/ChangeLog
new file mode 100644
index 000000000000..dc03140423e2
--- /dev/null
+++ b/net-www/elinks/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-www/elinks
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/elinks/ChangeLog,v 1.1 2003/01/08 19:45:05 blizzy Exp $
+
+*elinks-0.4.1 (08 Dec 2003)
+
+ 08 Dec 2003; Maik Schreiber <blizzy@gentoo.org> : Initial import (bug #13302).
+ Thanks to Maurizio Disimino <maurizio@iridium.aetheric.org> and mmc in
+ #gentoo-dev.
diff --git a/net-www/elinks/elinks-0.4.1.ebuild b/net-www/elinks/elinks-0.4.1.ebuild
new file mode 100644
index 000000000000..82159b28a31e
--- /dev/null
+++ b/net-www/elinks/elinks-0.4.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/elinks/elinks-0.4.1.ebuild,v 1.1 2003/01/08 19:45:05 blizzy Exp $
+
+DESCRIPTION="Advanced and well-established text-mode web browser"
+HOMEPAGE="http://elinks.or.cz"
+SRC_URI="http://elinks.or.cz/download/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ >=sys-apps/bzip2-1.0.2*
+ >=dev-libs/expat-1.95.4*
+ >=sys-apps/portage-2.0.45-r3
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ X? ( >=x11-base/xfree-4.2.1* )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ lua? ( >=dev-lang/lua-4.0 )
+ gpm? ( >=sys-libs/ncurses-5.2* >=sys-libs/gpm-1.20.0-r5 )"
+
+RDEPEND="virtual/glibc
+ >=sys-apps/bzip2-1.0.2*
+ >=dev-libs/expat-1.95.4*
+ >=sys-apps/gzip-1.3.3
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ lua? ( >=dev-lang/lua-4.0 )
+ gpm? ( >=sys-libs/ncurses-5.2* >=sys-libs/gpm-1.20.0-r5 )
+ X? ( >=x11-base/xfree-4.2.1* )"
+
+IUSE="gpm zlib ssl ipv6 X nls lua"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${WORKDIR}
+ bzcat ${FILESDIR}/elinks.conf.bz2 >elinks.conf
+}
+
+src_compile() {
+ if ! use nls; then
+ # Build with only english support
+ echo 'english' > intl/index.txt
+ cd intl && ./gen-intl && cd ${S}
+ fi
+
+ # NOTE about GNUTSL SSL support (from the README -- 25/12/2002)
+ # As GNUTLS is not yet 100% stable and its support in ELinks is not so well
+ # tested yet, it's recommended for users to give a strong preference to OpenSSL whenever possible.
+
+ econf `use_with gpm` \
+ `use_with zlib` \
+ `use_with ssl openssl` \
+ `use_with X x` \
+ `use_enable ipv6` \
+ `use_with lua` \
+ --enable-leds || die "configure problem"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ dobin src/elinks
+ doman elinks*.[0-9]
+
+ insopts -m 644 ; insinto /etc/elinks
+ doins ${WORKDIR}/elinks.conf
+ newins contrib/keybind-full.conf keybind-full.sample
+ newins contrib/keybind.conf keybind.conf.sample
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES THANKS TODO doc/*.*
+ docinto contrib ; dodoc contrib/{README,completion.tcsh,colws.diff,elinks[-.]vim*}
+ docinto contrib/lua ; dodoc contrib/lua/{*.lua,elinks-remote}
+ docinto contrib/conv ; dodoc contrib/conv/*.*
+}
+
+pkg_postinst() {
+ einfo "This ebuild provides a default config for Elinks."
+ einfo "Please check /etc/elinks/elinks.conf"
+ echo
+ einfo "You may want to convert your html.cfg and links.cfg of Links or older Elinks versions"
+ einfo "to the new Elinks elinks.conf using /usr/share/doc/${P}/contrib/conv/conf-links2elinks.pl"
+ echo
+ einfo "Please have a look at /etc/elinks/keybind-full.sample and"
+ einfo "/etc/elinks/keybind.conf.sample for some bindings examples."
+}
diff --git a/net-www/elinks/files/digest-elinks-0.4.1 b/net-www/elinks/files/digest-elinks-0.4.1
new file mode 100644
index 000000000000..76de73434370
--- /dev/null
+++ b/net-www/elinks/files/digest-elinks-0.4.1
@@ -0,0 +1 @@
+MD5 db8a21aeef9a717489e1f819f5a896f5 elinks-0.4.1.tar.bz2 757619
diff --git a/net-www/elinks/files/elinks.conf.bz2 b/net-www/elinks/files/elinks.conf.bz2
new file mode 100644
index 000000000000..ffcc6f18498e
--- /dev/null
+++ b/net-www/elinks/files/elinks.conf.bz2
Binary files differ