summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2009-01-07 15:09:31 +0000
committerRobert Buchholz <rbu@gentoo.org>2009-01-07 15:09:31 +0000
commit6f17d77b259b1e96dffd40f9dcdf84f6649a3586 (patch)
tree92e62be3a56632639529ea3ca339bf2b4a770701 /net-wireless
parentMarking ant-junit4-1.7.1 ppc64 for bug 252819 (diff)
downloadgentoo-2-6f17d77b259b1e96dffd40f9dcdf84f6649a3586.tar.gz
gentoo-2-6f17d77b259b1e96dffd40f9dcdf84f6649a3586.tar.bz2
gentoo-2-6f17d77b259b1e96dffd40f9dcdf84f6649a3586.zip
Version bump from obsolete version of the code to an actual release (bug
(Portage version: 2.1.6.4/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/iw/ChangeLog10
-rw-r--r--net-wireless/iw/files/iw-0.9.7-cflags.patch26
-rw-r--r--net-wireless/iw/files/iw-0.9.7-ldflags.patch34
-rw-r--r--net-wireless/iw/iw-0.9.7.ebuild31
-rw-r--r--net-wireless/iw/metadata.xml4
5 files changed, 104 insertions, 1 deletions
diff --git a/net-wireless/iw/ChangeLog b/net-wireless/iw/ChangeLog
index 3003b04e2601..86de103f06bc 100644
--- a/net-wireless/iw/ChangeLog
+++ b/net-wireless/iw/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-wireless/iw
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/iw/ChangeLog,v 1.1 2009/01/05 05:03:08 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/iw/ChangeLog,v 1.2 2009/01/07 15:09:31 rbu Exp $
+
+*iw-0.9.7 (07 Jan 2009)
+
+ 07 Jan 2009; Robert Buchholz <rbu@gentoo.org>
+ +files/iw-0.9.7-cflags.patch, +files/iw-0.9.7-ldflags.patch, metadata.xml,
+ +iw-0.9.7.ebuild:
+ Version bump from obsolete version of the code to an actual release (bug
+ #238879). Include patches to fix LDFLAGS and CFLAGS, both applied upstream.
*iw-0_p20080605 (05 Jan 2009)
diff --git a/net-wireless/iw/files/iw-0.9.7-cflags.patch b/net-wireless/iw/files/iw-0.9.7-cflags.patch
new file mode 100644
index 000000000000..6fbebd437c2b
--- /dev/null
+++ b/net-wireless/iw/files/iw-0.9.7-cflags.patch
@@ -0,0 +1,26 @@
+From da069ce18c72ec1bf2a15121a0aefb69a6756490 Mon Sep 17 00:00:00 2001
+From: Robert Buchholz <rbu@goodpoint.de>
+Date: Wed, 7 Jan 2009 15:46:13 +0100
+Subject: [PATCH] Do not set -O2 -g CFLAGS if CFLAGS are already defined (in the env).
+
+---
+ Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 8a97bae..5a0385b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -10,8 +10,8 @@ MKDIR ?= mkdir -p
+ INSTALL ?= install
+ CC ?= "gcc"
+
++CFLAGS ?= -O2 -g
+ CFLAGS += -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration `pkg-config --cflags libnl-1`
+-CFLAGS += -O2 -g
+ LIBS += `pkg-config --libs libnl-1`
+ NLVERSION = 1.0
+
+--
+1.6.0.4
+
diff --git a/net-wireless/iw/files/iw-0.9.7-ldflags.patch b/net-wireless/iw/files/iw-0.9.7-ldflags.patch
new file mode 100644
index 000000000000..9f876a58dd53
--- /dev/null
+++ b/net-wireless/iw/files/iw-0.9.7-ldflags.patch
@@ -0,0 +1,34 @@
+From 9b2e7e6e695370ae3d01c3f341f4ab9d8d13efcf Mon Sep 17 00:00:00 2001
+From: Mike Auty <mike.auty@gmail.com>
+Date: Fri, 12 Dec 2008 22:47:16 +0100
+Subject: [PATCH] allow compilation using --as-needed
+
+---
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index df59b51..8a97bae 100644
+--- a/Makefile
++++ b/Makefile
+@@ -12,7 +12,7 @@ CC ?= "gcc"
+
+ CFLAGS += -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration `pkg-config --cflags libnl-1`
+ CFLAGS += -O2 -g
+-LDFLAGS += `pkg-config --libs libnl-1`
++LIBS += `pkg-config --libs libnl-1`
+ NLVERSION = 1.0
+
+ OBJS = iw.o info.o phy.o interface.o station.o util.o mpath.o reg.o mesh.o genl.o
+@@ -42,7 +42,7 @@ version.h: version.sh
+
+ iw: $(OBJS)
+ @$(NQ) ' CC ' iw
+- $(Q)$(CC) $(LDFLAGS) $(OBJS) -o iw
++ $(Q)$(CC) $(LDFLAGS) $(OBJS) $(LIBS) -o iw
+
+ check:
+ $(Q)$(MAKE) all CC="REAL_CC=$(CC) CHECK=\"sparse -Wall\" cgcc"
+--
+1.6.0.4
+
diff --git a/net-wireless/iw/iw-0.9.7.ebuild b/net-wireless/iw/iw-0.9.7.ebuild
new file mode 100644
index 000000000000..c840aaeb692d
--- /dev/null
+++ b/net-wireless/iw/iw-0.9.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/iw/iw-0.9.7.ebuild,v 1.1 2009/01/07 15:09:31 rbu Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="nl80211-based configuration utility for wireless devices using the mac80211 kernel stack"
+HOMEPAGE="http://wireless.kernel.org/en/users/Documentation/iw"
+SRC_URI="http://wireless.kernel.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libnl
+ dev-util/pkgconfig"
+RDEPEND="dev-libs/libnl"
+
+CC=$(tc-getCC)
+LD=$(tc-getLD)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch "${FILESDIR}"/${P}-cflags.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Failed to install"
+}
diff --git a/net-wireless/iw/metadata.xml b/net-wireless/iw/metadata.xml
index ad08de8df302..ac9a945499dc 100644
--- a/net-wireless/iw/metadata.xml
+++ b/net-wireless/iw/metadata.xml
@@ -5,5 +5,9 @@
<email>rbu@gentoo.org</email>
<name>Robert Buchholz</name>
</maintainer>
+<maintainer>
+ <email>ikelos@gentoo.org</email>
+ <name>Mike Auty</name>
+</maintainer>
<herd>netmon</herd>
</pkgmetadata>