summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2009-04-15 21:45:22 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2009-04-15 21:45:22 +0000
commitbcdce612b5ebbae6022ad84b630fffa0938004c7 (patch)
treeb32c9c529e57650410a85cc3b85cc2b186bf2b9e /net-wireless/wpa_supplicant
parentamd64/x86 stable, bug #264832 (diff)
downloadgentoo-2-bcdce612b5ebbae6022ad84b630fffa0938004c7.tar.gz
gentoo-2-bcdce612b5ebbae6022ad84b630fffa0938004c7.tar.bz2
gentoo-2-bcdce612b5ebbae6022ad84b630fffa0938004c7.zip
Bumping to 0.6.9 and adding dbus service path fix
(Portage version: 2.2_rc30/cvs/Linux i686)
Diffstat (limited to 'net-wireless/wpa_supplicant')
-rw-r--r--net-wireless/wpa_supplicant/ChangeLog8
-rw-r--r--net-wireless/wpa_supplicant/files/dbus_path_fix.patch8
-rw-r--r--net-wireless/wpa_supplicant/metadata.xml5
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild237
4 files changed, 257 insertions, 1 deletions
diff --git a/net-wireless/wpa_supplicant/ChangeLog b/net-wireless/wpa_supplicant/ChangeLog
index 5db5b1c7553d..37809cfb9db7 100644
--- a/net-wireless/wpa_supplicant/ChangeLog
+++ b/net-wireless/wpa_supplicant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/wpa_supplicant
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.114 2009/03/30 16:29:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.115 2009/04/15 21:45:22 gurligebis Exp $
+
+*wpa_supplicant-0.6.9 (15 Apr 2009)
+
+ 15 Apr 2009; Bjarke Istrup Pedersen <gurligebis@gentoo.org>
+ +files/dbus_path_fix.patch, metadata.xml, +wpa_supplicant-0.6.9.ebuild:
+ Bumping to 0.6.9 and adding dbus service path fix
30 Mar 2009; Raúl Porcel <armin76@gentoo.org>
wpa_supplicant-0.5.7.ebuild, wpa_supplicant-0.5.8.ebuild,
diff --git a/net-wireless/wpa_supplicant/files/dbus_path_fix.patch b/net-wireless/wpa_supplicant/files/dbus_path_fix.patch
new file mode 100644
index 000000000000..e6348894cccd
--- /dev/null
+++ b/net-wireless/wpa_supplicant/files/dbus_path_fix.patch
@@ -0,0 +1,8 @@
+--- dbus-wpa_supplicant.service.old 2009-04-15 23:16:19.000000000 +0000
++++ dbus-wpa_supplicant.service 2009-04-15 23:16:29.000000000 +0000
+@@ -1,4 +1,4 @@
+ [D-BUS Service]
+ Name=fi.epitest.hostap.WPASupplicant
+-Exec=/sbin/wpa_supplicant -u
++Exec=/usr/sbin/wpa_supplicant -u
+ User=root
diff --git a/net-wireless/wpa_supplicant/metadata.xml b/net-wireless/wpa_supplicant/metadata.xml
index 53c6b5bf8ee2..eafa29d26321 100644
--- a/net-wireless/wpa_supplicant/metadata.xml
+++ b/net-wireless/wpa_supplicant/metadata.xml
@@ -1,10 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer>
+ <email>gurligebis@gentoo.org</email>
+ <name>Bjarke Istrup Pedersen</name>
+ </maintainer>
<herd>mobile</herd>
<use>
<flag name='gsm'>Add support for EAP-SIM authentication algorithm</flag>
<flag name='madwifi'>Add support for madwifi (Atheros chipset)</flag>
<flag name='ps3'>Add support for ps3 hypervisor driven gelic wifi</flag>
+ <flag name='wps'>Add support for Wi-Fi Protected Setup</flag>
</use>
</pkgmetadata>
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild
new file mode 100644
index 000000000000..98243fc8a88c
--- /dev/null
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild
@@ -0,0 +1,237 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild,v 1.1 2009/04/15 21:45:22 gurligebis Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs qt3 qt4
+
+DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
+HOMEPAGE="http://hostap.epitest.fi/wpa_supplicant/"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+LICENSE="|| ( GPL-2 BSD )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="dbus debug gnutls gsm madwifi ps3 qt3 qt4 readline ssl wps kernel_linux kernel_FreeBSD"
+
+DEPEND="dev-libs/libnl
+ dbus? ( sys-apps/dbus )
+ kernel_linux? (
+ gsm? ( sys-apps/pcsc-lite )
+ madwifi? ( ||
+ ( >net-wireless/madwifi-ng-tools-0.9.3
+ net-wireless/madwifi-old )
+ )
+ )
+ !kernel_linux? ( net-libs/libpcap )
+ qt4? ( x11-libs/qt-gui:4 )
+ !qt4? ( qt3? ( x11-libs/qt:3 ) )
+ readline? ( sys-libs/ncurses sys-libs/readline )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ !gnutls? ( !ssl? ( dev-libs/libtommath ) )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/${PN}"
+
+pkg_setup() {
+ if use gnutls && use ssl ; then
+ einfo "You have both 'gnutls' and 'ssl' USE flags enabled: defaulting to USE=\"ssl\""
+ fi
+
+ if use qt3 && use qt4 ; then
+ einfo "You have both 'qt3' and 'qt4' USE flags enabled: defaulting to USE=\"qt4\""
+ fi
+}
+
+src_prepare() {
+ # net/bpf.h needed for net-libs/libpcap on Gentoo/FreeBSD
+ sed -i \
+ -e "s:\(#include <pcap\.h>\):#include <net/bpf.h>\n\1:" \
+ ../src/l2_packet/l2_packet_freebsd.c || die
+
+ # People seem to take the example configuration file too literally (bug #102361)
+ sed -i \
+ -e "s:^\(opensc_engine_path\):#\1:" \
+ -e "s:^\(pkcs11_engine_path\):#\1:" \
+ -e "s:^\(pkcs11_module_path\):#\1:" \
+ wpa_supplicant.conf || die
+
+ # Change configuration to match Gentoo locations (bug #143750)
+ sed -i \
+ -e "s:/usr/lib/opensc:/usr/$(get_libdir):" \
+ -e "s:/usr/lib/pkcs11:/usr/$(get_libdir):" \
+ wpa_supplicant.conf || die
+
+ epatch "${FILESDIR}"/dbus_path_fix.patch
+}
+
+src_configure() {
+ # Toolchain setup
+ echo "CC = $(tc-getCC)" > .config
+
+ # Basic setup
+ echo "CONFIG_CTRL_IFACE=y" >> .config
+ echo "CONFIG_BACKEND=file" >> .config
+
+ # Basic authentication methods
+ # NOTE: we don't set GPSK or SAKE as they conflict
+ # with the below options
+ echo "CONFIG_EAP_GTC=y" >> .config
+ echo "CONFIG_EAP_MD5=y" >> .config
+ echo "CONFIG_EAP_OTP=y" >> .config
+ echo "CONFIG_EAP_PAX=y" >> .config
+ echo "CONFIG_EAP_PSK=y" >> .config
+ echo "CONFIG_EAP_TLV=y" >> .config
+ echo "CONFIG_IEEE8021X_EAPOL=y" >> .config
+ echo "CONFIG_PKCS12=y" >> .config
+ echo "CONFIG_PEERKEY=y" >> .config
+ echo "CONFIG_EAP_LEAP=y" >> .config
+ echo "CONFIG_EAP_MSCHAPV2=y" >> .config
+ echo "CONFIG_EAP_PEAP=y" >> .config
+ echo "CONFIG_EAP_TLS=y" >> .config
+ echo "CONFIG_EAP_TTLS=y" >> .config
+
+ if use dbus ; then
+ echo "CONFIG_CTRL_IFACE_DBUS=y" >> .config
+ fi
+
+ if use debug ; then
+ echo "CONFIG_DEBUG_FILE=y" >> .config
+ fi
+
+ if use gsm ; then
+ # Smart card authentication
+ echo "CONFIG_EAP_SIM=y" >> .config
+ echo "CONFIG_EAP_AKA=y" >> .config
+ echo "CONFIG_EAP_AKA_PRIME=y" >> .config
+ echo "CONFIG_PCSC=y" >> .config
+ fi
+
+ if use readline ; then
+ # readline/history support for wpa_cli
+ echo "CONFIG_READLINE=y" >> .config
+ fi
+
+ # SSL authentication methods
+ if use ssl ; then
+ echo "CONFIG_TLS=openssl" >> .config
+ echo "CONFIG_SMARTCARD=y" >> .config
+ elif use gnutls ; then
+ echo "CONFIG_TLS=gnutls" >> .config
+ echo "CONFIG_GNUTLS_EXTRA=y" >> .config
+ else
+ echo "CONFIG_TLS=internal" >> .config
+ fi
+
+ if use kernel_linux ; then
+ # Linux specific drivers
+ echo "CONFIG_DRIVER_ATMEL=y" >> .config
+ #echo "CONFIG_DRIVER_BROADCOM=y" >> .config
+ #echo "CONFIG_DRIVER_HERMES=y" >> .config
+ echo "CONFIG_DRIVER_HOSTAP=y" >> .config
+ echo "CONFIG_DRIVER_IPW=y" >> .config
+ echo "CONFIG_DRIVER_NDISWRAPPER=y" >> .config
+ echo "CONFIG_DRIVER_NL80211=y" >> .config
+ #echo "CONFIG_DRIVER_PRISM54=y" >> .config
+ echo "CONFIG_DRIVER_RALINK=y" >> .config
+ echo "CONFIG_DRIVER_WEXT=y" >> .config
+ echo "CONFIG_DRIVER_WIRED=y" >> .config
+
+ if use madwifi ; then
+ # Add include path for madwifi-driver headers
+ echo "CFLAGS += -I/usr/include/madwifi" >> .config
+ echo "CONFIG_DRIVER_MADWIFI=y" >> .config
+ fi
+
+ if use ps3 ; then
+ echo "CONFIG_DRIVER_PS3=y" >> .config
+ fi
+
+ elif use kernel_FreeBSD ; then
+ # FreeBSD specific driver
+ echo "CONFIG_DRIVER_BSD=y" >> .config
+ fi
+
+ # Wi-Fi Protected Setup (WPS)
+ if use wps ; then
+ echo "CONFIG_WPS=y" >> .config
+ fi
+
+ # Enable mitigation against certain attacks against TKIP
+ echo "CONFIG_DELAYED_MIC_ERROR_REPORT=y" >> .config
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use qt4 ; then
+ cd "${S}"/wpa_gui-qt4
+ eqmake4 wpa_gui.pro
+ emake || die "Qt4 wpa_gui compilation failed"
+ elif use qt3 ; then
+ cd "${S}"/wpa_gui
+ eqmake3 wpa_gui.pro
+ emake || die "Qt3 wpa_gui compilation failed"
+ fi
+}
+
+src_install() {
+ dosbin wpa_supplicant || die
+ dobin wpa_cli wpa_passphrase || die
+
+ # baselayout-1 compat
+ dosym /usr/sbin/wpa_supplicant /sbin/wpa_supplicant || die
+ dosym /usr/bin/wpa_cli /bin/wpa_cli || die
+
+ exeinto /etc/wpa_supplicant/
+ newexe "${FILESDIR}"/wpa_cli.sh wpa_cli.sh
+
+ dodoc ChangeLog {eap_testing,todo}.txt README{,-WPS} \
+ wpa_supplicant.conf || die "dodoc failed"
+
+ doman doc/docbook/*.{5,8} || die "doman failed"
+
+ if use qt4 ; then
+ into /usr
+ dobin wpa_gui-qt4/wpa_gui || die
+ elif use qt3 ; then
+ into /usr
+ dobin wpa_gui/wpa_gui || die
+ fi
+
+ if use qt3 || use qt4 ; then
+ make_desktop_entry wpa_gui "WPA Supplicant Administration GUI" "wpa_gui" "Qt;Network;"
+ fi
+
+ if use dbus ; then
+ insinto /etc/dbus-1/system.d
+ newins dbus-wpa_supplicant.conf wpa_supplicant.conf || die
+ insinto /usr/share/dbus-1/system-services
+ newins dbus-wpa_supplicant.service 'fi.epitest.hostap.WPASupplicant.service' || die
+ keepdir /var/run/wpa_supplicant
+ fi
+}
+
+pkg_postinst() {
+ einfo "If this is a clean installation of wpa_supplicant, you"
+ einfo "have to create a configuration file named"
+ einfo "/etc/wpa_supplicant/wpa_supplicant.conf"
+ einfo
+ einfo "An example configuration file is available for reference in"
+ einfo "/usr/share/doc/${PF}/"
+
+ if [[ -e ${ROOT}etc/wpa_supplicant.conf ]] ; then
+ echo
+ ewarn "WARNING: your old configuration file ${ROOT}etc/wpa_supplicant.conf"
+ ewarn "needs to be moved to ${ROOT}etc/wpa_supplicant/wpa_supplicant.conf"
+ fi
+
+ if use madwifi ; then
+ echo
+ einfo "This package compiles against the headers installed by"
+ einfo "madwifi-old, madwifi-ng or madwifi-ng-tools."
+ einfo "You should re-emerge ${PN} after upgrading these packages."
+ fi
+}