summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2010-02-28 17:40:01 +0000
committerFabio Erculiani <lxnay@gentoo.org>2010-02-28 17:40:01 +0000
commit1ae0b7bcd6c63c33925a77434544fbbe264e4be1 (patch)
tree4eda305282a621f4532f3fbbe77888b420a164f4 /net-wireless/acx
parentadd 2.6.33 kernel support and really close bug 297322 (diff)
downloadgentoo-2-1ae0b7bcd6c63c33925a77434544fbbe264e4be1.tar.gz
gentoo-2-1ae0b7bcd6c63c33925a77434544fbbe264e4be1.tar.bz2
gentoo-2-1ae0b7bcd6c63c33925a77434544fbbe264e4be1.zip
add 2.6.33 kernel support
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless/acx')
-rw-r--r--net-wireless/acx/ChangeLog8
-rw-r--r--net-wireless/acx/acx-0.3.37_p20080210.ebuild6
-rw-r--r--net-wireless/acx/files/acx-2.6.33.patch16
3 files changed, 26 insertions, 4 deletions
diff --git a/net-wireless/acx/ChangeLog b/net-wireless/acx/ChangeLog
index 665532f7ef25..8540eeb29cb4 100644
--- a/net-wireless/acx/ChangeLog
+++ b/net-wireless/acx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/acx
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/ChangeLog,v 1.15 2009/12/14 17:33:02 lxnay Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/ChangeLog,v 1.16 2010/02/28 17:40:00 lxnay Exp $
+
+ 28 Feb 2010; Fabio Erculiani <lxnay@gentoo.org>
+ acx-0.3.37_p20080210.ebuild, +files/acx-2.6.33.patch:
+ add 2.6.33 kernel support
*acx-0.3.37_p20080210 (14 Dec 2009)
diff --git a/net-wireless/acx/acx-0.3.37_p20080210.ebuild b/net-wireless/acx/acx-0.3.37_p20080210.ebuild
index db07159afe2e..7be751116b9c 100644
--- a/net-wireless/acx/acx-0.3.37_p20080210.ebuild
+++ b/net-wireless/acx/acx-0.3.37_p20080210.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/acx-0.3.37_p20080210.ebuild,v 1.1 2009/12/14 17:33:02 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/acx-0.3.37_p20080210.ebuild,v 1.2 2010/02/28 17:40:00 lxnay Exp $
inherit linux-mod
@@ -43,6 +43,8 @@ src_unpack() {
# Apply various fixes to make module compile with 2.6.31+ kernels
# thanks to Mepis
epatch "${FILESDIR}"/2.6.31+-mepis/*
+ # 2.6.33 patches
+ epatch "${FILESDIR}"/acx-2.6.33.patch
}
diff --git a/net-wireless/acx/files/acx-2.6.33.patch b/net-wireless/acx/files/acx-2.6.33.patch
new file mode 100644
index 000000000000..eb14b486f507
--- /dev/null
+++ b/net-wireless/acx/files/acx-2.6.33.patch
@@ -0,0 +1,16 @@
+diff -Nurp acx-20080210.orig/pci.c acx-20080210/pci.c
+--- acx-20080210.orig/pci.c 2010-02-28 14:09:55.000000000 +0000
++++ acx-20080210/pci.c 2010-02-28 14:13:09.000000000 +0000
+@@ -35,8 +35,12 @@
+
+ /* Linux 2.6.18+ uses <linux/utsrelease.h> */
+ #ifndef UTS_RELEASE
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33)
++#include <generated/utsrelease.h>
++#else
+ #include <linux/utsrelease.h>
+ #endif
++#endif
+
+ #include <linux/compiler.h> /* required for Lx 2.6.8 ?? */
+ #include <linux/kernel.h>