summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-07 18:56:54 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-07 18:56:54 +0000
commitc283763da5cc61a92d99d28f7ce59436cbecb134 (patch)
treebf8216335408c92f5eab202d8008479a7516fe63 /net-voip/telepathy-sofiasip
parentCorrect MODULE_VERSION (diff)
downloadgentoo-2-c283763da5cc61a92d99d28f7ce59436cbecb134.tar.gz
gentoo-2-c283763da5cc61a92d99d28f7ce59436cbecb134.tar.bz2
gentoo-2-c283763da5cc61a92d99d28f7ce59436cbecb134.zip
Version bump with bugfixes, improve python handling and add gnome to metadata as talked between us since empathy relies on this.
(Portage version: 2.1.9.36/cvs/Linux x86_64)
Diffstat (limited to 'net-voip/telepathy-sofiasip')
-rw-r--r--net-voip/telepathy-sofiasip/ChangeLog11
-rw-r--r--net-voip/telepathy-sofiasip/metadata.xml1
-rw-r--r--net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.6.ebuild40
3 files changed, 50 insertions, 2 deletions
diff --git a/net-voip/telepathy-sofiasip/ChangeLog b/net-voip/telepathy-sofiasip/ChangeLog
index 5c788f239aee..b91623b88b99 100644
--- a/net-voip/telepathy-sofiasip/ChangeLog
+++ b/net-voip/telepathy-sofiasip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-voip/telepathy-sofiasip
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-sofiasip/ChangeLog,v 1.18 2010/11/03 21:18:56 ford_prefect Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-sofiasip/ChangeLog,v 1.19 2011/02/07 18:56:54 pacho Exp $
+
+*telepathy-sofiasip-0.6.6 (07 Feb 2011)
+
+ 07 Feb 2011; Pacho Ramos <pacho@gentoo.org> +telepathy-sofiasip-0.6.6.ebuild,
+ metadata.xml:
+ Version bump with bugfixes, improve python handling and add gnome to metadata
+ as talked between us since empathy relies on this.
*telepathy-sofiasip-0.6.4-r1 (03 Nov 2010)
diff --git a/net-voip/telepathy-sofiasip/metadata.xml b/net-voip/telepathy-sofiasip/metadata.xml
index a38a25386d9b..31607d775a95 100644
--- a/net-voip/telepathy-sofiasip/metadata.xml
+++ b/net-voip/telepathy-sofiasip/metadata.xml
@@ -1,6 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+<herd>gnome</herd>
<herd>voip</herd>
<maintainer>
<email>tester@gentoo.org</email>
diff --git a/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.6.ebuild b/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.6.ebuild
new file mode 100644
index 000000000000..054da894dd28
--- /dev/null
+++ b/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.6.ebuild,v 1.1 2011/02/07 18:56:54 pacho Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="A SIP connection manager for Telepathy based around the Sofia-SIP library."
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=">=net-libs/sofia-sip-1.12.10
+ >=net-libs/telepathy-glib-0.8.0
+ >=dev-libs/glib-2.16
+ sys-apps/dbus
+ dev-libs/dbus-glib"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ test? ( dev-python/twisted )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+}