summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-09-27 18:07:55 +0000
committerOlivier Crête <tester@gentoo.org>2009-09-27 18:07:55 +0000
commit1f8f2c18eebe56ef382c384cffe0397649eb4bcd (patch)
treeb652346df0c19f032a77fe71dcfabe4063e2f024 /net-voip/telepathy-sofiasip
parentstable amd64, bug 286622 (diff)
downloadgentoo-2-1f8f2c18eebe56ef382c384cffe0397649eb4bcd.tar.gz
gentoo-2-1f8f2c18eebe56ef382c384cffe0397649eb4bcd.tar.bz2
gentoo-2-1f8f2c18eebe56ef382c384cffe0397649eb4bcd.zip
Version bump
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-voip/telepathy-sofiasip')
-rw-r--r--net-voip/telepathy-sofiasip/ChangeLog8
-rw-r--r--net-voip/telepathy-sofiasip/telepathy-sofiasip-0.5.18.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/net-voip/telepathy-sofiasip/ChangeLog b/net-voip/telepathy-sofiasip/ChangeLog
index 525fa42ad98d..25ef2d33d6b3 100644
--- a/net-voip/telepathy-sofiasip/ChangeLog
+++ b/net-voip/telepathy-sofiasip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-voip/telepathy-sofiasip
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-sofiasip/ChangeLog,v 1.5 2009/08/21 21:21:13 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-sofiasip/ChangeLog,v 1.6 2009/09/27 18:07:55 tester Exp $
+
+*telepathy-sofiasip-0.5.18 (27 Sep 2009)
+
+ 27 Sep 2009; Olivier Crête <tester@gentoo.org>
+ +telepathy-sofiasip-0.5.18.ebuild:
+ Version bump
21 Aug 2009; Olivier Crête <tester@gentoo.org>
-telepathy-sofiasip-0.5.14.ebuild, telepathy-sofiasip-0.5.17.ebuild:
diff --git a/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.5.18.ebuild b/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.5.18.ebuild
new file mode 100644
index 000000000000..6dccc9b95426
--- /dev/null
+++ b/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.5.18.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.5.18.ebuild,v 1.1 2009/09/27 18:07:55 tester Exp $
+
+inherit autotools
+
+DESCRIPTION="A SIP connection manager for Telepathy based around the Sofia-SIP library."
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug test"
+
+RDEPEND=">=net-libs/sofia-sip-1.12.10
+ >=net-libs/telepathy-glib-0.7.27
+ >=dev-libs/glib-2.16
+ sys-apps/dbus
+ dev-libs/dbus-glib"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-lang/python
+ test? ( dev-python/twisted )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ sed -i -e "s/python2.5/python2.6 python2.5/" configure.ac
+ rm ltmain.sh m4/libtool.m4 m4/lt*.m4
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable debug) || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}