summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-10-08 19:17:04 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-10-08 19:17:04 +0000
commit9307cf5d56f730eedb9a384e7311a36837f16af6 (patch)
tree519c2e429e15d9923acba04e844095a9646a4d46 /net-voip/cohoba
parentfix keywords (diff)
downloadgentoo-2-9307cf5d56f730eedb9a384e7311a36837f16af6.tar.gz
gentoo-2-9307cf5d56f730eedb9a384e7311a36837f16af6.tar.bz2
gentoo-2-9307cf5d56f730eedb9a384e7311a36837f16af6.zip
add an ugly built_with_use check for dbus python, bug 150497 thanks dsd
(Portage version: 2.1.2_pre2-r6)
Diffstat (limited to 'net-voip/cohoba')
-rw-r--r--net-voip/cohoba/ChangeLog5
-rw-r--r--net-voip/cohoba/cohoba-0.0.4.ebuild12
2 files changed, 15 insertions, 2 deletions
diff --git a/net-voip/cohoba/ChangeLog b/net-voip/cohoba/ChangeLog
index c43343bad3c8..37e10cba80c3 100644
--- a/net-voip/cohoba/ChangeLog
+++ b/net-voip/cohoba/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-voip/cohoba
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/cohoba/ChangeLog,v 1.3 2006/10/08 19:09:13 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/cohoba/ChangeLog,v 1.4 2006/10/08 19:17:04 genstef Exp $
+
+ 08 Oct 2006; Stefan Schweizer <genstef@gentoo.org> cohoba-0.0.4.ebuild:
+ add an ugly built_with_use check for dbus python, bug 150497 thanks dsd
*cohoba-0.0.4 (08 Oct 2006)
diff --git a/net-voip/cohoba/cohoba-0.0.4.ebuild b/net-voip/cohoba/cohoba-0.0.4.ebuild
index 544b5389665d..43867d9b7665 100644
--- a/net-voip/cohoba/cohoba-0.0.4.ebuild
+++ b/net-voip/cohoba/cohoba-0.0.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/cohoba/cohoba-0.0.4.ebuild,v 1.1 2006/10/08 19:09:13 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/cohoba/cohoba-0.0.4.ebuild,v 1.2 2006/10/08 19:17:04 genstef Exp $
+
+inherit eutils
DESCRIPTION="Gnome UI for Telepathy"
HOMEPAGE="http://telepathy.freedesktop.org/"
@@ -19,6 +21,14 @@ DEPEND="dev-python/gnome-python-desktop
RDEPEND="${DEPEND}
gnome-base/control-center"
+pkg_setup() {
+ if ! built_with_use sys-apps/dbus python; then
+ eerror "you need to build dbus with USE=python"
+ die "dbus needs python bindings"
+ fi
+
+}
+
src_install() {
emake install DESTDIR="${D}" || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README TODO