summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-05-13 19:16:12 +0000
committerAlin Năstac <mrness@gentoo.org>2009-05-13 19:16:12 +0000
commit7edc730a6cf03a8e73bc634f6a1f14d8c358eceb (patch)
tree3ad56bf518ee69461136178e594d1610a13e108d /net-proxy
parentChanged openmpi dep again to openmpi[cxx]. Changed eselect use flag to +esele... (diff)
downloadgentoo-2-7edc730a6cf03a8e73bc634f6a1f14d8c358eceb.tar.gz
gentoo-2-7edc730a6cf03a8e73bc634f6a1f14d8c358eceb.tar.bz2
gentoo-2-7edc730a6cf03a8e73bc634f6a1f14d8c358eceb.zip
Version bumps (#269319).
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/ChangeLog10
-rw-r--r--net-proxy/haproxy/haproxy-1.3.14.13.ebuild55
-rw-r--r--net-proxy/haproxy/haproxy-1.3.15.9.ebuild55
-rw-r--r--net-proxy/haproxy/haproxy-1.3.18.ebuild (renamed from net-proxy/haproxy/haproxy-1.3.17.ebuild)2
4 files changed, 120 insertions, 2 deletions
diff --git a/net-proxy/haproxy/ChangeLog b/net-proxy/haproxy/ChangeLog
index 2b20eeaf9835..898ad16976d9 100644
--- a/net-proxy/haproxy/ChangeLog
+++ b/net-proxy/haproxy/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-proxy/haproxy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.24 2009/05/02 09:48:57 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.25 2009/05/13 19:16:12 mrness Exp $
+
+*haproxy-1.3.18 (10 May 2009)
+*haproxy-1.3.15.9 (10 May 2009)
+*haproxy-1.3.14.13 (10 May 2009)
+
+ 10 May 2009; Alin Năstac <mrness@gentoo.org> +haproxy-1.3.14.13.ebuild,
+ +haproxy-1.3.15.9.ebuild, -haproxy-1.3.17.ebuild, +haproxy-1.3.18.ebuild:
+ Version bumps (#269319).
*haproxy-1.3.17 (02 May 2009)
diff --git a/net-proxy/haproxy/haproxy-1.3.14.13.ebuild b/net-proxy/haproxy/haproxy-1.3.14.13.ebuild
new file mode 100644
index 000000000000..8f4c89a236fe
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.3.14.13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.14.13.ebuild,v 1.1 2009/05/13 19:16:12 mrness Exp $
+
+inherit linux-info versionator eutils
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+}
+
+src_compile() {
+ local ARGS="TARGET=linux${KV_MAJOR}${KV_MINOR}"
+ use pcre && ARGS="${ARGS} REGEX=pcre"
+ emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${ARGS}
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe haproxy
+ newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/*.txt
+ docinto examples
+ dodoc examples/*.cfg
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}
diff --git a/net-proxy/haproxy/haproxy-1.3.15.9.ebuild b/net-proxy/haproxy/haproxy-1.3.15.9.ebuild
new file mode 100644
index 000000000000..744db642a201
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.3.15.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.15.9.ebuild,v 1.1 2009/05/13 19:16:12 mrness Exp $
+
+inherit versionator eutils
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+}
+
+src_compile() {
+ local ARGS="TARGET=linux26"
+ use pcre && ARGS="${ARGS} USE_PCRE=1"
+ emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${ARGS}
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe haproxy
+ newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/*.txt
+ docinto examples
+ dodoc examples/*.cfg
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}
diff --git a/net-proxy/haproxy/haproxy-1.3.17.ebuild b/net-proxy/haproxy/haproxy-1.3.18.ebuild
index 70161147716b..fb494ab73980 100644
--- a/net-proxy/haproxy/haproxy-1.3.17.ebuild
+++ b/net-proxy/haproxy/haproxy-1.3.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.17.ebuild,v 1.1 2009/05/02 09:48:57 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.18.ebuild,v 1.1 2009/05/13 19:16:12 mrness Exp $
inherit versionator eutils