summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-10-19 10:04:57 +0000
committerAlin Năstac <mrness@gentoo.org>2008-10-19 10:04:57 +0000
commit045f2a344684f500d8584e3837f129818c087719 (patch)
tree572ca9d43c6dd9f12d02d93fe270ce1f0ceaa3cd /net-proxy
parentVersion bump (#242646). (diff)
downloadgentoo-2-045f2a344684f500d8584e3837f129818c087719.tar.gz
gentoo-2-045f2a344684f500d8584e3837f129818c087719.tar.bz2
gentoo-2-045f2a344684f500d8584e3837f129818c087719.zip
Version bumps (#242648).
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/ChangeLog9
-rw-r--r--net-proxy/haproxy/haproxy-1.3.14.9.ebuild47
-rw-r--r--net-proxy/haproxy/haproxy-1.3.15.5.ebuild47
3 files changed, 102 insertions, 1 deletions
diff --git a/net-proxy/haproxy/ChangeLog b/net-proxy/haproxy/ChangeLog
index edbebdc8fe01..57ac321819cf 100644
--- a/net-proxy/haproxy/ChangeLog
+++ b/net-proxy/haproxy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-proxy/haproxy
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.17 2008/10/12 08:17:10 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.18 2008/10/19 10:04:57 mrness Exp $
+
+*haproxy-1.3.15.5 (19 Oct 2008)
+*haproxy-1.3.14.9 (19 Oct 2008)
+
+ 19 Oct 2008; Alin Năstac <mrness@gentoo.org> +haproxy-1.3.14.9.ebuild,
+ +haproxy-1.3.15.5.ebuild:
+ Version bumps (#242648).
*haproxy-1.3.15.4 (12 Oct 2008)
*haproxy-1.3.14.8 (12 Oct 2008)
diff --git a/net-proxy/haproxy/haproxy-1.3.14.9.ebuild b/net-proxy/haproxy/haproxy-1.3.14.9.ebuild
new file mode 100644
index 000000000000..156f78de9ac5
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.3.14.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.14.9.ebuild,v 1.1 2008/10/19 10:04:57 mrness Exp $
+
+inherit linux-info versionator
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local ARGS="TARGET=linux${KV_MAJOR}${KV_MINOR}"
+ use pcre && ARGS="${ARGS} REGEX=pcre"
+ emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${ARGS}
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe haproxy
+ newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/*.txt
+ docinto examples
+ dodoc examples/*.cfg
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ einfo "You need to create /etc/haproxy.cfg before you start haproxy service."
+ if [[ -d "${ROOT}/usr/share/doc/${P}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${P}"
+ fi
+ fi
+}
diff --git a/net-proxy/haproxy/haproxy-1.3.15.5.ebuild b/net-proxy/haproxy/haproxy-1.3.15.5.ebuild
new file mode 100644
index 000000000000..9a946fd3d128
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.3.15.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.15.5.ebuild,v 1.1 2008/10/19 10:04:57 mrness Exp $
+
+inherit versionator
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local ARGS="TARGET=linux26"
+ use pcre && ARGS="${ARGS} REGEX=pcre"
+ emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${ARGS}
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe haproxy
+ newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/*.txt
+ docinto examples
+ dodoc examples/*.cfg
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ einfo "You need to create /etc/haproxy.cfg before you start haproxy service."
+ if [[ -d "${ROOT}/usr/share/doc/${P}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${P}"
+ fi
+ fi
+}