summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-04-20 02:59:54 +0000
committerAlin Năstac <mrness@gentoo.org>2008-04-20 02:59:54 +0000
commitb80c4dd941f0650dadaad5ad74a692a37c64b207 (patch)
tree571770eef381af50b2e905f52d4056503729049f /net-proxy/haproxy/haproxy-1.3.15.ebuild
parentCorrect SRC_URI (#218353). (diff)
downloadgentoo-2-b80c4dd941f0650dadaad5ad74a692a37c64b207.tar.gz
gentoo-2-b80c4dd941f0650dadaad5ad74a692a37c64b207.tar.bz2
gentoo-2-b80c4dd941f0650dadaad5ad74a692a37c64b207.zip
Version bump (#213086 and #216010).
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-proxy/haproxy/haproxy-1.3.15.ebuild')
-rw-r--r--net-proxy/haproxy/haproxy-1.3.15.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-proxy/haproxy/haproxy-1.3.15.ebuild b/net-proxy/haproxy/haproxy-1.3.15.ebuild
new file mode 100644
index 000000000000..f58ad92d8f89
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.3.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.15.ebuild,v 1.1 2008/04/20 02:59:54 mrness Exp $
+
+inherit linux-info versionator
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( >=dev-libs/libpcre-6.3 )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local ARGS="TARGET=linux${KV_MAJOR}${KV_MINOR}"
+ use pcre && ARGS="${ARGS} REGEX=pcre"
+ emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${ARGS}
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe haproxy
+ newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/*.txt
+ docinto examples
+ dodoc examples/*.cfg
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ einfo "You need to create /etc/haproxy.cfg before you start haproxy service."
+ if [[ -d "${ROOT}/usr/share/doc/${P}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${P}"
+ fi
+ fi
+}