summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2012-10-02 13:47:12 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2012-10-02 13:47:12 +0000
commitc141003668b7f5337e1d514c178212f9c823949b (patch)
tree17e252dc79ecfe86560b30e7292660a81eaeb58e /net-proxy/cntlm
parenthttp://my.opera.com/desktopteam/blog/2012/10/02/opera-12-10-beta (diff)
downloadgentoo-2-c141003668b7f5337e1d514c178212f9c823949b.tar.gz
gentoo-2-c141003668b7f5337e1d514c178212f9c823949b.tar.bz2
gentoo-2-c141003668b7f5337e1d514c178212f9c823949b.zip
Revbump beta version, bug#403375.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/cntlm')
-rw-r--r--net-proxy/cntlm/ChangeLog8
-rw-r--r--net-proxy/cntlm/cntlm-0.93_beta5.ebuild55
-rw-r--r--net-proxy/cntlm/files/cntlm-0.93_beta5-buildsystem.patch195
3 files changed, 257 insertions, 1 deletions
diff --git a/net-proxy/cntlm/ChangeLog b/net-proxy/cntlm/ChangeLog
index 6c4f0c4c9be0..010a9dfacc0b 100644
--- a/net-proxy/cntlm/ChangeLog
+++ b/net-proxy/cntlm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/cntlm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/cntlm/ChangeLog,v 1.3 2012/10/02 13:16:42 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/cntlm/ChangeLog,v 1.4 2012/10/02 13:47:12 haubi Exp $
+
+*cntlm-0.93_beta5 (02 Oct 2012)
+
+ 02 Oct 2012; Michael Haubenwallner <haubi@gentoo.org>
+ +cntlm-0.93_beta5.ebuild, +files/cntlm-0.93_beta5-buildsystem.patch:
+ Revbump beta version, bug#403375.
*cntlm-0.92.3 (02 Oct 2012)
diff --git a/net-proxy/cntlm/cntlm-0.93_beta5.ebuild b/net-proxy/cntlm/cntlm-0.93_beta5.ebuild
new file mode 100644
index 000000000000..ed45a4e49469
--- /dev/null
+++ b/net-proxy/cntlm/cntlm-0.93_beta5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/cntlm/cntlm-0.93_beta5.ebuild,v 1.1 2012/10/02 13:47:12 haubi Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Cntlm is an NTLM/NTLMv2 authenticating HTTP proxy"
+HOMEPAGE="http://cntlm.sourceforge.net/"
+SRC_URI="http://ftp.awk.cz/pub/${P//_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${P//_}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buildsystem.patch # 334647
+}
+
+src_configure() {
+ tc-export CC
+
+ econf || die "econf failed"
+
+ # Replace default config file path in Makefile
+ sed -i -e 's~SYSCONFDIR=/usr/local/etc~SYSCONFDIR=/etc~' \
+ "${S}"/Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake V=1 || die "emake failed"
+}
+
+src_install() {
+ dobin cntlm
+ dodoc COPYRIGHT README VERSION doc/cntlm.conf
+ doman doc/cntlm.1
+ newinitd "${FILESDIR}"/cntlm.initd cntlm
+ newconfd "${FILESDIR}"/cntlm.confd cntlm
+ insinto /etc
+ insopts -m0600
+ doins doc/cntlm.conf
+}
+
+pkg_postinst() {
+ enewgroup cntlm
+ enewuser cntlm -1 -1 -1 cntlm
+}
diff --git a/net-proxy/cntlm/files/cntlm-0.93_beta5-buildsystem.patch b/net-proxy/cntlm/files/cntlm-0.93_beta5-buildsystem.patch
new file mode 100644
index 000000000000..d553e8661484
--- /dev/null
+++ b/net-proxy/cntlm/files/cntlm-0.93_beta5-buildsystem.patch
@@ -0,0 +1,195 @@
+Gentoo Bug#334647:
+Respect CC, CFLAGS, LDFLAGS (with gcc).
+Support verbose building via 'make V=1'.
+--- configure.orig 2012-10-02 14:01:48.735669564 +0200
++++ configure 2012-10-02 14:23:01.224271511 +0200
+@@ -10,7 +10,7 @@
+ # This can be disabled if neccessary.
+ #
+
+-CCS="xlc_r gcc"
++CCS=${CC-"xlc_r gcc"}
+
+ #
+ # Look for supported compilers
+@@ -31,15 +31,21 @@
+ else
+ echo "Using $CCPATH to compile Cntlm"
+ [ -h Makefile ] && rm -f Makefile 2>/dev/null
+- case "$CC" in
+- gcc)
++ if $CC -v >/dev/null 2>&1; then
+ # default Makefile is for GCC; just revert back to
+ # GCC if Makefile is linked to other compiler version
+ if [ ! -f Makefile ]; then
+ mv Makefile.gcc Makefile
+ fi
+- ;;
+- *)
++ : ${CFLAGS=-O3}
++ : ${LDFLAGS=}
++ CFLAGS="$CFLAGS -std=c99 -Wall -Wno-unused-but-set-variable -pedantic -pthread"
++ LDFLAGS="$LDFLAGS -pthread"
++ sed -e "s~^CFLAGS[ :]*=~CFLAGS=$CFLAGS ~" \
++ -e "s~^LDFLAGS[ :]*=.*~LDFLAGS=$LDFLAGS~" \
++ -e "s~^CC[ :]*=.*~CC=$CC~" \
++ -i Makefile
++ else
+ # backup default GCC Makefile and create a link to other
+ if [ -f Makefile ]; then
+ mv Makefile Makefile.gcc
+@@ -47,8 +53,7 @@
+
+ EXT=`echo "$CC" | sed 's/_.*//'`
+ ln -s Makefile.$EXT Makefile
+- ;;
+- esac
++ fi
+ fi
+
+ STAMP=configure-stamp
+@@ -62,7 +67,7 @@
+ for i in $TESTS; do
+ printf "Checking $i... "
+ printf "#define config_$i " >> $CONFIG
+- OUT=`$CC -D_POSIX_C_SOURCE=199506L -D_ISOC99_SOURCE -D_REENTRANT -o config/$i config/$i.c 2>&1`
++ OUT=`$CC $CFLAGS $LDFLAGS -D_POSIX_C_SOURCE=199506L -D_ISOC99_SOURCE -D_REENTRANT -o config/$i config/$i.c 2>&1`
+ rc=$?
+
+ if [ $rc -ne 0 ]; then # -o -n "$OUT" ]; then
+--- Makefile.orig 2012-10-02 15:31:03.986270993 +0200
++++ Makefile 2012-10-02 15:40:10.277689068 +0200
+@@ -16,14 +16,13 @@
+ CC := gcc
+ VER := $(shell cat VERSION)
+ OS := $(shell uname -s)
+-OSLDFLAGS := $(shell [ $(OS) = "SunOS" ] && echo "-lrt -lsocket -lnsl")
+-LDFLAGS := -lpthread $(OSLDFLAGS)
++LIBS := $(shell [ $(OS) = "SunOS" ] && echo "-lrt -lsocket -lnsl")
++LDFLAGS := -pthread
+ CYGWIN_REQS := cygwin1.dll cyggcc_s-1.dll cygstdc++-6.dll cygrunsrv.exe
+
++CFLAGS=-D__BSD_VISIBLE -D_ALL_SOURCE -D_XOPEN_SOURCE=600 -D_POSIX_C_SOURCE=200112 -D_ISOC99_SOURCE -D_REENTRANT -D_BSD_SOURCE -DVERSION=\"'$(VER)'\"
+ ifeq ($(DEBUG),1)
+- CFLAGS += -g -std=c99 -Wall -pedantic -D__BSD_VISIBLE -D_ALL_SOURCE -D_XOPEN_SOURCE=600 -D_POSIX_C_SOURCE=200112 -D_ISOC99_SOURCE -D_REENTRANT -D_BSD_SOURCE -DVERSION=\"'$(VER)'\"
+-else
+- CFLAGS += -O3 -std=c99 -D__BSD_VISIBLE -D_ALL_SOURCE -D_XOPEN_SOURCE=600 -D_POSIX_C_SOURCE=200112 -D_ISOC99_SOURCE -D_REENTRANT -D_BSD_SOURCE -DVERSION=\"'$(VER)'\"
++ CFLAGS += -g -O0
+ endif
+
+ ifneq ($(findstring CYGWIN,$(OS)),)
+@@ -32,28 +31,35 @@
+ OBJS=utils.o ntlm.o xcrypt.o config.o socket.o acl.o auth.o http.o forward.o direct.o scanner.o pages.o main.o
+ endif
+
++VE_=@echo
++VE_1=@:
++VE=$(VE_$(V))
++VV_=@
++VV_1=
++VV=$(VV_$(V))
++
+ $(NAME): configure-stamp $(OBJS)
+- @echo "Linking $@"
+- @$(CC) $(CFLAGS) -o $@ $(OBJS) $(LDFLAGS)
++ $(VE) "Linking $@"
++ $(VV) $(CC) $(CFLAGS) -o $@ $(OBJS) $(LDFLAGS) $(LIBS)
+
+ main.o: main.c
+- @echo "Compiling $<"
+- @if [ -z "$(SYSCONFDIR)" ]; then \
++ $(VE) "Compiling $<"
++ $(VV) if [ -z "$(SYSCONFDIR)" ]; then \
+ $(CC) $(CFLAGS) -c main.c -o $@; \
+ else \
+ $(CC) $(CFLAGS) -DSYSCONFDIR=\"$(SYSCONFDIR)\" -c main.c -o $@; \
+ fi
+
+ %.o: %.c
+- @echo "Compiling $<"
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ $(VE) "Compiling $<"
++ $(VV) $(CC) $(CFLAGS) -c -o $@ $<
+
+ configure-stamp:
+ ./configure
+
+ win/resources.o: win/resources.rc
+- @echo Adding EXE resources
+- @windres $^ -o $@
++ $(VE) Adding EXE resources
++ $(VV) windres $^ -o $@
+
+ install: $(NAME)
+ # Special handling for install(1)
+@@ -115,31 +121,31 @@
+
+ $(NAME)-$(VER)-win32.exe:
+ @echo - preparing binaries for GUI installer
+- @cp $(patsubst %, /bin/%, $(CYGWIN_REQS)) win/
++ $(VV) cp $(patsubst %, /bin/%, $(CYGWIN_REQS)) win/
+ ifeq ($(DEBUG),1)
+- @cp -p cntlm.exe win/
++ $(VV) cp -p cntlm.exe win/
+ else
+- @strip -o win/cntlm.exe cntlm.exe
++ $(VV) strip -o win/cntlm.exe cntlm.exe
+ endif
+ @echo - generating GUI installer
+- @win/Inno5/ISCC.exe /Q win/setup.iss #/Q win/setup.iss
++ $(VV) win/Inno5/ISCC.exe /Q win/setup.iss #/Q win/setup.iss
+
+ $(NAME)-$(VER)-win32.zip:
+ @echo - creating ZIP release for manual installs
+- @ln -s win $(NAME)-$(VER)
++ $(VV) ln -s win $(NAME)-$(VER)
+ zip -9 $(NAME)-$(VER)-win32.zip $(patsubst %, $(NAME)-$(VER)/%, $(CYGWIN_REQS) cntlm.ini LICENSE.txt cntlm_manual.pdf)
+- @rm -f $(NAME)-$(VER)
++ $(VV) rm -f $(NAME)-$(VER)
+
+ win/cntlm.ini: doc/cntlm.conf
+- @cat doc/cntlm.conf | unix2dos > win/cntlm.ini
++ $(VV) cat doc/cntlm.conf | unix2dos > win/cntlm.ini
+
+ win/LICENSE.txt: COPYRIGHT LICENSE
+- @cat COPYRIGHT LICENSE | unix2dos > win/LICENSE.txt
++ $(VV) cat COPYRIGHT LICENSE | unix2dos > win/LICENSE.txt
+
+ win/cntlm_manual.pdf: doc/cntlm.1
+ @echo - generating PDF manual
+- @rm -f win/cntlm_manual.pdf
+- @groff -t -e -mandoc -Tps doc/cntlm.1 | ps2pdf - win/cntlm_manual.pdf
++ $(VV) rm -f win/cntlm_manual.pdf
++ $(VV) groff -t -e -mandoc -Tps doc/cntlm.1 | ps2pdf - win/cntlm_manual.pdf
+
+ win/setup.iss: win/setup.iss.in
+ ifeq ($(findstring CYGWIN,$(OS)),)
+@@ -148,16 +154,16 @@
+ @echo
+ @exit 1
+ endif
+- @sed "s/\$$VERSION/$(VER)/g" $^ > $@
++ $(VV) sed "s/\$$VERSION/$(VER)/g" $^ > $@
+
+ uninstall:
+ rm -f $(BINDIR)/$(NAME) $(MANDIR)/man1/$(NAME).1 2>/dev/null || true
+
+ clean:
+- @rm -f config/endian config/gethostname config/strdup config/socklen_t config/*.exe
+- @rm -f *.o cntlm cntlm.exe configure-stamp build-stamp config/config.h
++ $(VV) rm -f config/endian config/gethostname config/strdup config/socklen_t config/*.exe
++ $(VV) rm -f *.o cntlm cntlm.exe configure-stamp build-stamp config/config.h
+ rm -f $(patsubst %, win/%, $(CYGWIN_REQS) cntlm.exe cntlm.ini LICENSE.txt setup.iss cntlm_manual.pdf)
+- @if [ -h Makefile ]; then rm -f Makefile; mv Makefile.gcc Makefile; fi
++ $(VV) if [ -h Makefile ]; then rm -f Makefile; mv Makefile.gcc Makefile; fi
+
+ distclean: clean
+ ifeq ($(findstring CYGWIN,$(OS)),)
+@@ -169,6 +175,6 @@
+ fakeroot rpm/rules clean; \
+ fi
+ endif
+- @rm -f *.exe *.deb *.rpm *.tgz *.tar.gz *.tar.bz2 *.zip *.exe tags ctags pid 2>/dev/null
++ $(VV) rm -f *.exe *.deb *.rpm *.tgz *.tar.gz *.tar.bz2 *.zip *.exe tags ctags pid 2>/dev/null
+
+ .PHONY: all install tgz tbz2 deb rpm win uninstall clean distclean