summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Duft <mduft@gentoo.org>2010-02-24 13:18:15 +0000
committerMarkus Duft <mduft@gentoo.org>2010-02-24 13:18:15 +0000
commit3875f6253f07a15692ea38cfa58d075ae0868911 (patch)
treee4d30c8d24f59c57d2f4a3aeda42b1365e91da9c /net-proxy/cntlm/cntlm-0.35.1-r1.ebuild
parentAdd a conditional patch for 1.0.x series to build against xulrunner 1.9.2, bu... (diff)
downloadgentoo-2-3875f6253f07a15692ea38cfa58d075ae0868911.tar.gz
gentoo-2-3875f6253f07a15692ea38cfa58d075ae0868911.tar.bz2
gentoo-2-3875f6253f07a15692ea38cfa58d075ae0868911.zip
initially added cntlm to tree
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'net-proxy/cntlm/cntlm-0.35.1-r1.ebuild')
-rw-r--r--net-proxy/cntlm/cntlm-0.35.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-proxy/cntlm/cntlm-0.35.1-r1.ebuild b/net-proxy/cntlm/cntlm-0.35.1-r1.ebuild
new file mode 100644
index 000000000000..9cd3c8e0f4b3
--- /dev/null
+++ b/net-proxy/cntlm/cntlm-0.35.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/cntlm/cntlm-0.35.1-r1.ebuild,v 1.1 2010/02/24 13:18:15 mduft Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Cntlm is an NTLM/NTLMv2 authenticating HTTP proxy"
+HOMEPAGE="http://cntlm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cntlm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ econf || die "econf failed"
+
+ # Replace default config file path in Makefile
+ sed -i -e 's~SYSCONFDIR=/usr/local/etc~SYSCONFDIR=/etc~' \
+ "${S}"/Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin cntlm
+ dodoc COPYRIGHT README VERSION doc/cntlm.conf
+ doman doc/cntlm.1
+ newinitd "${FILESDIR}"/cntlm.initd cntlm
+ newconfd "${FILESDIR}"/cntlm.confd cntlm
+ insinto /etc
+ insopts -m0600
+ doins doc/cntlm.conf
+}
+
+pkg_postinst() {
+ enewgroup cntlm
+ enewuser cntlm -1 -1 -1 cntlm
+}