summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2001-09-26 14:21:22 +0000
committerAron Griffis <agriffis@gentoo.org>2001-09-26 14:21:22 +0000
commite4cd37414b286d9154018e304620bdc74b1255a6 (patch)
treee33780268d54b62a26eddd30975f890b5d9d3247 /net-print
parentUpdate mutt 1.3.22 -> 1.3.22.1 (diff)
downloadgentoo-2-e4cd37414b286d9154018e304620bdc74b1255a6.tar.gz
gentoo-2-e4cd37414b286d9154018e304620bdc74b1255a6.tar.bz2
gentoo-2-e4cd37414b286d9154018e304620bdc74b1255a6.zip
(1) integrate the StylusColor-777 filters to be automatically built,
(2) update some dependencies, (3) move the filters to /usr/share/magicfilter so they can be updated by the ebuild without doing the ._cfg* stuff.
Diffstat (limited to 'net-print')
-rw-r--r--net-print/magicfilter/files/StylusColor-777@1440dpi-filter.x58
-rw-r--r--net-print/magicfilter/files/StylusColor-777@360dpi-filter.x58
-rw-r--r--net-print/magicfilter/files/StylusColor-777@720dpi-filter.x58
-rw-r--r--net-print/magicfilter/files/digest-magicfilter-1.2-r11
-rw-r--r--net-print/magicfilter/files/magicfilter-1.2-stc777.patch14
-rw-r--r--net-print/magicfilter/files/stc777-text-helper22
-rw-r--r--net-print/magicfilter/magicfilter-1.2-r1.ebuild95
7 files changed, 306 insertions, 0 deletions
diff --git a/net-print/magicfilter/files/StylusColor-777@1440dpi-filter.x b/net-print/magicfilter/files/StylusColor-777@1440dpi-filter.x
new file mode 100644
index 000000000000..d51fd120bac3
--- /dev/null
+++ b/net-print/magicfilter/files/StylusColor-777@1440dpi-filter.x
@@ -0,0 +1,58 @@
+%include <filters.h>
+#
+# Magic filter setup file for the EPSON Stylus Color 777 printer
+# operating at 360 dpi, originally based on StylusColor-800@360dpi-filter.
+#
+# There is no warranty for anything whatsoever!
+#
+# This file is covered by the GNU General Public License as published
+# by the Free Software Foundation; either version 2, or (at your
+# option) any later version.
+#
+# Copyright © 2001 Aron Griffis <agriffis@gentoo.org>
+#
+# This file has been automatically adapted to your system.
+%ifndef HAVE_GHOSTSCRIPT
+# However, since you did not have Ghostscript installed, most entries
+# are going to be rejects.
+%endif
+%define DPI 1440 /* printer resolution */
+%define IS_COLOR 1 /* color capability */
+
+# All documents sent to the printer should be prefixed by the magic
+# command and the reset code. The 'magic command' takes the printer
+# out of the Epson packet mode communication protocol (whatever that
+# is) and enables normal data transfer. The 'reset code' discards any
+# output, ejects the existing page, and returns all settings to their
+# default.
+0 \000\000\000\033\001@EJL\ 1284.4\n@EJL\ \ \ \ \ \n\033@ cat
+
+# Native printer control codes start with <ESC>, but if this wasn't
+# recognized by the magic above, then the reset code should be
+# prefixed. Then we pass the document to the printer, cross our
+# fingers and hope for the best.
+#
+# Note that we add a ff/reset on the end just for good measure...
+0 \033 cat \000\000\000\033\001@EJL\ 1284.4\n@EJL\ \ \ \ \ \n\033@ \014\033@
+
+%ifdef HAVE_GHOSTSCRIPT
+%define HANDLE_PS pipe PATH_GHOSTSCRIPT -sDEVICE=stp -sModel=escp2-777 -sQuality="1440 x 1440 DPI Highest Quality" -r1440x1440 -sDither="Ordered" -sInkType="Four Color Standard" -sMediaType="Plain Paper" -DImageType=2 -dNOPAUSE -dSAFER -q -sOutputFile=- - -c quit
+%define HANDLE_PDF fpipe PATH_GHOSTSCRIPT -sDEVICE=stp -sModel=escp2-777 -sQuality="1440 x 1440 DPI Highest Quality" -r1440x1440 -sDither="Ordered" -sInkType="Four Color Standard" -sMediaType="Plain Paper" -DImageType=2 -dNOPAUSE -dSAFER -q -sOutputFile=- $FILE -c quit
+%endif
+%define HANDLE_TEXT /usr/share/magicfilter/stc777-text-helper
+
+%ifdef HAVE_GHOSTSCRIPT
+# For PostScript, use ghostscript with the gimp-print driver. This is
+# done as a pipe (instead of a filter, which would go directly to the
+# printer) so that magicfilter can then decide whether or not a reset
+# sequence should be prefixed to the output.
+#
+# See `Devices.htm' for a description of the GhostScript options. They are
+# needed and are not documented in the GhostScript manual page since they are
+# specific to the GhostScript device drivers.
+%endif
+%include <stdconv.mh>
+
+# Default entry for normal (text) files. This must be the last entry!
+# =====================================================================
+default HANDLE_TEXT
diff --git a/net-print/magicfilter/files/StylusColor-777@360dpi-filter.x b/net-print/magicfilter/files/StylusColor-777@360dpi-filter.x
new file mode 100644
index 000000000000..fe4314efcd44
--- /dev/null
+++ b/net-print/magicfilter/files/StylusColor-777@360dpi-filter.x
@@ -0,0 +1,58 @@
+%include <filters.h>
+#
+# Magic filter setup file for the EPSON Stylus Color 777 printer
+# operating at 360 dpi, originally based on StylusColor-800@360dpi-filter.
+#
+# There is no warranty for anything whatsoever!
+#
+# This file is covered by the GNU General Public License as published
+# by the Free Software Foundation; either version 2, or (at your
+# option) any later version.
+#
+# Copyright © 2001 Aron Griffis <agriffis@gentoo.org>
+#
+# This file has been automatically adapted to your system.
+%ifndef HAVE_GHOSTSCRIPT
+# However, since you did not have Ghostscript installed, most entries
+# are going to be rejects.
+%endif
+%define DPI 360 /* printer resolution */
+%define IS_COLOR 1 /* color capability */
+
+# All documents sent to the printer should be prefixed by the magic
+# command and the reset code. The 'magic command' takes the printer
+# out of the Epson packet mode communication protocol (whatever that
+# is) and enables normal data transfer. The 'reset code' discards any
+# output, ejects the existing page, and returns all settings to their
+# default.
+0 \000\000\000\033\001@EJL\ 1284.4\n@EJL\ \ \ \ \ \n\033@ cat
+
+# Native printer control codes start with <ESC>, but if this wasn't
+# recognized by the magic above, then the reset code should be
+# prefixed. Then we pass the document to the printer, cross our
+# fingers and hope for the best.
+#
+# Note that we add a ff/reset on the end just for good measure...
+0 \033 cat \000\000\000\033\001@EJL\ 1284.4\n@EJL\ \ \ \ \ \n\033@ \014\033@
+
+%ifdef HAVE_GHOSTSCRIPT
+%define HANDLE_PS pipe PATH_GHOSTSCRIPT -sDEVICE=stp -sModel=escp2-777 -sQuality="360 DPI Softweave" -r360x360 -sDither="Adaptive Hybrid" -sInkType="Four Color Standard" -sMediaType="Plain Paper" -dImageType=0 -dNOPAUSE -dSAFER -q -sOutputFile=- - -c quit
+%define HANDLE_PDF fpipe PATH_GHOSTSCRIPT -sDEVICE=stp -sModel=escp2-777 -sQuality="360 DPI Softweave" -r360x360 -sDither="Adaptive Hybrid" -sInkType="Four Color Standard" -sMediaType="Plain Paper" -dImageType=0 -dNOPAUSE -dSAFER -q -sOutputFile=- $FILE -c quit
+%endif
+%define HANDLE_TEXT /usr/share/magicfilter/stc777-text-helper
+
+%ifdef HAVE_GHOSTSCRIPT
+# For PostScript, use ghostscript with the gimp-print driver. This is
+# done as a pipe (instead of a filter, which would go directly to the
+# printer) so that magicfilter can then decide whether or not a reset
+# sequence should be prefixed to the output.
+#
+# See `Devices.htm' for a description of the GhostScript options. They are
+# needed and are not documented in the GhostScript manual page since they are
+# specific to the GhostScript device drivers.
+%endif
+%include <stdconv.mh>
+
+# Default entry for normal (text) files. This must be the last entry!
+# =====================================================================
+default HANDLE_TEXT
diff --git a/net-print/magicfilter/files/StylusColor-777@720dpi-filter.x b/net-print/magicfilter/files/StylusColor-777@720dpi-filter.x
new file mode 100644
index 000000000000..b64b2e3c1b59
--- /dev/null
+++ b/net-print/magicfilter/files/StylusColor-777@720dpi-filter.x
@@ -0,0 +1,58 @@
+%include <filters.h>
+#
+# Magic filter setup file for the EPSON Stylus Color 777 printer
+# operating at 720 dpi, originally based on StylusColor-800@360dpi-filter.
+#
+# There is no warranty for anything whatsoever!
+#
+# This file is covered by the GNU General Public License as published
+# by the Free Software Foundation; either version 2, or (at your
+# option) any later version.
+#
+# Copyright © 2001 Aron Griffis <agriffis@gentoo.org>
+#
+# This file has been automatically adapted to your system.
+%ifndef HAVE_GHOSTSCRIPT
+# However, since you did not have Ghostscript installed, most entries
+# are going to be rejects.
+%endif
+%define DPI 720 /* printer resolution */
+%define IS_COLOR 1 /* color capability */
+
+# All documents sent to the printer should be prefixed by the magic
+# command and the reset code. The 'magic command' takes the printer
+# out of the Epson packet mode communication protocol (whatever that
+# is) and enables normal data transfer. The 'reset code' discards any
+# output, ejects the existing page, and returns all settings to their
+# default.
+0 \000\000\000\033\001@EJL\ 1284.4\n@EJL\ \ \ \ \ \n\033@ cat
+
+# Native printer control codes start with <ESC>, but if this wasn't
+# recognized by the magic above, then the reset code should be
+# prefixed. Then we pass the document to the printer, cross our
+# fingers and hope for the best.
+#
+# Note that we add a ff/reset on the end just for good measure...
+0 \033 cat \000\000\000\033\001@EJL\ 1284.4\n@EJL\ \ \ \ \ \n\033@ \014\033@
+
+%ifdef HAVE_GHOSTSCRIPT
+%define HANDLE_PS pipe PATH_GHOSTSCRIPT -sDEVICE=stp -sModel=escp2-777 -sQuality="720 DPI Softweave" -r720x720 -sDither="Adaptive Hybrid" -sInkType="Four Color Standard" -sMediaType="Plain Paper" -dImageType=1 -dNOPAUSE -dSAFER -q -sOutputFile=- - -c quit
+%define HANDLE_PDF fpipe PATH_GHOSTSCRIPT -sDEVICE=stp -sModel=escp2-777 -sQuality="720 DPI Softweave" -r720x720 -sDither="Adaptive Hybrid" -sInkType="Four Color Standard" -sMediaType="Plain Paper" -dImageType=1 -dNOPAUSE -dSAFER -q -sOutputFile=- $FILE -c quit
+%endif
+%define HANDLE_TEXT /usr/share/magicfilter/stc777-text-helper
+
+%ifdef HAVE_GHOSTSCRIPT
+# For PostScript, use ghostscript with the gimp-print driver. This is
+# done as a pipe (instead of a filter, which would go directly to the
+# printer) so that magicfilter can then decide whether or not a reset
+# sequence should be prefixed to the output.
+#
+# See `Devices.htm' for a description of the GhostScript options. They are
+# needed and are not documented in the GhostScript manual page since they are
+# specific to the GhostScript device drivers.
+%endif
+%include <stdconv.mh>
+
+# Default entry for normal (text) files. This must be the last entry!
+# =====================================================================
+default HANDLE_TEXT
diff --git a/net-print/magicfilter/files/digest-magicfilter-1.2-r1 b/net-print/magicfilter/files/digest-magicfilter-1.2-r1
new file mode 100644
index 000000000000..e60e713ad018
--- /dev/null
+++ b/net-print/magicfilter/files/digest-magicfilter-1.2-r1
@@ -0,0 +1 @@
+MD5 dcece221e363ca5dbc79bdd84713c04e magicfilter-1.2.tar.gz
diff --git a/net-print/magicfilter/files/magicfilter-1.2-stc777.patch b/net-print/magicfilter/files/magicfilter-1.2-stc777.patch
new file mode 100644
index 000000000000..a728908e1478
--- /dev/null
+++ b/net-print/magicfilter/files/magicfilter-1.2-stc777.patch
@@ -0,0 +1,14 @@
+--- magicfilter-1.2/filters/Makefile.in.orig Wed Sep 26 08:51:27 2001
++++ magicfilter-1.2/filters/Makefile.in Wed Sep 26 08:49:15 2001
+@@ -52,7 +52,10 @@
+ StylusColor-800@720dpi-filter \
+ StylusColor-800@1440dpi-filter \
+ StylusColor-1520@1440dpi-filter \
+- StylusColor-generic-filter
++ StylusColor-generic-filter \
++ StylusColor-777@360dpi-filter \
++ StylusColor-777@720dpi-filter \
++ StylusColor-777@1440dpi-filter
+
+ .SUFFIXES:
+ .SUFFIXES: .x .xc .h .xh .mh .xt
diff --git a/net-print/magicfilter/files/stc777-text-helper b/net-print/magicfilter/files/stc777-text-helper
new file mode 100644
index 000000000000..a93eb7b9f9ab
--- /dev/null
+++ b/net-print/magicfilter/files/stc777-text-helper
@@ -0,0 +1,22 @@
+#!/bin/bash
+
+# Magic command to take the printer out of the Epson packet mode
+# communication protocol (whatever that is) and enable normal data
+# transfer
+printf '\000\000\000\033\001@EJL 1284.4\n@EJL \n\033@'
+
+# Reset the printer
+printf '\033@'
+
+# Recode standard input to IBM PC characters
+if type -p recode >/dev/null 2>&1; then
+ recode --silent latin1..ibmpc
+else
+ cat
+fi
+
+# Eject the page
+printf '\014'
+
+# Finally, reset the printer
+printf '\033@'
diff --git a/net-print/magicfilter/magicfilter-1.2-r1.ebuild b/net-print/magicfilter/magicfilter-1.2-r1.ebuild
new file mode 100644
index 000000000000..722d8b03b51e
--- /dev/null
+++ b/net-print/magicfilter/magicfilter-1.2-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Aron Griffis <agriffis@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-print/magicfilter/magicfilter-1.2-r1.ebuild,v 1.1 2001/09/26 14:21:22 agriffis Exp $
+
+A=magicfilter-$PV.tar.gz
+S=$WORKDIR/$P
+DESCRIPTION="Customizable, extensible automatic printer filter"
+SRC_URI="ftp://metalab.unc.edu/pub/linux/system/printing/$A"
+HOMEPAGE="http://www.gnu.org/directory/magicfilter.html"
+
+# Others that perhaps should be added to this list as I figure out
+# what packages they belong to...
+#
+# checking for recode... no
+# checking for gs... /usr/bin/gs
+# checking for grog... /usr/bin/grog
+# checking for groff... /usr/bin/groff
+# checking for gtroff... no
+# checking for ditroff... no
+# checking for troff... /usr/bin/troff
+# checking for grops... /usr/bin/grops
+# checking for grodvi... /usr/bin/grodvi
+# checking for grotty... /usr/bin/grotty
+# checking for grolj4... /usr/bin/grolj4
+# checking for bzip2... /bin/bzip2
+# checking for gzip... /bin/gzip
+# checking for zcat... /bin/zcat
+# checking for uncompress... no
+# checking for dvips... no
+# checking for pnmtops... no
+# checking for pngtopnm... no
+# checking for giftopnm... no
+# checking for giftoppm... no
+# checking for djpeg... /usr/bin/djpeg
+# checking for sgitopnm... no
+# checking for tops... no
+# checking for sgitops... no
+# checking for tiff2ps... /usr/bin/tiff2ps
+# checking for tifftopnm... no
+# checking for bmptopnm... no
+# checking for bmptoppm... no
+# checking for rasttopnm... no
+# checking for nenscript... no
+# checking for enscript... no
+# checking for a2x... no
+# checking for a2ps... no
+# checking for fig2dev... no
+# checking whether zcat is really gzip... yes
+# checking whether ditroff works... yes
+# checking for sendmail... /usr/sbin/sendmail
+DEPEND="virtual/glibc
+ >=app-text/ghostscript-6.50-r2
+ >=sys-apps/groff-1.16.1-r1
+ >=sys-apps/bzip2-1.0.1-r4
+ >=sys-apps/gzip-1.2.4a-r6"
+
+src_unpack() {
+ unpack $A
+ # This is the patch directly from the Debian package. It's included
+ # here (instead of fetching from Debian) because their package
+ # revisions will change faster than this ebuild will keep up...
+ cd $S
+ patch -p1 < $FILESDIR/magicfilter_1.2-39.diff || die
+ patch -p1 < $FILESDIR/magicfilter-1.2-stc777.patch || die
+ cp $FILESDIR/*-filter.x filters || die
+}
+
+src_compile() {
+ ./configure --host="$CHOST" || die
+ emake || die
+ # Fixup the filters for /usr/sbin/magicfilter; eventually
+ # magicfilterconf should be fixed up for
+ # /usr/share/magicfilter/... :-(
+ cd filters
+ for f in *-filter; do
+ mv $f $f.old
+ ( read l; echo '#!/usr/sbin/magicfilter'; cat ) <$f.old >$f
+ done
+}
+
+src_install() {
+ dodir /usr/sbin /usr/share/man/man8 /usr/share/magicfilter
+ install -m 755 magicfilter $D/usr/sbin
+ install -m 755 magicfilter.man $D/usr/share/man/man8/magicfilter.8
+ install -m 755 magicfilterconfig $D/usr/sbin
+ install -m 644 magicfilterconfig.8 $D/usr/share/man
+ install -m 755 filters/*-filter $D/usr/share/magicfilter
+ install -m 755 $FILESDIR/stc777-text-helper $D/usr/share/magicfilter
+ gzip -9f $D/usr/share/man/*/*
+ gzip -9f filters/README*
+ dodoc README QuickInst TODO debian/copyright
+ docinto filters
+ dodoc filters/README*
+}