summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-17 20:33:42 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-17 20:33:42 +0000
commitdabdf11ab670e2f1f257a947c51e298a4c8d82b1 (patch)
treed9d651156b9925bb360aa314b68c34e755265bc3 /net-print
parentStable for HPPA (bug #317819). (diff)
downloadgentoo-2-dabdf11ab670e2f1f257a947c51e298a4c8d82b1.tar.gz
gentoo-2-dabdf11ab670e2f1f257a947c51e298a4c8d82b1.tar.bz2
gentoo-2-dabdf11ab670e2f1f257a947c51e298a4c8d82b1.zip
Version bump, #307067
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/foomatic-db-engine/ChangeLog8
-rw-r--r--net-print/foomatic-db-engine/foomatic-db-engine-4.0.4.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/net-print/foomatic-db-engine/ChangeLog b/net-print/foomatic-db-engine/ChangeLog
index 269245d36c6f..2c6e04baafde 100644
--- a/net-print/foomatic-db-engine/ChangeLog
+++ b/net-print/foomatic-db-engine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/foomatic-db-engine
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-engine/ChangeLog,v 1.44 2010/02/10 08:25:49 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-engine/ChangeLog,v 1.45 2010/05/17 20:33:42 jlec Exp $
+
+*foomatic-db-engine-4.0.4 (17 May 2010)
+
+ 17 May 2010; Justin Lecher <jlec@gentoo.org>
+ +foomatic-db-engine-4.0.4.ebuild:
+ Version bump, #307067
10 Feb 2010; Torsten Veller <tove@gentoo.org>
foomatic-db-engine-4.0.3.ebuild:
diff --git a/net-print/foomatic-db-engine/foomatic-db-engine-4.0.4.ebuild b/net-print/foomatic-db-engine/foomatic-db-engine-4.0.4.ebuild
new file mode 100644
index 000000000000..1089fcf5445e
--- /dev/null
+++ b/net-print/foomatic-db-engine/foomatic-db-engine-4.0.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-engine/foomatic-db-engine-4.0.4.ebuild,v 1.1 2010/05/17 20:33:42 jlec Exp $
+
+EAPI="2"
+
+inherit eutils perl-app versionator
+
+DESCRIPTION="Generates ppds out of xml foomatic printer description files"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+SRC_URI="http://www.linuxprinting.org/download/foomatic/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libxml2
+ net-print/foomatic-filters"
+PDEPEND="net-print/foomatic-db"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/4.0.3-perl-module.patch \
+ "${FILESDIR}"/4.0.3-respect-ldflag.patch
+ sed -i -e "s:@LIB_CUPS@:$(cups-config --serverbin):" "${S}"/Makefile.in
+}
+
+src_configure() {
+ default
+ emake defaults || die "emake defaults failed"
+
+ cd lib
+ perl-app_src_configure
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ cd lib
+ perl-app_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ cd lib
+ perl-module_src_install
+}
+
+src_test() {
+ cd lib
+ perl-module_src_test
+}