summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-04-08 11:06:05 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-04-08 11:06:05 +0000
commit2297874ef45a1124d3a77d62136817817e97a8a9 (patch)
tree43746a64a22d0c9fdd81c84f18e985a06affa1f4 /net-print/pup/pup-1.1.ebuild
parentmark 4.2.6 x86, remove 4.3.25 (Manifest recommit) (diff)
downloadgentoo-2-2297874ef45a1124d3a77d62136817817e97a8a9.tar.gz
gentoo-2-2297874ef45a1124d3a77d62136817817e97a8a9.tar.bz2
gentoo-2-2297874ef45a1124d3a77d62136817817e97a8a9.zip
initial ebuild, thx to Scott Alfter <gentoo@salfter.dyndns.org> , bug# 46893
Diffstat (limited to 'net-print/pup/pup-1.1.ebuild')
-rw-r--r--net-print/pup/pup-1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-print/pup/pup-1.1.ebuild b/net-print/pup/pup-1.1.ebuild
new file mode 100644
index 000000000000..6b8750ed2b70
--- /dev/null
+++ b/net-print/pup/pup-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/pup/pup-1.1.ebuild,v 1.1 2004/04/08 11:06:05 lanius Exp $
+
+MY_P=${P/-/_}
+
+DESCRIPTION="Printer Utility Program, setup & maintenance for certain Lexmark & HP printers"
+HOMEPAGE="http://pup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pup/${MY_P}_src.tar.gz
+ http://alfter.us/files/${P}-manpage-install.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="=x11-libs/gtk+-1.2*"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${DISTDIR}/${P}-manpage-install.patch.gz
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/share/man/man1
+ make DESTDIR=${D} install || die
+}