summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-02-19 22:49:58 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-02-19 22:49:58 +0000
commit81230473783173ef2ea791cb1a8511769d563855 (patch)
tree2c6e72e3eff4dd72de6aae0a233eb080e0091aaf /net-print/hplip
parentAdded Hauppauge Firmware license (diff)
downloadgentoo-2-81230473783173ef2ea791cb1a8511769d563855.tar.gz
gentoo-2-81230473783173ef2ea791cb1a8511769d563855.tar.bz2
gentoo-2-81230473783173ef2ea791cb1a8511769d563855.zip
Version bump, thanks to Francisco Lloret <fcolloret@terra.es> in bug 163738
(Portage version: 2.1.2-r9)
Diffstat (limited to 'net-print/hplip')
-rw-r--r--net-print/hplip/ChangeLog8
-rw-r--r--net-print/hplip/files/digest-hplip-1.7.15
-rw-r--r--net-print/hplip/files/hplip-1.7.1-1.patch12
-rw-r--r--net-print/hplip/hplip-1.7.1.ebuild117
4 files changed, 141 insertions, 1 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index d35114dfa2d1..1f585791bc6c 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.47 2007/01/07 10:00:03 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.48 2007/02/19 22:49:58 genstef Exp $
+
+*hplip-1.7.1 (19 Feb 2007)
+
+ 19 Feb 2007; <genstef@gentoo.org> +files/hplip-1.7.1-1.patch,
+ +hplip-1.7.1.ebuild:
+ Version bump, thanks to Francisco Lloret <fcolloret@terra.es> in bug 163738
*hplip-1.6.12 (07 Jan 2007)
diff --git a/net-print/hplip/files/digest-hplip-1.7.1 b/net-print/hplip/files/digest-hplip-1.7.1
new file mode 100644
index 000000000000..51029e2e9b40
--- /dev/null
+++ b/net-print/hplip/files/digest-hplip-1.7.1
@@ -0,0 +1,5 @@
+RMD160 0c2c09f3cea6fc2a8e5da216bd9996b96d91613d foomatic-db-hpijs-20060720.tar.gz 98252
+SHA256 1e50f603b46b1d07980212b2e5dfc5d72d07c889259e79ecbf09469fef5ad20e foomatic-db-hpijs-20060720.tar.gz 98252
+MD5 1732a8544413ba8557c8b71929d848fa hplip-1.7.1.tar.gz 10874573
+RMD160 a6fb08542256408c29fc08974442c89308a7a0a7 hplip-1.7.1.tar.gz 10874573
+SHA256 155bddb595466a8008665fb1bbef6ab2a84addfc0cb3e60fa63592dc4525eac8 hplip-1.7.1.tar.gz 10874573
diff --git a/net-print/hplip/files/hplip-1.7.1-1.patch b/net-print/hplip/files/hplip-1.7.1-1.patch
new file mode 100644
index 000000000000..f5c4f61f41fe
--- /dev/null
+++ b/net-print/hplip/files/hplip-1.7.1-1.patch
@@ -0,0 +1,12 @@
+diff -uNr hplip-1.7.1_old/prnt/hpijs/dj3320.cpp hplip-1.7.1_new/prnt/hpijs/dj3320.cpp
+--- hplip-1.7.1_old/prnt/hpijs/dj3320.cpp 2007-01-24 15:42:03.000000000 -0800
++++ hplip-1.7.1_new/prnt/hpijs/dj3320.cpp 2007-01-31 13:33:42.000000000 -0800
+@@ -3066,7 +3066,7 @@
+ }
+
+ // Send Sync packet
+- err = pPrinterXBow->Send (pbySync, (DWORD) sizeof (pbySync));
++ err = pPrinterXBow->Send (pbySync, SYNCSIZE);
+ if(err)
+ {
+ return err;
diff --git a/net-print/hplip/hplip-1.7.1.ebuild b/net-print/hplip/hplip-1.7.1.ebuild
new file mode 100644
index 000000000000..47ccdbb8562f
--- /dev/null
+++ b/net-print/hplip/hplip-1.7.1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-1.7.1.ebuild,v 1.1 2007/02/19 22:49:58 genstef Exp $
+
+inherit eutils
+
+DB_V=20060720
+DESCRIPTION="HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools."
+HOMEPAGE="http://hplip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
+ foomaticdb? (
+ http://gentooexperimental.org/~genstef/dist/foomatic-db-hpijs-${DB_V}.tar.gz
+ http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-${DB_V}.tar.gz
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="foomaticdb snmp X qt3 ppds scanner"
+
+DEPEND=">=dev-lang/python-2.2.0
+ snmp? ( >=net-analyzer/net-snmp-5.0.9 )
+ !net-print/hpijs
+ !net-print/hpoj
+ virtual/ghostscript
+ scanner? (
+ >=media-gfx/sane-backends-1.0.9
+ || (
+ X? ( >=media-gfx/xsane-0.89 )
+ >=media-gfx/sane-frontends-1.0.9
+ )
+ )
+ qt3? ( >=dev-python/PyQt-3.11 =x11-libs/qt-3* )
+ >=dev-libs/libusb-0.1.10a
+ sys-apps/hotplug-base
+ net-print/cups
+ foomaticdb? ( net-print/foomatic-db-engine )
+ >=net-print/foomatic-filters-3.0.2"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ # avoid collisions with cups-1.2 compat symlinks
+ if [ -e ${ROOT}/usr/lib/cups/backend/hp ] && [ -e ${ROOT}/usr/libexec/cups/backend/hp ]; then
+ rm -f ${ROOT}/usr/libexec/cups/backend/hp{,fax};
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/hplip-1.7.1-1.patch
+
+ # bug 98428
+ sed -i -e "s:/usr/bin/env python:/usr/bin/python:g" \
+ hpssd.py
+}
+src_compile() {
+ econf \
+ $(use_enable snmp network-build) \
+ $(use_enable cups cups-install) \
+ $(use_enable ppds foomatic-install) \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ econf || die "econf failed"
+ rm -fR data-generators/hpijs-rss
+ emake || die "emake failed"
+ fi
+}
+
+
+src_install() {
+ # cups-1.2 installation paths, make sure that the .desktop is installed
+ sed -i -e "s:/usr/lib/cups:$(cups-config --serverbin):" \
+ -e 's:\(ICON_FILE = \).*:\1hplip.desktop:' \
+ -e 's:\(ICON_PATH = \).*:\1/usr/share/applications:' \
+ Makefile
+
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}"/hplip.init.d hplip
+
+ if use scanner; then
+ dodir /usr/$(get_libdir)/sane
+ for i in libsane-hpaio.{la,so{,.1{,.0.0}}}; do
+ dosym /usr/$(get_libdir)/${i} /usr/$(get_libdir)/sane/${i}; done
+ else
+ rm -f "${D}"/usr/$(get_libdir)/libsane-hpaio.{la,so{,.1{,.0.0}}}
+ rm -f "${D}"/etc/sane.d/dll.conf
+ fi
+
+ # bug 106035
+ if ! use qt3 ; then
+ rm -f "${D}"/usr/{bin/hp-,share/hplip/}{print,toolbox}
+ rm -f "${D}"/usr/share/applications/hplip.desktop
+ rm -f "${D}"/usr/lib/menu/hplip
+ fi
+
+ rm -rf ${D}/$(cups-config --serverbin)/filter ${D}/usr/bin/foomatic-rip
+
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ emake DESTDIR="${D}" install || die "emake install failed"
+ fi
+}
+
+pkg_preinst() {
+ if use scanner; then
+ insinto /etc/sane.d
+ [ -e /etc/sane.d/dll.conf ] && cp /etc/sane.d/dll.conf .
+ [ -e ${ROOT}/etc/sane.d/dll.conf ] && cp ${ROOT}/etc/sane.d/dll.conf .
+ grep -q hpaio dll.conf || echo hpaio >> dll.conf
+ doins dll.conf
+ fi
+}