summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-08 07:59:22 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-08 07:59:22 +0000
commite37e0fae4e79798182d25c3d06d340dc7e9af6f9 (patch)
treedc78c4297f2a1cc53e2f4e3088a65dabe7b803fa /net-p2p
parentPass --with-ssl to use dev-libs/openssl because otherwise unshield will fallb... (diff)
downloadgentoo-2-e37e0fae4e79798182d25c3d06d340dc7e9af6f9.tar.gz
gentoo-2-e37e0fae4e79798182d25c3d06d340dc7e9af6f9.tar.bz2
gentoo-2-e37e0fae4e79798182d25c3d06d340dc7e9af6f9.zip
Add patch to link with gold
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog6
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.9.0-gold.patch32
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.0.ebuild5
3 files changed, 40 insertions, 3 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index ad70bbcb5805..022bf8ba5971 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.170 2012/03/08 04:34:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.171 2012/03/08 07:59:22 jlec Exp $
+
+ 08 Mar 2012; Justin Lecher <jlec@gentoo.org> rtorrent-0.9.0.ebuild,
+ +files/rtorrent-0.9.0-gold.patch:
+ Add patch to link with gold
*rtorrent-0.9.0 (08 Mar 2012)
diff --git a/net-p2p/rtorrent/files/rtorrent-0.9.0-gold.patch b/net-p2p/rtorrent/files/rtorrent-0.9.0-gold.patch
new file mode 100644
index 000000000000..aeec1941519f
--- /dev/null
+++ b/net-p2p/rtorrent/files/rtorrent-0.9.0-gold.patch
@@ -0,0 +1,32 @@
+ src/Makefile.am | 3 ++-
+ src/Makefile.in | 3 ++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 33ab889..ee9340e 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -48,7 +48,8 @@ rtorrent_LDADD = \
+ display/libsub_display.a \
+ input/libsub_input.a \
+ rpc/libsub_rpc.a \
+- utils/libsub_utils.a
++ utils/libsub_utils.a \
++ @PTHREAD_LIBS@
+
+ rtorrent_SOURCES = \
+ main.cc
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 0eecb06..cf52bf5 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -324,7 +324,8 @@ rtorrent_LDADD = \
+ display/libsub_display.a \
+ input/libsub_input.a \
+ rpc/libsub_rpc.a \
+- utils/libsub_utils.a
++ utils/libsub_utils.a \
++ @PTHREAD_LIBS@
+
+ rtorrent_SOURCES = \
+ main.cc
diff --git a/net-p2p/rtorrent/rtorrent-0.9.0.ebuild b/net-p2p/rtorrent/rtorrent-0.9.0.ebuild
index b7f6a439af8b..120937e1dcc5 100644
--- a/net-p2p/rtorrent/rtorrent-0.9.0.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.9.0.ebuild,v 1.1 2012/03/08 04:34:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.9.0.ebuild,v 1.2 2012/03/08 07:59:22 jlec Exp $
EAPI=2
@@ -29,6 +29,7 @@ DEPEND="${COMMON_DEPEND}
src_prepare() {
# bug #358271
epatch "${FILESDIR}"/${P}-ncurses.patch
+ epatch "${FILESDIR}"/${P}-gold.patch
use color && EPATCH_OPTS="-p1" epatch "${FILESDIR}"/${P}-canvas-fix.patch
}
@@ -42,7 +43,7 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die
- dodoc AUTHORS README TODO doc/rtorrent.rc
+ dodoc AUTHORS README doc/rtorrent.rc
if use daemon; then
newinitd "${FILESDIR}/rtorrentd.init" rtorrentd || die "newinitd failed"