summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2010-04-11 17:52:42 +0000
committerRaúl Porcel <armin76@gentoo.org>2010-04-11 17:52:42 +0000
commitdf79dee4fc06bdbb4d8212fdb9bbbb0a89a56067 (patch)
treeddc48867673651ca0e0d1f81c666ca7f35b16bd3 /net-p2p
parentx86 stable wrt bug #311603 (diff)
downloadgentoo-2-df79dee4fc06bdbb4d8212fdb9bbbb0a89a56067.tar.gz
gentoo-2-df79dee4fc06bdbb4d8212fdb9bbbb0a89a56067.tar.bz2
gentoo-2-df79dee4fc06bdbb4d8212fdb9bbbb0a89a56067.zip
Add patch from debian to build on hppa wrt #312831
(Portage version: 2.1.7.17/cvs/Linux ia64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/ChangeLog6
-rw-r--r--net-p2p/amule/amule-2.2.6.ebuild6
-rw-r--r--net-p2p/amule/files/amule-2.2.6-fallocate.diff23
3 files changed, 33 insertions, 2 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index 90ca7198a847..4616a2f953b7 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/amule
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.149 2010/03/20 13:13:45 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.150 2010/04/11 17:52:42 armin76 Exp $
+
+ 11 Apr 2010; Raúl Porcel <armin76@gentoo.org> amule-2.2.6.ebuild,
+ +files/amule-2.2.6-fallocate.diff:
+ Add patch from debian to build on hppa wrt #312831
20 Mar 2010; Raúl Porcel <armin76@gentoo.org> amule-2.2.6.ebuild:
alpha/x86 stable wrt #309293
diff --git a/net-p2p/amule/amule-2.2.6.ebuild b/net-p2p/amule/amule-2.2.6.ebuild
index 28b6fb44f497..d021a41ad5e8 100644
--- a/net-p2p/amule/amule-2.2.6.ebuild
+++ b/net-p2p/amule/amule-2.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.6.ebuild,v 1.5 2010/03/20 13:13:45 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.6.ebuild,v 1.6 2010/04/11 17:52:42 armin76 Exp $
EAPI="2"
@@ -50,6 +50,10 @@ pkg_preinst() {
fi
}
+src_unpack() {
+ epatch "${FILESDIR}"/${P}-fallocate.diff
+}
+
src_configure() {
local myconf
diff --git a/net-p2p/amule/files/amule-2.2.6-fallocate.diff b/net-p2p/amule/files/amule-2.2.6-fallocate.diff
new file mode 100644
index 000000000000..8d1485a67786
--- /dev/null
+++ b/net-p2p/amule/files/amule-2.2.6-fallocate.diff
@@ -0,0 +1,23 @@
+Disable fallocate #562992
+
+This is only a workaround to fix FTBFS, the configure check is wrong and needs to be fixed:
+http://www.amule.org/abugs/view.php?id=1572
+
+--- a/src/ThreadTasks.cpp
++++ b/src/ThreadTasks.cpp
+@@ -506,6 +506,15 @@ void CCompletionTask::OnExit()
+ #include <stdlib.h>
+ #include <errno.h>
+
++// #562992
++#if defined(__alpha__) || defined(__hppa__)
++#undef HAVE_FALLOCATE
++#endif
++
++#if defined(__hppa__)
++#undef HAVE_SYS_FALLOCATE
++#endif
++
+ CAllocateFileTask::CAllocateFileTask(CPartFile *file, bool pause)
+ // GetPrintable is used to improve the readability of the log.
+ : CThreadTask(wxT("Allocating"), file->GetFullName().RemoveExt().GetPrintable(), ETP_High),