summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-10-31 16:11:14 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-10-31 16:11:14 +0000
commitadccfce6d7d726cd7d33591db87e9e33e7382c9a (patch)
tree9f1248c5c0126cccf494fe76192df78fe2588f1d /net-p2p
parentFix pam_console_apply -r segfaulting if a group used in (diff)
downloadgentoo-2-adccfce6d7d726cd7d33591db87e9e33e7382c9a.tar.gz
gentoo-2-adccfce6d7d726cd7d33591db87e9e33e7382c9a.tar.bz2
gentoo-2-adccfce6d7d726cd7d33591db87e9e33e7382c9a.zip
Version bumped.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/xmule/ChangeLog7
-rw-r--r--net-p2p/xmule/files/digest-xmule-1.9.31
-rw-r--r--net-p2p/xmule/xmule-1.9.3.ebuild48
3 files changed, 55 insertions, 1 deletions
diff --git a/net-p2p/xmule/ChangeLog b/net-p2p/xmule/ChangeLog
index 5d8ddc1bdc4b..784939063199 100644
--- a/net-p2p/xmule/ChangeLog
+++ b/net-p2p/xmule/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/xmule
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/ChangeLog,v 1.50 2004/10/26 02:35:18 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/ChangeLog,v 1.51 2004/10/31 16:11:14 mholzer Exp $
+
+*xmule-1.9.3 (31 Oct 2004)
+
+ 31 Oct 2004; Martin Holzer <mholzer@gentoo.org> +xmule-1.9.3.ebuild:
+ Version bumped.
*xmule-1.9.2 (25 Oct 2004)
diff --git a/net-p2p/xmule/files/digest-xmule-1.9.3 b/net-p2p/xmule/files/digest-xmule-1.9.3
new file mode 100644
index 000000000000..aeba2512cf93
--- /dev/null
+++ b/net-p2p/xmule/files/digest-xmule-1.9.3
@@ -0,0 +1 @@
+MD5 1c5acb30f0af4bddcef7355ab6e06ce5 xmule-1.9.3.tar.bz2 1392679
diff --git a/net-p2p/xmule/xmule-1.9.3.ebuild b/net-p2p/xmule/xmule-1.9.3.ebuild
new file mode 100644
index 000000000000..7b4b4f992044
--- /dev/null
+++ b/net-p2p/xmule/xmule-1.9.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.9.3.ebuild,v 1.1 2004/10/31 16:11:14 mholzer Exp $
+
+inherit wxwidgets
+
+DESCRIPTION="wxWidgets based client for the eDonkey/eMule/lMule network"
+HOMEPAGE="http://xmule.ws/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2 ZLIB GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+IUSE="nls gtk2 debug"
+
+DEPEND=">=x11-libs/wxGTK-2.4.2-r2
+ nls? ( sys-devel/gettext )
+ >=sys-libs/zlib-1.2.1
+ !net-p2p/amule"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's/@datadir@/${DESTDIR}@datadir@/' Makefile.in || die
+}
+
+src_compile () {
+ local myconf=
+
+ if ! use gtk2 ; then
+ need-wxwidgets gtk
+ else
+ need-wxwidgets gtk2
+ fi
+
+ myconf="${myconf} --with-zlib=/tmp/zlib/"
+
+ myconf="${myconf} `use_enable debug` `use_enable nls`"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ einstall mkinstalldirs=${S}/mkinstalldirs DESTDIR=${D} || die
+ rm -rf ${D}/var || die
+}