summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-01-17 11:42:27 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-01-17 11:42:27 +0000
commit9599fd74fdc20df69e7bd2ab6185c1f8ba2419d5 (patch)
tree92d9636039189eb596a2710bb11127c7f0da591c /net-p2p
parentInitial commit for net-analyzer/nagios-check_ipmi_sensor. (diff)
downloadgentoo-2-9599fd74fdc20df69e7bd2ab6185c1f8ba2419d5.tar.gz
gentoo-2-9599fd74fdc20df69e7bd2ab6185c1f8ba2419d5.tar.bz2
gentoo-2-9599fd74fdc20df69e7bd2ab6185c1f8ba2419d5.zip
old
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/ChangeLog5
-rw-r--r--net-p2p/ktorrent/ktorrent-3.3.4.ebuild90
2 files changed, 4 insertions, 91 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index 4d295f7fed3a..a6e26e939943 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.161 2011/01/17 01:08:40 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.162 2011/01/17 11:42:27 scarabeus Exp $
+
+ 17 Jan 2011; Tomáš Chvátal <scarabeus@gentoo.org> -ktorrent-3.3.4.ebuild:
+ old
17 Jan 2011; Brent Baude <ranger@gentoo.org> ktorrent-4.0.5.ebuild:
Marking ktorrent-4.0.5 ppc for bug 350970
diff --git a/net-p2p/ktorrent/ktorrent-3.3.4.ebuild b/net-p2p/ktorrent/ktorrent-3.3.4.ebuild
deleted file mode 100644
index 8fedf76c1502..000000000000
--- a/net-p2p/ktorrent/ktorrent-3.3.4.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-3.3.4.ebuild,v 1.7 2010/06/21 17:02:51 ssuominen Exp $
-
-EAPI="2"
-
-if [[ ${PV} == *9999* ]] ; then
- KEYWORDS=""
- KMNAME="extragear/network"
-else
- # upstream likes to skip that _ in beta releases
- MY_PV="${PV/_/}"
- MY_P="${PN}-${MY_PV}"
-
- KDE_LINGUAS="ar be bg ca cs da de el en_GB es et eu fr ga gl hi hne hr hu is it
- ja km lt lv mai ms nb nds nl nn oc pl pt pt_BR ro ru se sk sl sr sv
- tr uk zh_CN zh_TW"
- KEYWORDS="amd64 ppc ~ppc64 x86"
- SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
- S="${WORKDIR}"/"${MY_P}"
-fi
-
-inherit kde4-base
-
-DESCRIPTION="A BitTorrent program for KDE."
-HOMEPAGE="http://ktorrent.org/"
-
-LICENSE="GPL-2"
-SLOT="4"
-IUSE="+bwscheduler debug +downloadorder +infowidget +ipfilter +kross +logviewer
-+mediaplayer plasma rss +scanfolder +search +shutdown +stats +upnp webinterface +zeroconf"
-
-COMMONDEPEND="
- app-crypt/qca:2
- dev-libs/gmp
- mediaplayer? ( >=media-libs/taglib-1.5 )
- plasma? ( >=kde-base/libtaskmanager-${KDE_MINIMAL} )
- rss? (
- >=kde-base/kdepimlibs-${KDE_MINIMAL}
- )
- shutdown? (
- >=kde-base/solid-${KDE_MINIMAL}
- )
-"
-DEPEND="${COMMONDEPEND}
- sys-devel/gettext
-"
-RDEPEND="${COMMONDEPEND}
- kde-base/oxygen-icons
- infowidget? ( >=dev-libs/geoip-1.4.4 )
- ipfilter? (
- app-arch/bzip2
- app-arch/unzip
- >=kde-base/kdebase-kioslaves-${KDE_MINIMAL}
- )
- kross? ( >=kde-base/krosspython-${KDE_MINIMAL} )
-"
-
-src_prepare() {
- if ! use plasma; then
- sed -i \
- -e "s:add_subdirectory(plasma):#nada:g" \
- CMakeLists.txt || die "Failed to make plasmoid optional"
- fi
-
- kde4-base_src_prepare
-}
-
-src_configure() {
- mycmakeargs="${mycmakeargs}
- -DENABLE_DHT_SUPPORT=ON
- -DWITH_SYSTEM_GEOIP=ON
- $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
- $(cmake-utils_use_enable downloadorder DOWNLOADORDER_PLUGIN)
- $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
- $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
- $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
- $(cmake-utils_use_enable kross SCRIPTING_PLUGIN)
- $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
- $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)
- $(cmake-utils_use_enable rss SYNDICATION_PLUGIN)
- $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
- $(cmake-utils_use_enable search SEARCH_PLUGIN)
- $(cmake-utils_use_enable shutdown SHUTDOWN_PLUGIN)
- $(cmake-utils_use_enable stats STATS_PLUGIN)
- $(cmake-utils_use_enable upnp UPNP_PLUGIN)
- $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
- $(cmake-utils_use_enable zeroconf ZEROCONF_PLUGIN)"
- kde4-base_src_configure
-}