summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-03-26 21:46:04 +0000
committerBen de Groot <yngwin@gentoo.org>2010-03-26 21:46:04 +0000
commit907dde54abc194d9f77c4a704dae25eb0d417f88 (patch)
tree7ead3b159f182f1cf1b8e1b41d5e6c183a9b754f /net-p2p
parentdev-util/cvs2svn: Remove (renamed to dev-vcs/cvs2svn) (diff)
downloadgentoo-2-907dde54abc194d9f77c4a704dae25eb0d417f88.tar.gz
gentoo-2-907dde54abc194d9f77c4a704dae25eb0d417f88.tar.bz2
gentoo-2-907dde54abc194d9f77c4a704dae25eb0d417f88.zip
Remove old versions. Add slotted boost detection to fix bug #309415.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.5.5.ebuild45
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.1.6.ebuild51
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.2.0.ebuild51
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.2.2.ebuild13
5 files changed, 17 insertions, 150 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 2b1bc53e65d7..d541e51749cb 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.76 2010/03/25 18:12:10 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.77 2010/03/26 21:46:04 yngwin Exp $
+
+ 26 Mar 2010; Ben de Groot <yngwin@gentoo.org> -qbittorrent-1.5.5.ebuild,
+ -qbittorrent-2.1.6.ebuild, -qbittorrent-2.2.0.ebuild,
+ qbittorrent-2.2.2.ebuild:
+ Remove old versions. Add slotted boost detection to fix bug #309415.
*qbittorrent-2.2.2 (25 Mar 2010)
diff --git a/net-p2p/qbittorrent/qbittorrent-1.5.5.ebuild b/net-p2p/qbittorrent/qbittorrent-1.5.5.ebuild
deleted file mode 100644
index 1bc59edcd632..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-1.5.5.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.5.5.ebuild,v 1.3 2009/12/28 21:29:42 maekke Exp $
-
-EAPI="2"
-inherit eutils qt4 multilib
-
-MY_P="${P/_/}"
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-# boost version so that we always have thread support
-DEPEND=" x11-libs/qt-gui:4
- >=net-libs/rb_libtorrent-0.14.6
- >=dev-libs/boost-1.34.1
- dev-libs/zziplib
- net-misc/curl
- dev-cpp/commoncpp2"
-RDEPEND="${DEPEND}
- >=dev-lang/python-2.3"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
- qt4_src_prepare
-}
-
-src_configure() {
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr || die "configure failed"
- eqmake4
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
- dodoc AUTHORS Changelog NEWS README TODO
-}
diff --git a/net-p2p/qbittorrent/qbittorrent-2.1.6.ebuild b/net-p2p/qbittorrent/qbittorrent-2.1.6.ebuild
deleted file mode 100644
index 57da26964624..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-2.1.6.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.1.6.ebuild,v 1.1 2010/03/07 21:50:36 wired Exp $
-
-EAPI="2"
-inherit confutils qt4-r2
-
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+X geoip libnotify"
-
-# boost version so that we always have thread support
-CDEPEND="net-libs/rb_libtorrent
- x11-libs/qt-core:4
- X? ( x11-libs/qt-gui:4
- libnotify? ( x11-libs/qt-gui:4[glib] ) )
- >=dev-libs/boost-1.34.1"
-DEPEND="${CDEPEND}
- dev-util/pkgconfig"
-RDEPEND="${CDEPEND}
- >=dev-lang/python-2.3
- geoip? ( dev-libs/geoip )
- libnotify? ( x11-libs/libnotify )"
-
-DOCS="AUTHORS Changelog NEWS README TODO"
-
-pkg_setup() {
- confutils_use_depend_all libnotify X
-}
-
-src_prepare() {
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
- qt4-r2_src_prepare
-}
-
-src_configure() {
- local myconf
- use X || myconf+=" --disable-gui"
- use geoip || myconf+=" --disable-geoip-database"
- use libnotify || myconf+=" --disable-libnotify"
-
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
- eqmake4
-}
diff --git a/net-p2p/qbittorrent/qbittorrent-2.2.0.ebuild b/net-p2p/qbittorrent/qbittorrent-2.2.0.ebuild
deleted file mode 100644
index c381072ef5a8..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-2.2.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.0.ebuild,v 1.1 2010/03/18 20:41:28 yngwin Exp $
-
-EAPI="2"
-inherit confutils qt4-r2
-
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+X geoip libnotify"
-
-# boost version so that we always have thread support
-CDEPEND="net-libs/rb_libtorrent
- x11-libs/qt-core:4
- X? ( x11-libs/qt-gui:4
- libnotify? ( x11-libs/qt-gui:4[glib] ) )
- >=dev-libs/boost-1.34.1"
-DEPEND="${CDEPEND}
- dev-util/pkgconfig"
-RDEPEND="${CDEPEND}
- >=dev-lang/python-2.3
- geoip? ( dev-libs/geoip )
- libnotify? ( x11-libs/libnotify )"
-
-DOCS="AUTHORS Changelog NEWS README TODO"
-
-pkg_setup() {
- confutils_use_depend_all libnotify X
-}
-
-src_prepare() {
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
- qt4-r2_src_prepare
-}
-
-src_configure() {
- local myconf
- use X || myconf+=" --disable-gui"
- use geoip || myconf+=" --disable-geoip-database"
- use libnotify || myconf+=" --disable-libnotify"
-
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
- eqmake4
-}
diff --git a/net-p2p/qbittorrent/qbittorrent-2.2.2.ebuild b/net-p2p/qbittorrent/qbittorrent-2.2.2.ebuild
index 7734ca277ba0..d3c479100e75 100644
--- a/net-p2p/qbittorrent/qbittorrent-2.2.2.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-2.2.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.2.ebuild,v 1.1 2010/03/25 18:12:10 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.2.ebuild,v 1.2 2010/03/26 21:46:04 yngwin Exp $
EAPI="2"
-inherit confutils qt4-r2
+inherit confutils qt4-r2 versionator
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="http://www.qbittorrent.org/"
@@ -45,7 +45,16 @@ src_configure() {
use geoip || myconf+=" --disable-geoip-database"
use libnotify || myconf+=" --disable-libnotify"
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
# econf fails, since this uses qconf
./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
eqmake4
+
+ # link to the correct slotted boost version, bug #309415
+ sed -i "s/-mt/-mt-${BOOST_VER}/g" conf.pri
}