summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2010-08-30 20:53:35 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2010-08-30 20:53:35 +0000
commit2685b2651e8fb8b47a88fec652c76591950be0a1 (patch)
treec28cc5fe54b548aae13d541cda720feab38c2686 /net-p2p
parentVersion bump. Clean up old revisions. Make ewarn display a bit more logical, ... (diff)
downloadgentoo-2-2685b2651e8fb8b47a88fec652c76591950be0a1.tar.gz
gentoo-2-2685b2651e8fb8b47a88fec652c76591950be0a1.tar.bz2
gentoo-2-2685b2651e8fb8b47a88fec652c76591950be0a1.zip
Rebase to 4.20.9 version. Upstream not providing source tarballs anymore,
so we use just binary package. Most dependencies are bundled unfortunately (Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/frostwire/ChangeLog11
-rw-r--r--net-p2p/frostwire/frostwire-4.13.5-r1.ebuild4
-rw-r--r--net-p2p/frostwire/frostwire-4.20.9.ebuild84
3 files changed, 95 insertions, 4 deletions
diff --git a/net-p2p/frostwire/ChangeLog b/net-p2p/frostwire/ChangeLog
index 1d9d90fb778b..5aadd5c1341b 100644
--- a/net-p2p/frostwire/ChangeLog
+++ b/net-p2p/frostwire/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/frostwire
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/frostwire/ChangeLog,v 1.8 2009/07/23 13:22:56 ali_bush Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/frostwire/ChangeLog,v 1.9 2010/08/30 20:53:35 sochotnicky Exp $
+
+*frostwire-4.20.9 (30 Aug 2010)
+
+ 30 Aug 2010; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ +frostwire-4.20.9.ebuild:
+ Rebase to 4.20.9 version. Upstream not providing source tarballs anymore,
+ so we use just binary package.
23 Jul 2009; Alistair Bush <ali_bush@gentoo.org>
frostwire-4.13.5-r1.ebuild:
diff --git a/net-p2p/frostwire/frostwire-4.13.5-r1.ebuild b/net-p2p/frostwire/frostwire-4.13.5-r1.ebuild
index ecbae6f13963..62ff4ae76b5e 100644
--- a/net-p2p/frostwire/frostwire-4.13.5-r1.ebuild
+++ b/net-p2p/frostwire/frostwire-4.13.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/frostwire/frostwire-4.13.5-r1.ebuild,v 1.4 2009/07/23 13:22:56 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/frostwire/frostwire-4.13.5-r1.ebuild,v 1.5 2010/08/30 20:53:35 sochotnicky Exp $
EAPI=1
JAVA_PKG_IUSE="source"
@@ -10,7 +10,7 @@ inherit java-pkg-2 java-ant-2
DESCRIPTION="Frostwire Java Gnutella client"
HOMEPAGE="http://www.frostwire.com"
SRC_URI="http://www.frostwire.com/frostwire/${PV}/${P}.src.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
#IUSE="gtk"
diff --git a/net-p2p/frostwire/frostwire-4.20.9.ebuild b/net-p2p/frostwire/frostwire-4.20.9.ebuild
new file mode 100644
index 000000000000..b84946b14760
--- /dev/null
+++ b/net-p2p/frostwire/frostwire-4.20.9.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/frostwire/frostwire-4.20.9.ebuild,v 1.1 2010/08/30 20:53:35 sochotnicky Exp $
+
+EAPI=2
+
+inherit java-pkg-2
+
+DESCRIPTION="Frostwire Java Gnutella client"
+HOMEPAGE="http://www.frostwire.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.noarch.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-java/aopalliance
+ dev-java/commons-logging
+ dev-java/commons-net
+ dev-java/icu4j:0
+ dev-java/jgoodies-looks:1.2
+ dev-java/jmdns
+ dev-java/jython:0
+ dev-java/log4j
+ dev-java/xml-commons-external
+ >=virtual/jre-1.4"
+
+S="${WORKDIR}/${P}.noarch"
+
+PREFIX="/usr/share/${PN}"
+
+src_prepare() {
+ rm -fR commons-logging.jar commons-codec-1.3.jar \
+ log4j.jar icu4j.jar jmdns.jar jython.jar \
+ aopalliance.jar looks.jar forms.jar \
+ junit.jar
+
+ java-pkg_getjars commons-logging,commons-codec
+ java-pkg_getjars log4j,icu4j,jmdns,jython,aopalliance-1
+ java-pkg_getjars jgoodies-looks-1.2,junit
+}
+
+src_install() {
+ java-pkg_dojar "${S}/FrostWire.jar"
+ java-pkg_dojar "${S}/themes.jar"
+ java-pkg_dojar "${S}/splash.jar"
+
+ # Install resources for Frostwire. Don't let the jars deceive ya :)
+ # These are directly required, not sure of source atm
+ pushd "${D}/usr/share/${PN}"
+ ln -s lib/themes.jar
+ popd
+
+ # Bundled jars, yeah I know throw up in your mouth some
+ # but registering them you say, only doing so for launcher
+ bjs="clink.jar daap.jar httpclient-4.0.jar httpcore-4.0.1.jar \
+ httpcore-nio-4.0.1.jar foxtrot.jar gettext-commons.jar \
+ gson-1.4.jar guice-1.0.jar jaudiotagger.jar \
+ jcip-annotations.jar jcraft.jar jdic.jar jdic_stub.jar \
+ jflac.jar jl.jar messages.jar mp3spi.jar onion-common.jar \
+ onion-fec.jar ProgressTabs.jar tritonus.jar vorbisspi.jar \
+ lw-azureus.jar lw-collection.jar lw-common.jar lw-http.jar \
+ lw-io.jar lw-mojito.jar lw-net.jar lw-nio.jar \
+ lw-resources.jar lw-rudp.jar lw-security.jar lw-setting.jar \
+ lw-statistic.jar \
+ "
+ for bj in ${bjs}; do
+ java-pkg_dojar "${bj}"
+ done
+
+ touch "${D}/${PREFIX}/hashes"
+
+ java-pkg_dolauncher ${PN} \
+ --main com.limegroup.gnutella.gui.Main \
+ --java_args "-Xms64m -Xmx128m -ea -Dorg.apache.commons.logging.Log=org.apache.commons.logging.impl.NoOpLog" \
+ --pwd /usr/share/${PN}
+
+ insinto /usr/share/pixmaps
+ doins FrostWire.icns
+
+ make_desktop_entry frostwire FrostWire
+
+ dodoc EULA.txt
+}