summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-07-21 20:50:48 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-07-21 20:50:48 +0000
commit16a3042e54d207eeaaf0c8cf2b37f3be85f4fe2f (patch)
tree656798b43a97bc528e962dc409ce32630e099dd5 /net-p2p
parentStable on alpha, bug 97595. (diff)
downloadgentoo-2-16a3042e54d207eeaaf0c8cf2b37f3be85f4fe2f.tar.gz
gentoo-2-16a3042e54d207eeaaf0c8cf2b37f3be85f4fe2f.tar.bz2
gentoo-2-16a3042e54d207eeaaf0c8cf2b37f3be85f4fe2f.zip
Version bump, bug #99458
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittorrent/ChangeLog8
-rw-r--r--net-p2p/bittorrent/bittorrent-4.1.3.ebuild80
-rw-r--r--net-p2p/bittorrent/files/btdownloadgui.desktop7
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-4.1.31
4 files changed, 95 insertions, 1 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index c0a81ff81868..e34eefd5d4eb 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.50 2005/06/14 21:18:10 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.51 2005/07/21 20:50:48 sekretarz Exp $
+
+*bittorrent-4.1.3 (21 Jul 2005)
+
+ 21 Jul 2005; <sekretarz@gentoo.org> +files/btdownloadgui.desktop,
+ +bittorrent-4.1.3.ebuild:
+ Version bump, bug #99458
*bittorrent-4.1.2 (14 Jun 2005)
diff --git a/net-p2p/bittorrent/bittorrent-4.1.3.ebuild b/net-p2p/bittorrent/bittorrent-4.1.3.ebuild
new file mode 100644
index 000000000000..0cf901fa40b3
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-4.1.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.1.3.ebuild,v 1.1 2005/07/21 20:50:48 sekretarz Exp $
+
+inherit distutils fdo-mime
+
+MY_P="${P/bittorrent/BitTorrent}"
+#MY_P="${MY_P/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://www.bittorrent.com/"
+SRC_URI="http://www.bittorrent.com/dl/${MY_P}.tar.gz"
+
+LICENSE="BitTorrent"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~sparc ~alpha"
+IUSE="X"
+
+RDEPEND="X? (
+ >=x11-libs/gtk+-2.4
+ >=dev-python/pygtk-2.4
+ )
+ >=dev-lang/python-2.3
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/gzip
+ >=sys-apps/sed-4.0.5
+ dev-python/dnspython"
+PROVIDE="virtual/bittorrent"
+
+DOCS="credits.txt"
+PYTHON_MODNAME="BitTorrent"
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+ dohtml redirdonate.html
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+
+ if use X ; then
+ cp ${D}/usr/share/pixmaps/${MY_P}/bittorrent.ico ${D}/usr/share/pixmaps/
+ dodir /usr/share/applications
+ insinto /usr/share/applications
+ doins ${FILESDIR}/btdownloadgui.desktop
+ fi
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/bttrack.conf bttrack
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bttrack.rc bttrack
+}
+
+pkg_postinst() {
+ einfo "BitTorrent has changed to the BitTorrent Open Source License"
+ einfo ">> http://www.bittorrent.com/license/"
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/bittorrent/files/btdownloadgui.desktop b/net-p2p/bittorrent/files/btdownloadgui.desktop
new file mode 100644
index 000000000000..c060278b7fad
--- /dev/null
+++ b/net-p2p/bittorrent/files/btdownloadgui.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=BitTorrent
+Exec=/usr/bin/btdownloadgui.py
+Icon=/usr/share/pixmaps/bittorrent.ico
+Terminal=false
+Type=Application
+Categories=Application;Network;
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-4.1.3 b/net-p2p/bittorrent/files/digest-bittorrent-4.1.3
new file mode 100644
index 000000000000..5d9c16ce968a
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-4.1.3
@@ -0,0 +1 @@
+MD5 cd4dff145b5dea3789fa384bb94a4de9 BitTorrent-4.1.3.tar.gz 850332