summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-09-22 21:21:21 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-09-22 21:21:21 +0000
commit013b877c117ebc7c7a23ed87c2831399115270ba (patch)
tree3ba5fca9191b5ca0a7a8569452353da7cf6066bf /net-p2p
parentrevbump for segfault fix (bug #192668) (diff)
downloadgentoo-2-013b877c117ebc7c7a23ed87c2831399115270ba.tar.gz
gentoo-2-013b877c117ebc7c7a23ed87c2831399115270ba.tar.bz2
gentoo-2-013b877c117ebc7c7a23ed87c2831399115270ba.zip
version bump from upstream
(Portage version: 2.1.3.9)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/ChangeLog8
-rw-r--r--net-p2p/transmission/files/digest-transmission-0.823
-rw-r--r--net-p2p/transmission/transmission-0.82.ebuild42
3 files changed, 52 insertions, 1 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index 596d40140c0d..ada4af455cde 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/transmission
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.29 2007/08/29 02:34:58 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.30 2007/09/22 21:21:20 compnerd Exp $
+
+*transmission-0.82 (22 Sep 2007)
+
+ 22 Sep 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+ +transmission-0.82.ebuild:
+ Version bump from upstream.
*transmission-0.81 (29 Aug 2007)
diff --git a/net-p2p/transmission/files/digest-transmission-0.82 b/net-p2p/transmission/files/digest-transmission-0.82
new file mode 100644
index 000000000000..e74bce789f80
--- /dev/null
+++ b/net-p2p/transmission/files/digest-transmission-0.82
@@ -0,0 +1,3 @@
+MD5 ddc7842b4c8f7882d90dcf874019ccdc transmission-0.82.tar.gz 2272308
+RMD160 29bed8cf5fc2a41d01f9f08ab8014ad122225d57 transmission-0.82.tar.gz 2272308
+SHA256 98ee0d2b551290e6ad207d0b79cace2643789df2a1d9677f9ce64f617e14e82d transmission-0.82.tar.gz 2272308
diff --git a/net-p2p/transmission/transmission-0.82.ebuild b/net-p2p/transmission/transmission-0.82.ebuild
new file mode 100644
index 000000000000..ac46c5d3654c
--- /dev/null
+++ b/net-p2p/transmission/transmission-0.82.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-0.82.ebuild,v 1.1 2007/09/22 21:21:20 compnerd Exp $
+
+inherit eutils
+
+DESCRIPTION="Simple BitTorrent client"
+HOMEPAGE="http://transmission.m0k.org/"
+SRC_URI="http://download.m0k.org/transmission/files/${PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="daemon gtk wxwindows"
+
+RDEPEND="sys-devel/gettext
+ dev-libs/openssl
+ >=dev-libs/glib-2.6
+ daemon? ( dev-libs/libevent )
+ gtk? ( >=x11-libs/gtk+-2.6 )
+ wxwindows? ( >=x11-libs/wxGTK-2.6 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix man page install location
+ sed -i -e 's|/man/man1|/share/man/man1|' mk/common.mk
+}
+
+src_compile() {
+ econf $(use_enable daemon) $(use_enable gtk) $(use_with wxwindows wx) || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS README
+}