summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-27 16:59:02 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-27 16:59:02 +0000
commitb4036eba721cbc704f251d768f6184af5243b186 (patch)
treefb924df68130a54be179eaf2a18eaef3f8a2aaf0 /net-p2p/rtorrent
parentVersion bump. (diff)
downloadgentoo-2-b4036eba721cbc704f251d768f6184af5243b186.tar.gz
gentoo-2-b4036eba721cbc704f251d768f6184af5243b186.tar.bz2
gentoo-2-b4036eba721cbc704f251d768f6184af5243b186.zip
Version bump.
(Portage version: 2.1.5.2)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/rtorrent-0.8.2.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index b7e180653b4c..e3e3b4136dc9 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.107 2008/04/21 15:08:51 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.108 2008/05/27 16:59:02 drac Exp $
+
+*rtorrent-0.8.2 (27 May 2008)
+
+ 27 May 2008; Samuli Suominen <drac@gentoo.org> +rtorrent-0.8.2.ebuild:
+ Version bump.
21 Apr 2008; Diego Pettenò <flameeyes@gentoo.org>
+files/rtorrent-0.8.0+gcc-4.3.patch, rtorrent-0.8.0.ebuild:
diff --git a/net-p2p/rtorrent/rtorrent-0.8.2.ebuild b/net-p2p/rtorrent/rtorrent-0.8.2.ebuild
new file mode 100644
index 000000000000..629a75b7d194
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.8.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.2.ebuild,v 1.1 2008/05/27 16:59:02 drac Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6 xmlrpc"
+
+DEPEND=">=net-libs/libtorrent-0.12.${PV##*.}
+ >=dev-libs/libsigc++-2
+ >=net-misc/curl-7.15
+ sys-libs/ncurses
+ xmlrpc? ( dev-libs/xmlrpc-c )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.8.0+gcc-4.3.patch
+}
+
+src_compile() {
+ replace-flags -Os -O2
+ append-flags -fno-strict-aliasing
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with xmlrpc xmlrpc-c) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ elog "rtorrent now supports a configuration file."
+ elog "A sample configuration file for rtorrent is can be found"
+ elog "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}