summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-01 10:52:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-01 10:52:00 +0000
commit8f4ba224b03fd0d61ea6c8e552c15d4a6749f1dd (patch)
tree64bc1f12e9483af507cfe7b0b222447ab6e93b6c /net-p2p/nicotine+
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-8f4ba224b03fd0d61ea6c8e552c15d4a6749f1dd.tar.gz
gentoo-2-8f4ba224b03fd0d61ea6c8e552c15d4a6749f1dd.tar.bz2
gentoo-2-8f4ba224b03fd0d61ea6c8e552c15d4a6749f1dd.zip
Set PYTHON_MODNAME. Delete call to deprecated distutils_python_version().
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/nicotine+')
-rw-r--r--net-p2p/nicotine+/ChangeLog6
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.14.ebuild12
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.15.ebuild6
3 files changed, 15 insertions, 9 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index eb29112cc59d..8255c93840b7 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/nicotine+
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.45 2010/03/08 03:29:41 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.46 2010/06/01 10:52:00 arfrever Exp $
+
+ 01 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ nicotine+-1.2.14.ebuild, nicotine+-1.2.15.ebuild:
+ Set PYTHON_MODNAME. Delete call to deprecated distutils_python_version().
08 Mar 2010; Ryan Hill <dirtyepic@gentoo.org> nicotine+-1.2.15.ebuild:
More python fixedness.
diff --git a/net-p2p/nicotine+/nicotine+-1.2.14.ebuild b/net-p2p/nicotine+/nicotine+-1.2.14.ebuild
index 114912fdb2b5..4590a7318a64 100644
--- a/net-p2p/nicotine+/nicotine+-1.2.14.ebuild
+++ b/net-p2p/nicotine+/nicotine+-1.2.14.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.14.ebuild,v 1.3 2009/11/21 18:50:26 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.14.ebuild,v 1.4 2010/06/01 10:52:00 arfrever Exp $
-inherit distutils multilib toolchain-funcs
+inherit distutils
DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
HOMEPAGE="http://nicotine-plus.sourceforge.net"
@@ -24,9 +24,9 @@ RDEPEND="virtual/python
DEPEND="${RDEPEND}"
+PYTHON_MODNAME="pynicotine"
+
src_install() {
- distutils_python_version
- distutils_src_install \
- --install-lib /usr/$(get_libdir)/python${PYVER}/site-packages
+ distutils_src_install
dosym nicotine.py /usr/bin/nicotine
}
diff --git a/net-p2p/nicotine+/nicotine+-1.2.15.ebuild b/net-p2p/nicotine+/nicotine+-1.2.15.ebuild
index d7726d40ea2f..6f66d08e8899 100644
--- a/net-p2p/nicotine+/nicotine+-1.2.15.ebuild
+++ b/net-p2p/nicotine+/nicotine+-1.2.15.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.15.ebuild,v 1.3 2010/03/08 03:29:41 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.15.ebuild,v 1.4 2010/06/01 10:52:00 arfrever Exp $
EAPI="2"
PYTHON_DEPEND="2"
-inherit distutils python
+inherit distutils
DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
HOMEPAGE="http://nicotine-plus.sourceforge.net"
@@ -25,6 +25,8 @@ RDEPEND=">=dev-python/pygtk-2.12
DEPEND="${RDEPEND}"
+PYTHON_MODNAME="pynicotine"
+
pkg_setup() {
python_set_active_version 2
}