summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-01-08 20:27:04 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-01-08 20:27:04 +0000
commit114fa8aab138784072876426f6e6b7a05d567a2d (patch)
tree8c2f69f838221ca00924c5fa775d71a541b9b980 /net-p2p/nicotine+
parentFixed a couple of things as upstream have no --disable :( (diff)
downloadgentoo-2-114fa8aab138784072876426f6e6b7a05d567a2d.tar.gz
gentoo-2-114fa8aab138784072876426f6e6b7a05d567a2d.tar.bz2
gentoo-2-114fa8aab138784072876426f6e6b7a05d567a2d.zip
Version bump, bug 144454
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-p2p/nicotine+')
-rw-r--r--net-p2p/nicotine+/ChangeLog10
-rw-r--r--net-p2p/nicotine+/files/digest-nicotine+-1.2.63
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.6.ebuild47
3 files changed, 58 insertions, 2 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index 0410473ee4f6..41160d44101d 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/nicotine+
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.5 2006/12/17 16:20:44 dertobi123 Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.6 2007/01/08 20:27:04 armin76 Exp $
+
+*nicotine+-1.2.6 (08 Jan 2007)
+
+ 08 Jan 2007; Raúl Porcel (armin76) <armin76@gentoo.org>
+ +nicotine+-1.2.6.ebuild:
+ Version bump, bug 144454
17 Dec 2006; Tobias Scherbaum <dertobi123@gentoo.org>
nicotine+-1.2.3.ebuild:
diff --git a/net-p2p/nicotine+/files/digest-nicotine+-1.2.6 b/net-p2p/nicotine+/files/digest-nicotine+-1.2.6
new file mode 100644
index 000000000000..6f78d36056bd
--- /dev/null
+++ b/net-p2p/nicotine+/files/digest-nicotine+-1.2.6
@@ -0,0 +1,3 @@
+MD5 845b071c235a1ae7b19699275818ecc4 nicotine+-1.2.6.tar.bz2 611707
+RMD160 6a35394440aa2ec96efa3408cba35874860081dd nicotine+-1.2.6.tar.bz2 611707
+SHA256 de390a7ac759dbff766f9fb668610a1bdaf6b8fe46c7982790bee6e0fd766654 nicotine+-1.2.6.tar.bz2 611707
diff --git a/net-p2p/nicotine+/nicotine+-1.2.6.ebuild b/net-p2p/nicotine+/nicotine+-1.2.6.ebuild
new file mode 100644
index 000000000000..fc1d69a19150
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-1.2.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.6.ebuild,v 1.1 2007/01/08 20:27:04 armin76 Exp $
+
+inherit distutils eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="http://www.nicotine-plus.org"
+SRC_URI="mirror://sourceforge/nicotine-plus/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="vorbis geoip"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2
+ vorbis? ( >=dev-python/pyvorbis-1.4-r1
+ >=dev-python/pyogg-1 )
+ geoip? ( >=dev-python/geoip-python-0.2.0
+ >=dev-libs/geoip-1.2.1 )
+ !net-p2p/nicotine"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+src_compile() {
+ distutils_src_compile
+
+ cd "${S}"/trayicon/
+ sed -i -e "s:/lib/:/$(get_libdir)/:" \
+ Makefile.in || die "sed failed"
+ ./autogen.py
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ distutils_python_version
+ distutils_src_install --install-lib \
+ /usr/$(get_libdir)/python${PYVER}/site-packages
+
+ cd "${S}"/trayicon/
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon ${FILESDIR}/nicotine-n.png
+ domenu ${FILESDIR}/${PN}.desktop
+}