summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2007-07-06 23:51:05 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2007-07-06 23:51:05 +0000
commitd38283b61923d46d2c495029ec86a741dcde0a71 (patch)
tree69095f42707613d7d3110c7057607d82b7808e0c /net-p2p/ktorrent
parentSplit off Emacs support to package app-emacs/po-mode, bug #149431. (diff)
downloadgentoo-2-d38283b61923d46d2c495029ec86a741dcde0a71.tar.gz
gentoo-2-d38283b61923d46d2c495029ec86a741dcde0a71.tar.bz2
gentoo-2-d38283b61923d46d2c495029ec86a741dcde0a71.zip
Version bump, bug 184195
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-p2p/ktorrent')
-rw-r--r--net-p2p/ktorrent/ChangeLog7
-rw-r--r--net-p2p/ktorrent/files/digest-ktorrent-2.23
-rw-r--r--net-p2p/ktorrent/ktorrent-2.2.ebuild46
3 files changed, 55 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index f27eba06b08a..f49477c60593 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.51 2007/07/05 17:21:08 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.52 2007/07/06 23:51:05 keytoaster Exp $
+
+*ktorrent-2.2 (06 Jul 2007)
+
+ 06 Jul 2007; Tobias Heinlein <keytoaster@gentoo.org> +ktorrent-2.2.ebuild:
+ Version bump, bug 184195
05 Jul 2007; Wulf C. Krueger <philantrop@gentoo.org>
ktorrent-2.2_rc1.ebuild:
diff --git a/net-p2p/ktorrent/files/digest-ktorrent-2.2 b/net-p2p/ktorrent/files/digest-ktorrent-2.2
new file mode 100644
index 000000000000..0ff95bac4bc6
--- /dev/null
+++ b/net-p2p/ktorrent/files/digest-ktorrent-2.2
@@ -0,0 +1,3 @@
+MD5 6790dd2507895da9d1d468ba3a357277 ktorrent-2.2.tar.gz 3666182
+RMD160 54a9f38aedc71a6f0429995d49837a5e0c974e98 ktorrent-2.2.tar.gz 3666182
+SHA256 82e4865ffc7103958067fa6953decdaa675ea4cfcb158734729778198d7ed048 ktorrent-2.2.tar.gz 3666182
diff --git a/net-p2p/ktorrent/ktorrent-2.2.ebuild b/net-p2p/ktorrent/ktorrent-2.2.ebuild
new file mode 100644
index 000000000000..b34dd2ef56df
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-2.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-2.2.ebuild,v 1.1 2007/07/06 23:51:05 keytoaster Exp $
+
+inherit kde
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdeenablefinal"
+
+DEPEND="dev-libs/gmp"
+
+need-kde 3.4
+
+LANGS="ar bg br ca cs cy da de el en_GB es et fa fr gl hu it ja ka lt
+ms nds nl pa pl pt pt_BR ru rw sk sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+src_unpack() {
+ kde_src_unpack
+
+ local MAKE_LANGS
+ cd "${WORKDIR}/${MY_P}/translations"
+ for X in ${LANGS} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}"
+ done
+ rm -f ${S}/configure
+ sed -i -e "s:SUBDIRS=.*:SUBDIRS=${MAKE_LANGS}:" Makefile.am
+}
+
+src_compile(){
+ local myconf="--enable-knetwork"
+ kde_src_compile
+}