summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-09-15 08:47:18 +0000
committerPeter Volkov <pva@gentoo.org>2010-09-15 08:47:18 +0000
commitfd8ebb3df611a6d97f7545c006e9ff9288f7a2ce (patch)
treed892c56f30285d968626c182ab220547115964fc /net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
parentInitial import, bug #241120, thank Michał Górny and Nikoli for this job. (diff)
downloadgentoo-2-fd8ebb3df611a6d97f7545c006e9ff9288f7a2ce.tar.gz
gentoo-2-fd8ebb3df611a6d97f7545c006e9ff9288f7a2ce.tar.bz2
gentoo-2-fd8ebb3df611a6d97f7545c006e9ff9288f7a2ce.zip
Update 9999 ebuild to better match reality: Use system miniupnp library, new sounds/emoticons. Thank Nikoli for this job.
(Portage version: 2.1.9.5/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild')
-rw-r--r--net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild b/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
index 6a315426a35a..a654d944cfc0 100644
--- a/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
+++ b/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild,v 1.12 2010/09/05 05:03:13 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild,v 1.13 2010/09/15 08:47:18 pva Exp $
EAPI="2"
@@ -15,7 +15,7 @@ ESVN_REPO_URI="http://${PN%pp}.googlecode.com/svn/branches/trunk/"
LICENSE="GPL-2 GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="dbus examples -gnome -gtk -javascript kde lua +qt4 spell upnp"
+IUSE="dbus +emoticons examples -gnome -gtk -javascript kde lua +qt4 sounds spell upnp"
RDEPEND="
app-arch/bzip2
@@ -24,6 +24,7 @@ RDEPEND="
virtual/libiconv
sys-devel/gettext
lua? ( >=dev-lang/lua-5.1 )
+ upnp? ( net-libs/miniupnpc )
gtk? (
x11-libs/pango
>=x11-libs/gtk+-2.10:2
@@ -71,11 +72,14 @@ src_configure() {
"$(cmake-utils_use spell USE_ASPELL)"
"$(cmake-utils_use qt4 USE_QT)"
"$(cmake-utils_use upnp USE_MINIUPNP)"
- "$(cmake-utils_use upnp LOCAL_MINIUPNP)"
+ -DLOCAL_MINIUPNP="0"
"$(cmake-utils_use gtk USE_GTK)"
"$(cmake-utils_use gnome USE_LIBGNOME2)"
- "-DUSE_WT=OFF"
+ -DUSE_WT="0"
+ "$(cmake-utils_use emoticons WITH_EMOTICONS)"
"$(cmake-utils_use examples WITH_EXAMPLES)"
+ "$(cmake-utils_use lua WITH_LUASCRIPTS)"
+ "$(cmake-utils_use sounds WITH_SOUNDS)"
-Dlinguas="${langs}"
)
cmake-utils_src_configure