summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-01-16 01:15:49 +0000
committerMike Frysinger <vapier@gentoo.org>2011-01-16 01:15:49 +0000
commit4a88c2baa4f5cd25d38061b7e4ca491b5530d074 (patch)
treeb18d1cf7d47bbb997096d217043cbd42b285487f /net-p2p/ctorrent
parentold (diff)
downloadgentoo-2-4a88c2baa4f5cd25d38061b7e4ca491b5530d074.tar.gz
gentoo-2-4a88c2baa4f5cd25d38061b7e4ca491b5530d074.tar.bz2
gentoo-2-4a88c2baa4f5cd25d38061b7e4ca491b5530d074.zip
Update to EAPI 2 and fix parsing of torrents with negative ints.
(Portage version: 2.2.0_alpha13/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/ctorrent')
-rw-r--r--net-p2p/ctorrent/ChangeLog10
-rw-r--r--net-p2p/ctorrent/ctorrent-3.3.2-r2.ebuild32
-rw-r--r--net-p2p/ctorrent/files/ctorrent-3.3.2-negative-ints.patch17
3 files changed, 57 insertions, 2 deletions
diff --git a/net-p2p/ctorrent/ChangeLog b/net-p2p/ctorrent/ChangeLog
index 5f83b375356d..4638d754cbcf 100644
--- a/net-p2p/ctorrent/ChangeLog
+++ b/net-p2p/ctorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/ctorrent
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ctorrent/ChangeLog,v 1.50 2010/09/19 17:55:11 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ctorrent/ChangeLog,v 1.51 2011/01/16 01:15:49 vapier Exp $
+
+*ctorrent-3.3.2-r2 (16 Jan 2011)
+
+ 16 Jan 2011; Mike Frysinger <vapier@gentoo.org> +ctorrent-3.3.2-r2.ebuild,
+ +files/ctorrent-3.3.2-negative-ints.patch:
+ Update to EAPI 2 and fix parsing of torrents with negative ints.
19 Sep 2010; Raúl Porcel <armin76@gentoo.org> ctorrent-3.3.2-r1.ebuild:
arm/s390/sh stable wrt #266953
diff --git a/net-p2p/ctorrent/ctorrent-3.3.2-r2.ebuild b/net-p2p/ctorrent/ctorrent-3.3.2-r2.ebuild
new file mode 100644
index 000000000000..3616987313ba
--- /dev/null
+++ b/net-p2p/ctorrent/ctorrent-3.3.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ctorrent/ctorrent-3.3.2-r2.ebuild,v 1.1 2011/01/16 01:15:49 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_P="${PN}-dnh${PV}"
+
+DESCRIPTION="Enhanced CTorrent is a BitTorrent console client written in C and C++"
+HOMEPAGE="http://www.rahul.net/dholmes/ctorrent/"
+SRC_URI="mirror://sourceforge/dtorrent/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-libs/openssl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-CVE-2009-1759.patch
+ epatch "${FILESDIR}"/${P}-negative-ints.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README-DNH.TXT README NEWS
+}
diff --git a/net-p2p/ctorrent/files/ctorrent-3.3.2-negative-ints.patch b/net-p2p/ctorrent/files/ctorrent-3.3.2-negative-ints.patch
new file mode 100644
index 000000000000..c3f98c713d01
--- /dev/null
+++ b/net-p2p/ctorrent/files/ctorrent-3.3.2-negative-ints.patch
@@ -0,0 +1,17 @@
+allow negative integers ... should fix random "error, initial meta info failed"
+
+https://sourceforge.net/tracker/?func=detail&aid=3159066&group_id=202532&atid=981959
+
+--- ctorrent-dnh3.3.2/bencode.cpp
++++ ctorrent-dnh3.3.2/bencode.cpp
+@@ -44,6 +44,10 @@
+ p++; len--;
+ }
+
++ if( *p == '-'){
++ p++; len--;
++ }
++
+ for(psave = p; len && isdigit(*p); p++,len--) ;
+
+ if(!len || MAX_INT_SIZ < (p - psave) || *p != endchar) return 0;