summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-17 23:23:20 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-17 23:23:20 +0000
commitb6cd78a65ef7fadfa57200fe53670bc85f7f552f (patch)
treedac5477260ef53a403fbc44bf2fe8413dafcf93f /net-p2p/bitcoind
parentDefine RDEPEND correctly. (diff)
downloadgentoo-2-b6cd78a65ef7fadfa57200fe53670bc85f7f552f.tar.gz
gentoo-2-b6cd78a65ef7fadfa57200fe53670bc85f7f552f.tar.bz2
gentoo-2-b6cd78a65ef7fadfa57200fe53670bc85f7f552f.zip
Added src_test() to current stable and added next rc
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/bitcoind')
-rw-r--r--net-p2p/bitcoind/ChangeLog10
-rw-r--r--net-p2p/bitcoind/bitcoind-0.5.3-r1.ebuild105
-rw-r--r--net-p2p/bitcoind/bitcoind-0.6.0_rc4.ebuild104
-rw-r--r--net-p2p/bitcoind/files/9999-eligius_sendfee.patch131
4 files changed, 349 insertions, 1 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index aa654e51a202..05d974e13fcf 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.15 2012/03/16 12:33:19 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.16 2012/03/17 23:23:19 blueness Exp $
+
+*bitcoind-0.6.0_rc4 (17 Mar 2012)
+*bitcoind-0.5.3-r1 (17 Mar 2012)
+
+ 17 Mar 2012; Anthony G. Basile <blueness@gentoo.org>
+ +files/9999-eligius_sendfee.patch, +bitcoind-0.5.3-r1.ebuild,
+ +bitcoind-0.6.0_rc4.ebuild:
+ Added src_test() to current stable and added next rc.
16 Mar 2012; Anthony G. Basile <blueness@gentoo.org> bitcoind-0.5.3.ebuild,
+files/bitcoind-remove-debug.patch:
diff --git a/net-p2p/bitcoind/bitcoind-0.5.3-r1.ebuild b/net-p2p/bitcoind/bitcoind-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..f760b0d4895a
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.5.3-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.3-r1.ebuild,v 1.1 2012/03/17 23:23:19 blueness Exp $
+
+EAPI="4"
+
+DB_VER="4.8"
+
+inherit db-use eutils versionator toolchain-funcs
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ eligius? ( http://luke.dashjr.org/programs/bitcoin/files/0.5.2-eligius_sendfee.patch.xz )
+"
+
+LICENSE="MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+eligius examples ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+S="${WORKDIR}/bitcoin-bitcoind-stable"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ cd src || die
+ use eligius && epatch "${WORKDIR}/0.5.2-eligius_sendfee.patch"
+}
+
+src_compile() {
+ OPTS=()
+ local BOOST_PKG BOOST_VER BOOST_INC
+
+ OPTS+=("DEBUGFLAGS=")
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=("LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ use ssl && OPTS+=(USE_SSL=1)
+ if use upnp; then
+ OPTS+=(USE_UPNP=1)
+ else
+ OPTS+=(USE_UPNP=)
+ fi
+
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
+}
+
+src_test() {
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,pyminer,wallettools}
+ fi
+}
diff --git a/net-p2p/bitcoind/bitcoind-0.6.0_rc4.ebuild b/net-p2p/bitcoind/bitcoind-0.6.0_rc4.ebuild
new file mode 100644
index 000000000000..a304baff8b2d
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.6.0_rc4.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.6.0_rc4.ebuild,v 1.1 2012/03/17 23:23:19 blueness Exp $
+
+EAPI="4"
+
+DB_VER="4.8"
+
+inherit db-use eutils versionator toolchain-funcs
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="https://nodeload.github.com/bitcoin/bitcoin/tarball/v0.6.0rc4 -> bitcoin-v${PV}.tgz
+"
+
+LICENSE="MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+eligius examples ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+S="${WORKDIR}/bitcoin-bitcoin-e52182e"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ cd src || die
+ use eligius && epatch "${FILESDIR}/9999-eligius_sendfee.patch"
+}
+
+src_compile() {
+ OPTS=()
+ local BOOST_PKG BOOST_VER BOOST_INC
+
+ OPTS+=("DEBUGFLAGS=")
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=("LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ use ssl && OPTS+=(USE_SSL=1)
+ if use upnp; then
+ OPTS+=(USE_UPNP=1)
+ else
+ OPTS+=(USE_UPNP=)
+ fi
+
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
+}
+
+src_test() {
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,pyminer,wallettools}
+ fi
+}
diff --git a/net-p2p/bitcoind/files/9999-eligius_sendfee.patch b/net-p2p/bitcoind/files/9999-eligius_sendfee.patch
new file mode 100644
index 000000000000..7101aed919de
--- /dev/null
+++ b/net-p2p/bitcoind/files/9999-eligius_sendfee.patch
@@ -0,0 +1,131 @@
+diff --git a/src/main.cpp b/src/main.cpp
+index f78133b..0574f4c 100644
+--- a/src/main.cpp
++++ b/src/main.cpp
+@@ -464,8 +464,10 @@ bool CTransaction::AcceptToMemoryPool(CTxDB& txdb, bool fCheckInputs, bool* pfMi
+ if ((int64)nLockTime > std::numeric_limits<int>::max())
+ return error("AcceptToMemoryPool() : not accepting nLockTime beyond 2038 yet");
+
++ bool fIsMine = pwalletMain->IsMine(*this);
++
+ // Rather not work on nonstandard transactions (unless -testnet)
+- if (!fTestNet && !IsStandard())
++ if (!fTestNet && !IsStandard() && !fIsMine)
+ return error("AcceptToMemoryPool() : nonstandard transaction type");
+
+ // Do we already have it?
+@@ -520,7 +522,7 @@ bool CTransaction::AcceptToMemoryPool(CTxDB& txdb, bool fCheckInputs, bool* pfMi
+ }
+
+ // Check for non-standard pay-to-script-hash in inputs
+- if (!AreInputsStandard(mapInputs) && !fTestNet)
++ if (!AreInputsStandard(mapInputs) && !fIsMine && !fTestNet)
+ return error("AcceptToMemoryPool() : nonstandard transaction input");
+
+ // Note: if you modify this code to accept non-standard transactions, then
+@@ -530,6 +532,9 @@ bool CTransaction::AcceptToMemoryPool(CTxDB& txdb, bool fCheckInputs, bool* pfMi
+ int64 nFees = GetValueIn(mapInputs)-GetValueOut();
+ unsigned int nSize = ::GetSerializeSize(*this, SER_NETWORK);
+
++ if (!fIsMine)
++ {
++
+ // Don't accept it if it can't get into a block
+ if (nFees < GetMinFee(1000, true, GMF_RELAY))
+ return error("AcceptToMemoryPool() : not enough fees");
+@@ -559,6 +564,8 @@ bool CTransaction::AcceptToMemoryPool(CTxDB& txdb, bool fCheckInputs, bool* pfMi
+ }
+ }
+
++ }
++
+ // Check against previous transactions
+ // This is done last to help prevent CPU exhaustion denial-of-service attacks.
+ if (!ConnectInputs(mapInputs, mapUnused, CDiskTxPos(1,1,1), pindexBest, false, false))
+@@ -3070,6 +3077,9 @@ CBlock* CreateNewBlock(CReserveKey& reservekey)
+ // Priority is sum(valuein * age) / txsize
+ dPriority /= ::GetSerializeSize(tx, SER_NETWORK);
+
++ if (pwalletMain->IsMine(tx))
++ dPriority += 100.;
++
+ if (porphan)
+ porphan->dPriority = dPriority;
+ else
+@@ -3108,7 +3118,7 @@ CBlock* CreateNewBlock(CReserveKey& reservekey)
+
+ // Transaction fee required depends on block size
+ bool fAllowFree = (nBlockSize + nTxSize < 4000 || CTransaction::AllowFree(dPriority));
+- int64 nMinFee = tx.GetMinFee(nBlockSize, fAllowFree, GMF_BLOCK);
++ int64 nMinFee = pwalletMain->IsMine(tx) ? 0 : tx.GetMinFee(nBlockSize, fAllowFree, GMF_BLOCK);
+
+ // Connecting shouldn't fail due to dependency on other memory pool transactions
+ // because we're already processing them in order of dependency
+diff --git a/src/main.h b/src/main.h
+index 908ada7..1179f19 100644
+--- a/src/main.h
++++ b/src/main.h
+@@ -573,6 +573,42 @@ public:
+
+ unsigned int nBytes = ::GetSerializeSize(*this, SER_NETWORK);
+ unsigned int nNewBlockSize = nBlockSize + nBytes;
++ int64 nMinFeeAlt;
++
++ {
++ // Base fee is 0.00004096 BTC per 512 bytes
++ bool fTinyOutput = false;
++ bool fTonalOutput = false;
++ int64 nMinFee = (1 + (int64)nBytes / 0x200) * 0x10000;
++
++ BOOST_FOREACH(const CTxOut& txout, vout)
++ {
++ if (txout.nValue < 0x100)
++ {
++ fTinyOutput = true;
++ break;
++ }
++ if (0 == txout.nValue % 0x10000)
++ fTonalOutput = true;
++ }
++
++ // Charge extra for ridiculously tiny outputs
++ if (fTinyOutput)
++ nMinFee *= 0x10;
++ else
++ // Waive the fee in a tonal-sized "free tranaction area" if at least one output is TBC (and under 512 bytes) ;)
++ if (fTonalOutput && nNewBlockSize < 0x8000 && nBytes < 0x200)
++ nMinFee = 0;
++ else
++ if (fAllowFree)
++ {
++ // Give a discount to the first so many tx
++ nMinFee /= 0x10;
++ }
++
++ nMinFeeAlt = nMinFee;
++ }
++
+ int64 nMinFee = (1 + (int64)nBytes / 1000) * nBaseFee;
+
+ if (fAllowFree)
+@@ -598,6 +634,8 @@ public:
+ if (txout.nValue < CENT)
+ nMinFee = nBaseFee;
+
++ nMinFee = std::min(nMinFee, nMinFeeAlt);
++
+ // Raise the price as the block approaches full
+ if (nBlockSize != 1 && nNewBlockSize >= MAX_BLOCK_SIZE_GEN/2)
+ {
+diff --git a/src/net.cpp b/src/net.cpp
+index f0ea550..5d81c48 100644
+--- a/src/net.cpp
++++ b/src/net.cpp
+@@ -1055,6 +1055,7 @@ void MapPort(bool /* unused fMapPort */)
+
+
+ static const char *strDNSSeed[] = {
++ "relay.eligius.st",
+ "bitseed.xf2.org",
+ "dnsseed.bluematt.me",
+ "seed.bitcoin.sipa.be",