summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-21 20:29:22 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-21 20:29:22 +0000
commit242767994d50d8d24eb147ec7f70abec55254cd9 (patch)
tree9685d6a94154c7540dd4cf48f9e300d3cd3c0541 /net-nntp
parentStable on amd64 wrt bug #337124 (diff)
downloadgentoo-2-242767994d50d8d24eb147ec7f70abec55254cd9.tar.gz
gentoo-2-242767994d50d8d24eb147ec7f70abec55254cd9.tar.bz2
gentoo-2-242767994d50d8d24eb147ec7f70abec55254cd9.zip
Update live ebuild to gnome git repository, bug #290914. Make it use base eclass and update dependencies.
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/pan/ChangeLog8
-rw-r--r--net-nntp/pan/pan-9999.ebuild42
2 files changed, 24 insertions, 26 deletions
diff --git a/net-nntp/pan/ChangeLog b/net-nntp/pan/ChangeLog
index 3cd6c091fc42..341f9db7c876 100644
--- a/net-nntp/pan/ChangeLog
+++ b/net-nntp/pan/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nntp/pan
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.76 2009/05/15 22:11:59 dirtyepic Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.77 2010/09/21 20:29:22 eva Exp $
+
+ 21 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org> pan-9999.ebuild:
+ Update live ebuild to gnome git repository, bug #290914. Make it use base
+ eclass and update dependencies.
15 May 2009; Ryan Hill <dirtyepic@gentoo.org> pan-0.133.ebuild,
+files/pan-0.133-gcc44.patch:
diff --git a/net-nntp/pan/pan-9999.ebuild b/net-nntp/pan/pan-9999.ebuild
index 2197ddbf6360..a04e56bd411f 100644
--- a/net-nntp/pan/pan-9999.ebuild
+++ b/net-nntp/pan/pan-9999.ebuild
@@ -1,51 +1,45 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-9999.ebuild,v 1.2 2008/10/04 11:11:38 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-9999.ebuild,v 1.3 2010/09/21 20:29:22 eva Exp $
-inherit autotools subversion
+EAPI="3"
+
+inherit autotools base git
DESCRIPTION="A newsreader for the Gnome2 desktop"
HOMEPAGE="http://pan.rebelbase.com/"
-ESVN_REPO_URI="http://svn.gnome.org/svn/pan2/trunk"
-ESVN_STORE_DIR="${PORTAGE_ACTUAL_DISTDIR-${DISTDIR}}"
-# maximum svn update frequency, hours
-ESVN_UP_FREQ="${ESVN_UP_FREQ:-1}"
+EGIT_REPO_URI="git://git.gnome.org/${PN}2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="spell"
-RDEPEND=">=dev-libs/glib-2.4.0
- >=x11-libs/gtk+-2.4.0
- >=dev-libs/libpcre-5.0
- =dev-libs/gmime-2.2*
+RDEPEND=">=dev-libs/glib-2.14:2
+ >=x11-libs/gtk+-2.12:2
+ >=dev-libs/gmime-2.1.9:0
spell? ( >=app-text/gtkspell-2.0.7 )"
DEPEND="${RDEPEND}
- >=dev-util/intltool-0.21
+ >=dev-util/intltool-0.35.5
dev-util/pkgconfig
sys-devel/gettext"
- # The normal version tree ebuild we are based on (for patching)
- Pnorm="${PN}-0.132"
+# The normal version tree ebuild we are based on (for patching)
+Pnorm="${PN}-0.133"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
-src_unpack() {
- subversion_src_unpack
- cd "${S}"
+src_prepare() {
+ git_src_prepare
# bootstrap build system
- intltoolize --force || die "intltoolize failed"
+ intltoolize --force --automake || die "intltoolize failed"
eautoreconf
}
-src_compile() {
+src_configure() {
econf $(use_with spell gtkspell)
- emake || die "emake failed"
}
-src_install() {
- emake install DESTDIR="${D}" || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
-}