summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-30 21:32:40 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-30 21:32:40 +0000
commit1475ff77f8a9c7494ced6786e495790b62dce179 (patch)
tree375cb8e745acf0ef34fbfb020fdf706118851577 /net-nntp
parentVersion bump. The new version fixes support for invalid USE_EXPAND values (bu... (diff)
downloadgentoo-2-1475ff77f8a9c7494ced6786e495790b62dce179.tar.gz
gentoo-2-1475ff77f8a9c7494ced6786e495790b62dce179.tar.bz2
gentoo-2-1475ff77f8a9c7494ced6786e495790b62dce179.zip
Fix underlinking issue (bug #372021) and add dependency on pkgconfig.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/nzbget/ChangeLog8
-rw-r--r--net-nntp/nzbget/files/nzbget-0.7.0-underlinking.patch20
-rw-r--r--net-nntp/nzbget/nzbget-0.7.0.ebuild16
3 files changed, 36 insertions, 8 deletions
diff --git a/net-nntp/nzbget/ChangeLog b/net-nntp/nzbget/ChangeLog
index bf58753245b1..5dd2fba741d8 100644
--- a/net-nntp/nzbget/ChangeLog
+++ b/net-nntp/nzbget/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nntp/nzbget
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/nzbget/ChangeLog,v 1.34 2010/09/11 18:59:05 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/nzbget/ChangeLog,v 1.35 2011/08/30 21:32:40 radhermit Exp $
+
+ 30 Aug 2011; Tim Harder <radhermit@gentoo.org> nzbget-0.7.0.ebuild,
+ +files/nzbget-0.7.0-underlinking.patch:
+ Fix underlinking issue (bug #372021) and add dependency on pkgconfig.
11 Sep 2010; Raúl Porcel <armin76@gentoo.org> nzbget-0.7.0.ebuild:
alpha stable wrt #329443
diff --git a/net-nntp/nzbget/files/nzbget-0.7.0-underlinking.patch b/net-nntp/nzbget/files/nzbget-0.7.0-underlinking.patch
new file mode 100644
index 000000000000..1771420304db
--- /dev/null
+++ b/net-nntp/nzbget/files/nzbget-0.7.0-underlinking.patch
@@ -0,0 +1,20 @@
+--- nzbget-0.7.0/configure.ac.orig
++++ nzbget-0.7.0/configure.ac
+@@ -204,7 +204,7 @@
+ [LIBVAL="no"])
+ if test "$INCVAL" = "no" -o "$LIBVAL" = "no"; then
+ PKG_CHECK_MODULES(libxml2, libxml-2.0,
+- [LDFLAGS="${LDFLAGS} $libxml2_LIBS"]
++ [LIBS="${LIBS} $libxml2_LIBS"]
+ [CPPFLAGS="${CPPFLAGS} $libxml2_CFLAGS"]
+ [CFLAGS="${CFLAGS} $libxml2_CFLAGS"])
+ fi
+@@ -290,7 +290,7 @@
+ [LIBVAL="no"])
+ if test "$INCVAL" = "no" -o "$LIBVAL" = "no"; then
+ PKG_CHECK_MODULES(libsigc, sigc++-2.0,
+- [LDFLAGS="${LDFLAGS} $libsigc_LIBS"]
++ [LIBS="${LIBS} $libsigc_LIBS"]
+ [CPPFLAGS="${CPPFLAGS} $libsigc_CFLAGS"])
+ fi
+
diff --git a/net-nntp/nzbget/nzbget-0.7.0.ebuild b/net-nntp/nzbget/nzbget-0.7.0.ebuild
index 198bd21260e6..b54dbfd3ac83 100644
--- a/net-nntp/nzbget/nzbget-0.7.0.ebuild
+++ b/net-nntp/nzbget/nzbget-0.7.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/nzbget/nzbget-0.7.0.ebuild,v 1.5 2010/09/11 18:59:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/nzbget/nzbget-0.7.0.ebuild,v 1.6 2011/08/30 21:32:40 radhermit Exp $
EAPI="2"
-inherit eutils
+inherit eutils autotools
MY_P="${P/_pre/-testing-r}"
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="alpha amd64 ~ppc x86"
IUSE="debug ssl gnutls ncurses parcheck"
-DEPEND="dev-libs/libxml2
+RDEPEND="dev-libs/libxml2
ssl? (
gnutls? ( net-libs/gnutls )
!gnutls? ( dev-libs/openssl )
@@ -27,7 +27,8 @@ DEPEND="dev-libs/libxml2
app-arch/libpar2
dev-libs/libsigc++:2
)"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
S="${WORKDIR}"/${P/_pre*/-testing}
@@ -45,7 +46,10 @@ src_prepare() {
"${S}"/nzbget.conf.example >"${S}"/nzbgetd.conf.example \
|| die "sed nzbgetd.conf.example failed"
- epatch "${FILESDIR}"/${P}-openssl-1.patch
+ epatch "${FILESDIR}"/${P}-openssl-1.patch \
+ "${FILESDIR}"/${P}-underlinking.patch
+
+ eautoreconf
}
src_configure() {