summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-04-28 01:50:51 +0000
committerMike Frysinger <vapier@gentoo.org>2015-04-28 01:50:51 +0000
commit211182171754fe49740753c21ffe9cf614fe78dd (patch)
tree2d2561e5feeeaa2fe4f8a298c9cb065f4600279c /net-nds
parentfix bug 547602 (diff)
downloadgentoo-2-211182171754fe49740753c21ffe9cf614fe78dd.tar.gz
gentoo-2-211182171754fe49740753c21ffe9cf614fe78dd.tar.bz2
gentoo-2-211182171754fe49740753c21ffe9cf614fe78dd.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/rpcbind/ChangeLog10
-rw-r--r--net-nds/rpcbind/rpcbind-0.2.3.ebuild55
-rw-r--r--net-nds/rpcbind/rpcbind-9999.ebuild6
3 files changed, 66 insertions, 5 deletions
diff --git a/net-nds/rpcbind/ChangeLog b/net-nds/rpcbind/ChangeLog
index f9f2d7e354c6..d91134b908dc 100644
--- a/net-nds/rpcbind/ChangeLog
+++ b/net-nds/rpcbind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nds/rpcbind
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.42 2014/12/23 02:14:39 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.43 2015/04/28 01:50:51 vapier Exp $
+
+*rpcbind-0.2.3 (28 Apr 2015)
+
+ 28 Apr 2015; Mike Frysinger <vapier@gentoo.org> +rpcbind-0.2.3.ebuild,
+ rpcbind-9999.ebuild:
+ Version bump.
23 Dec 2014; Tim Harder <radhermit@gentoo.org> rpcbind-9999.ebuild:
Sync changes to live ebuild.
diff --git a/net-nds/rpcbind/rpcbind-0.2.3.ebuild b/net-nds/rpcbind/rpcbind-0.2.3.ebuild
new file mode 100644
index 000000000000..be9c8de1cce8
--- /dev/null
+++ b/net-nds/rpcbind/rpcbind-0.2.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-0.2.3.ebuild,v 1.1 2015/04/28 01:50:51 vapier Exp $
+
+EAPI="5"
+
+inherit eutils systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://linux-nfs.org/~steved/rpcbind.git"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="portmap replacement which supports RPC over various protocols"
+HOMEPAGE="http://sourceforge.net/projects/rpcbind/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="debug selinux systemd tcpd warmstarts"
+
+CDEPEND=">=net-libs/libtirpc-0.2.3
+ systemd? ( sys-apps/systemd:= )
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-rpcbind )
+"
+src_prepare() {
+ [[ ${PV} == "9999" ]] && eautoreconf
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --with-statedir="${EPREFIX}"/run/${PN} \
+ --with-rpcuser=root \
+ --with-systemdsystemunitdir=$(usex systemd "$(systemd_get_unitdir)" "no") \
+ $(use_enable tcpd libwrap) \
+ $(use_enable debug) \
+ $(use_enable warmstarts)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
diff --git a/net-nds/rpcbind/rpcbind-9999.ebuild b/net-nds/rpcbind/rpcbind-9999.ebuild
index 48ab5a9e0308..ebab9410a8d2 100644
--- a/net-nds/rpcbind/rpcbind-9999.ebuild
+++ b/net-nds/rpcbind/rpcbind-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-9999.ebuild,v 1.13 2014/12/23 02:14:39 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-9999.ebuild,v 1.14 2015/04/28 01:50:51 vapier Exp $
EAPI="5"
inherit eutils systemd
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.infradead.org/~steved/rpcbind.git"
+ EGIT_REPO_URI="git://linux-nfs.org/~steved/rpcbind.git"
inherit autotools git-r3
else
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"