summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-07-07 01:15:13 +0000
committerJeroen Roovers <jer@gentoo.org>2009-07-07 01:15:13 +0000
commitf18a5815a184e4c21a5abc4457d9c6794c9f30dd (patch)
treebe237ce39d5199598c3a200548af794ef7387c20 /net-nds/ypbind
parentStable for HPPA too. (diff)
downloadgentoo-2-f18a5815a184e4c21a5abc4457d9c6794c9f30dd.tar.gz
gentoo-2-f18a5815a184e4c21a5abc4457d9c6794c9f30dd.tar.bz2
gentoo-2-f18a5815a184e4c21a5abc4457d9c6794c9f30dd.zip
Do not strip. Use emake instead of make.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-nds/ypbind')
-rw-r--r--net-nds/ypbind/ChangeLog8
-rw-r--r--net-nds/ypbind/files/ypbind-1.19.1-strip.patch11
-rw-r--r--net-nds/ypbind/ypbind-1.19.1-r2.ebuild52
3 files changed, 70 insertions, 1 deletions
diff --git a/net-nds/ypbind/ChangeLog b/net-nds/ypbind/ChangeLog
index 660f7f34dc9c..1641a67ffbc5 100644
--- a/net-nds/ypbind/ChangeLog
+++ b/net-nds/ypbind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nds/ypbind
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.47 2009/06/04 05:58:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.48 2009/07/07 01:15:12 jer Exp $
+
+*ypbind-1.19.1-r2 (07 Jul 2009)
+
+ 07 Jul 2009; Jeroen Roovers <jer@gentoo.org> +ypbind-1.19.1-r2.ebuild,
+ +files/ypbind-1.19.1-strip.patch:
+ Do not strip. Use emake instead of make.
04 Jun 2009; Mike Frysinger <vapier@gentoo.org> ypbind-1.19.1-r1.ebuild:
Allow portmap or rpcbind #272363 by peteru.
diff --git a/net-nds/ypbind/files/ypbind-1.19.1-strip.patch b/net-nds/ypbind/files/ypbind-1.19.1-strip.patch
new file mode 100644
index 000000000000..3acae486f68a
--- /dev/null
+++ b/net-nds/ypbind/files/ypbind-1.19.1-strip.patch
@@ -0,0 +1,11 @@
+--- ypbind-mt-1.19.1/src/Makefile.in.orig 2005-07-03 18:52:34.000000000 +0200
++++ ypbind-mt-1.19.1/src/Makefile.in 2009-07-07 03:09:18.000000000 +0200
+@@ -106,7 +106,7 @@
+ EXEEXT = @EXEEXT@
+ GMSGFMT = @GMSGFMT@
+ INSTALL_DATA = @INSTALL_DATA@
+-INSTALL_PROGRAM = @INSTALL_PROGRAM@ -s -m 555
++INSTALL_PROGRAM = @INSTALL_PROGRAM@ -m 555
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ INTLLIBS = @INTLLIBS@
diff --git a/net-nds/ypbind/ypbind-1.19.1-r2.ebuild b/net-nds/ypbind/ypbind-1.19.1-r2.ebuild
new file mode 100644
index 000000000000..b1ffc1d2a3bc
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.19.1-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.19.1-r2.ebuild,v 1.1 2009/07/07 01:15:12 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_P=${PN}-mt-${PV}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Multithreaded NIS bind service (ypbind-mt)"
+HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls slp"
+
+RDEPEND="slp? ( net-libs/openslp )
+ net-nds/yp-tools
+ || ( net-nds/portmap net-nds/rpcbind )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-strip.patch"
+}
+
+src_configure() {
+ econf $(use_enable nls) $(use_enable slp)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc AUTHORS ChangeLog README THANKS TODO
+
+ insinto /etc
+ newins etc/yp.conf yp.conf.example
+
+ newconfd "${FILESDIR}/ypbind.confd-r1" ypbind
+ newinitd "${FILESDIR}/ypbind.initd" ypbind
+}
+
+pkg_postinst() {
+ einfo "To complete setup, you will need to edit /etc/conf.d/ypbind."
+ einfo "If you are using dhcpcd, be sure to add the -Y option to"
+ einfo "dhcpcd_eth0 (or eth1, etc.) to keep dhcpcd from clobbering"
+ einfo "/etc/yp.conf."
+}