summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-04-13 12:41:05 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-04-13 12:41:05 +0000
commit2b4e6d3750525163864f47719cbe30bccfdc1b1e (patch)
treebd479dd8bef00d14e79107cf7b96ae90c8c68fe8 /net-nds/gosa-plugin-systems
parentEnable (L)GPL-3 only when needed (diff)
downloadgentoo-2-2b4e6d3750525163864f47719cbe30bccfdc1b1e.tar.gz
gentoo-2-2b4e6d3750525163864f47719cbe30bccfdc1b1e.tar.bz2
gentoo-2-2b4e6d3750525163864f47719cbe30bccfdc1b1e.zip
Fixed broken translations, icons and help files.
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'net-nds/gosa-plugin-systems')
-rw-r--r--net-nds/gosa-plugin-systems/ChangeLog8
-rw-r--r--net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.12-r1.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/net-nds/gosa-plugin-systems/ChangeLog b/net-nds/gosa-plugin-systems/ChangeLog
index 41607b41bcc1..45041ac49c9b 100644
--- a/net-nds/gosa-plugin-systems/ChangeLog
+++ b/net-nds/gosa-plugin-systems/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nds/gosa-plugin-systems
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/gosa-plugin-systems/ChangeLog,v 1.3 2011/03/01 06:48:16 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/gosa-plugin-systems/ChangeLog,v 1.4 2011/04/13 12:41:05 dev-zero Exp $
+
+*gosa-plugin-systems-2.6.12-r1 (13 Apr 2011)
+
+ 13 Apr 2011; Tiziano Müller <dev-zero@gentoo.org>
+ +gosa-plugin-systems-2.6.12-r1.ebuild:
+ Fixed broken translations, icons and help files.
*gosa-plugin-systems-2.6.12 (01 Mar 2011)
diff --git a/net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.12-r1.ebuild b/net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.12-r1.ebuild
new file mode 100644
index 000000000000..2fa7df31ebed
--- /dev/null
+++ b/net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.12-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.12-r1.ebuild,v 1.1 2011/04/13 12:41:05 dev-zero Exp $
+
+EAPI=4
+
+MY_P="${P/plugin/plugins}"
+
+DESCRIPTION="GOsa plugin for common systems integration"
+HOMEPAGE="https://oss.gonicus.de/labs/gosa/wiki/WikiStart."
+SRC_URI="ftp://oss.gonicus.de/pub/gosa/${MY_P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/${MY_P}.tar.bz2
+ ftp://oss.gonicus.de/pub/gosa/archive/${MY_P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/archive/${MY_P}.tar.bz2 "
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="~net-nds/gosa-core-${PV}"
+
+S="${WORKDIR}/${MY_P}"
+GOSA_COMPONENT="${PN/gosa-plugin-}"
+
+src_install() {
+ insinto /usr/share/gosa/html/plugins/${GOSA_COMPONENT}/
+ doins -r html/*
+
+ insinto /usr/share/gosa/locale/plugins/${GOSA_COMPONENT}/
+ doins -r locale/*
+
+ insinto /usr/share/gosa/plugins
+ doins -r admin
+
+ insinto /usr/share/gosa/doc/plugins/${GOSA_COMPONENT}/
+ doins -r help/*
+}
+
+pkg_postinst() {
+ ebegin "Updating class cache and locales"
+ "${EROOT}"usr/sbin/update-gosa
+ eend $?
+}