summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-10-17 18:22:30 +0000
committerSteve Dibb <beandog@gentoo.org>2007-10-17 18:22:30 +0000
commited9802c2c6457edc14274e173de212923b06701d (patch)
treef218353f03023039ca59cd1287dd1e6436209fbb /net-misc
parentChange media-libs/fmod dep to work with slots. (diff)
downloadgentoo-2-ed9802c2c6457edc14274e173de212923b06701d.tar.gz
gentoo-2-ed9802c2c6457edc14274e173de212923b06701d.tar.bz2
gentoo-2-ed9802c2c6457edc14274e173de212923b06701d.zip
Add codec use flags
(Portage version: 2.1.3.12)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/icecast/ChangeLog7
-rw-r--r--net-misc/icecast/files/digest-icecast-2.3.1-r23
-rw-r--r--net-misc/icecast/icecast-2.3.1-r2.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/net-misc/icecast/ChangeLog b/net-misc/icecast/ChangeLog
index 6e6e64527cf5..89bda59cad03 100644
--- a/net-misc/icecast/ChangeLog
+++ b/net-misc/icecast/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/icecast
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.74 2007/08/08 18:18:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.75 2007/10/17 18:22:29 beandog Exp $
+
+*icecast-2.3.1-r2 (17 Oct 2007)
+
+ 17 Oct 2007; Steve Dibb <beandog@gentoo.org> +icecast-2.3.1-r2.ebuild:
+ Add codec use flags
08 Aug 2007; Raúl Porcel <armin76@gentoo.org> icecast-2.3.1-r1.ebuild:
alpha stable wrt #185967
diff --git a/net-misc/icecast/files/digest-icecast-2.3.1-r2 b/net-misc/icecast/files/digest-icecast-2.3.1-r2
new file mode 100644
index 000000000000..0f54ccbe566a
--- /dev/null
+++ b/net-misc/icecast/files/digest-icecast-2.3.1-r2
@@ -0,0 +1,3 @@
+MD5 2d80a249fa8529f82d018c6216108ea8 icecast-2.3.1.tar.gz 1094154
+RMD160 394148f060daca979d49787530c4928558dd325c icecast-2.3.1.tar.gz 1094154
+SHA256 7bcc2a1e2137a143deeacd7619cd348300672aaf8774fcfcb2e43aa7c3e74660 icecast-2.3.1.tar.gz 1094154
diff --git a/net-misc/icecast/icecast-2.3.1-r2.ebuild b/net-misc/icecast/icecast-2.3.1-r2.ebuild
new file mode 100644
index 000000000000..cba292938ff7
--- /dev/null
+++ b/net-misc/icecast/icecast-2.3.1-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.3.1-r2.ebuild,v 1.1 2007/10/17 18:22:29 beandog Exp $
+
+inherit eutils
+
+DESCRIPTION="An opensource alternative to shoutcast that supports mp3, ogg (vorbis/theora) and aac streaming"
+HOMEPAGE="http://www.icecast.org/"
+SRC_URI="http://downloads.xiph.org/releases/icecast/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ogg speex theora vorbis yp"
+
+DEPEND="dev-libs/libxslt
+ ogg? ( media-libs/libogg )
+ vorbis? ( media-libs/libvorbis )
+ speex? ( media-libs/speex )
+ theora? ( media-libs/libtheora )
+ yp? ( net-misc/curl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-nocurlpassword.patch"
+}
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/icecast2 \
+ $(use_enable yp) || die "configure failed"
+
+ emake || die "make failed"
+}
+
+pkg_preinst() {
+ enewuser icecast -1 "-1" -1 nogroup || die "Problem adding icecast user"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO HACKING NEWS conf/icecast.xml.dist
+ dohtml -A chm,hhc,hhp doc/*
+ doman "${S}/debian/icecast2.1"
+
+ newinitd "${FILESDIR}/init.d.icecast" icecast
+
+ insinto /etc/icecast2/
+ doins "${FILESDIR}/icecast.xml"
+ fperms 600 /etc/icecast2/icecast.xml
+
+ keepdir /var/log/icecast
+ fowners icecast:nogroup /var/log/icecast
+
+ rm -rf "${D}/usr/share/doc/icecast"
+}