summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-08-23 22:14:17 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-08-23 22:14:17 +0000
commitde407944271fa79ad761b60a4e78539f75cc4178 (patch)
treea629b728e879e36db909ca08ec23118f806b0dcb /net-misc
parentForward-port the X509/hpn glue patch per bug #235086. (diff)
downloadgentoo-2-de407944271fa79ad761b60a4e78539f75cc4178.tar.gz
gentoo-2-de407944271fa79ad761b60a4e78539f75cc4178.tar.bz2
gentoo-2-de407944271fa79ad761b60a4e78539f75cc4178.zip
Update the LDAP patches, also mailed to upstream.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/ChangeLog9
-rw-r--r--net-misc/openssh/files/openssh-5.1_p1-ldap-hpn-glue.patch55
-rw-r--r--net-misc/openssh/metadata.xml1
-rw-r--r--net-misc/openssh/openssh-5.1_p1-r1.ebuild168
4 files changed, 232 insertions, 1 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index 8ea1e6ff0654..aa91636c1800 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.313 2008/08/23 21:33:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.314 2008/08/23 22:14:16 robbat2 Exp $
+
+*openssh-5.1_p1-r1 (23 Aug 2008)
+
+ 23 Aug 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/openssh-5.1_p1-ldap-hpn-glue.patch, metadata.xml,
+ +openssh-5.1_p1-r1.ebuild:
+ Update the LDAP patches, also mailed to upstream.
23 Aug 2008; Robin H. Johnson <robbat2@gentoo.org>
+files/openssh-5.1_p1-x509-hpn-glue.patch, openssh-5.1_p1.ebuild:
diff --git a/net-misc/openssh/files/openssh-5.1_p1-ldap-hpn-glue.patch b/net-misc/openssh/files/openssh-5.1_p1-ldap-hpn-glue.patch
new file mode 100644
index 000000000000..e6e22e865da6
--- /dev/null
+++ b/net-misc/openssh/files/openssh-5.1_p1-ldap-hpn-glue.patch
@@ -0,0 +1,55 @@
+diff -Nuar --exclude '*.rej' --exclude '*.orig' openssh-5.1p1+lpk/servconf.c openssh-5.1p1+lpk+glue/servconf.c
+--- openssh-5.1p1+lpk/servconf.c 2008-08-23 14:37:18.000000000 -0700
++++ openssh-5.1p1+lpk+glue/servconf.c 2008-08-23 14:52:19.000000000 -0700
+@@ -111,6 +111,25 @@
+ options->num_allow_groups = 0;
+ options->num_deny_groups = 0;
+ options->ciphers = NULL;
++#ifdef WITH_LDAP_PUBKEY
++ /* XXX dirty */
++ options->lpk.ld = NULL;
++ options->lpk.on = -1;
++ options->lpk.servers = NULL;
++ options->lpk.u_basedn = NULL;
++ options->lpk.g_basedn = NULL;
++ options->lpk.binddn = NULL;
++ options->lpk.bindpw = NULL;
++ options->lpk.sgroup = NULL;
++ options->lpk.filter = NULL;
++ options->lpk.fgroup = NULL;
++ options->lpk.l_conf = NULL;
++ options->lpk.tls = -1;
++ options->lpk.b_timeout.tv_sec = -1;
++ options->lpk.s_timeout.tv_sec = -1;
++ options->lpk.flags = FLAG_EMPTY;
++#endif
++
+ options->macs = NULL;
+ options->protocol = SSH_PROTO_UNKNOWN;
+ options->gateway_ports = -1;
+@@ -131,25 +150,6 @@
+ options->num_permitted_opens = -1;
+ options->adm_forced_command = NULL;
+ options->chroot_directory = NULL;
+-#ifdef WITH_LDAP_PUBKEY
+- /* XXX dirty */
+- options->lpk.ld = NULL;
+- options->lpk.on = -1;
+- options->lpk.servers = NULL;
+- options->lpk.u_basedn = NULL;
+- options->lpk.g_basedn = NULL;
+- options->lpk.binddn = NULL;
+- options->lpk.bindpw = NULL;
+- options->lpk.sgroup = NULL;
+- options->lpk.filter = NULL;
+- options->lpk.fgroup = NULL;
+- options->lpk.l_conf = NULL;
+- options->lpk.tls = -1;
+- options->lpk.b_timeout.tv_sec = -1;
+- options->lpk.s_timeout.tv_sec = -1;
+- options->lpk.flags = FLAG_EMPTY;
+-#endif
+-
+ }
+
+ void
diff --git a/net-misc/openssh/metadata.xml b/net-misc/openssh/metadata.xml
index 2577af26547e..760807f43b91 100644
--- a/net-misc/openssh/metadata.xml
+++ b/net-misc/openssh/metadata.xml
@@ -24,5 +24,6 @@ ssh-keygen and sftp-server. OpenSSH supports SSH protocol versions 1.3, 1.5, and
<flag name="chroot">Enable chrooting support</flag>
<flag name="hpn">Enable high performance ssh</flag>
<flag name="X509">Adds support for X.509 certificate authentication</flag>
+ <flag name="ldap">Add support for storing SSH public keys in LDAP</flag>
</use>
</pkgmetadata>
diff --git a/net-misc/openssh/openssh-5.1_p1-r1.ebuild b/net-misc/openssh/openssh-5.1_p1-r1.ebuild
new file mode 100644
index 000000000000..dd7fb6d12d81
--- /dev/null
+++ b/net-misc/openssh/openssh-5.1_p1-r1.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.1_p1-r1.ebuild,v 1.1 2008/08/23 22:14:16 robbat2 Exp $
+
+inherit eutils flag-o-matic ccc multilib autotools pam
+
+# Make it more portable between straight releases
+# and _p? releases.
+PARCH=${P/_/}
+
+X509_PATCH="${PARCH}+x509-6.1.1.diff.gz"
+LDAP_PATCH="${PARCH/openssh/openssh-lpk}-0.3.10.patch.gz"
+HPN_PATCH="${PARCH}-hpn13v5.diff.gz"
+
+DESCRIPTION="Port of OpenBSD's free SSH release"
+HOMEPAGE="http://www.openssh.org/"
+SRC_URI="mirror://openbsd/OpenSSH/portable/${PARCH}.tar.gz
+ http://www.sxw.org.uk/computing/patches/openssh-5.0p1-gsskex-20080404.patch
+ ${LDAP_PATCH:+ldap? ( mirror://gentoo/${LDAP_PATCH} )}
+ ${X509_PATCH:+X509? ( http://roumenpetrov.info/openssh/x509-6.1.1/${X509_PATCH} )}
+ ${HPN_PATCH:+hpn? ( http://www.psc.edu/networking/projects/hpn-ssh/${HPN_PATCH} )}"
+ #${LDAP_PATCH:+ldap? ( http://dev.inversepath.com/openssh-lpk/${LDAP_PATCH} )}
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="static pam tcpd kerberos skey selinux X509 ldap smartcard hpn libedit X"
+
+RDEPEND="pam? ( virtual/pam )
+ kerberos? ( virtual/krb5 )
+ selinux? ( >=sys-libs/libselinux-1.28 )
+ skey? ( >=sys-auth/skey-1.1.5-r1 )
+ ldap? ( net-nds/openldap )
+ libedit? ( dev-libs/libedit )
+ >=dev-libs/openssl-0.9.6d
+ >=sys-libs/zlib-1.2.3
+ smartcard? ( dev-libs/opensc )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ X? ( x11-apps/xauth )
+ userland_GNU? ( sys-apps/shadow )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ virtual/os-headers
+ sys-devel/autoconf"
+RDEPEND="${RDEPEND}
+ pam? ( sys-auth/pambase )"
+PROVIDE="virtual/ssh"
+
+S=${WORKDIR}/${PARCH}
+
+pkg_setup() {
+ # this sucks, but i'd rather have people unable to `emerge -u openssh`
+ # than not be able to log in to their server any more
+ maybe_fail() { [[ -z ${!2} ]] && use ${1} && echo ${1} ; }
+ local fail="
+ $(maybe_fail X509 X509_PATCH)
+ $(maybe_fail ldap LDAP_PATCH)
+ "
+ fail=$(echo ${fail})
+ if [[ -n ${fail} ]] ; then
+ eerror "Sorry, but this version does not yet support features"
+ eerror "that you requested: ${fail}"
+ eerror "Please mask ${PF} for now and check back later:"
+ eerror " # echo '=${CATEGORY}/${PF}' >> /etc/portage/package.mask"
+ die "booooo"
+ fi
+}
+
+src_unpack() {
+ unpack ${PARCH}.tar.gz
+ cd "${S}"
+
+ sed -i \
+ -e '/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:/usr/bin/xauth:' \
+ pathnames.h || die
+
+ use X509 && epatch "${DISTDIR}"/${X509_PATCH} "${FILESDIR}"/${PN}-5.1_p1-x509-hpn-glue.patch
+ use smartcard && epatch "${FILESDIR}"/openssh-3.9_p1-opensc.patch
+ if ! use X509 ; then
+ if [[ -n ${LDAP_PATCH} ]] && use ldap ; then
+ # The patch for bug 210110 64-bit stuff is now included.
+ epatch "${DISTDIR}"/${LDAP_PATCH}
+ epatch "${FILESDIR}"/${PN}-5.1_p1-ldap-hpn-glue.patch
+ fi
+ #epatch "${DISTDIR}"/openssh-5.0p1-gsskex-20080404.patch #115553 #216932
+ else
+ use ldap && ewarn "Sorry, X509 and ldap don't get along, disabling ldap"
+ fi
+ epatch "${FILESDIR}"/${PN}-4.7_p1-GSSAPI-dns.patch #165444 integrated into gsskex
+ [[ -n ${HPN_PATCH} ]] && use hpn && epatch "${DISTDIR}"/${HPN_PATCH}
+ epatch "${FILESDIR}"/${PN}-4.7p1-selinux.diff #191665
+
+ sed -i "s:-lcrypto:$(pkg-config --libs openssl):" configure{,.ac} || die
+
+ eautoreconf
+}
+
+src_compile() {
+ addwrite /dev/ptmx
+ addpredict /etc/skey/skeykeys #skey configure code triggers this
+
+ local myconf=""
+ if use static ; then
+ append-ldflags -static
+ use pam && ewarn "Disabling pam support becuse of static flag"
+ myconf="${myconf} --without-pam"
+ else
+ myconf="${myconf} $(use_with pam)"
+ fi
+
+ econf \
+ --with-ldflags="${LDFLAGS}" \
+ --disable-strip \
+ --sysconfdir=/etc/ssh \
+ --libexecdir=/usr/$(get_libdir)/misc \
+ --datadir=/usr/share/openssh \
+ --with-privsep-path=/var/empty \
+ --with-privsep-user=sshd \
+ --with-md5-passwords \
+ --with-ssl-engine \
+ ${LDAP_PATCH:+$(use_with ldap)} \
+ $(use_with libedit) \
+ $(use_with kerberos kerberos5 /usr) \
+ $(use_with tcpd tcp-wrappers) \
+ $(use_with selinux) \
+ $(use_with skey) \
+ $(use_with smartcard opensc) \
+ ${myconf} \
+ || die "bad configure"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install-nokeys DESTDIR="${D}" || die
+ fperms 600 /etc/ssh/sshd_config
+ dobin contrib/ssh-copy-id
+ newinitd "${FILESDIR}"/sshd.rc6 sshd
+ newconfd "${FILESDIR}"/sshd.confd sshd
+ keepdir /var/empty
+
+ newpamd "${FILESDIR}"/sshd.pam_include.2 sshd
+ use pam \
+ && dosed "/^#UsePAM /s:.*:UsePAM yes:" /etc/ssh/sshd_config \
+ && dosed "/^#PasswordAuthentication /s:.*:PasswordAuthentication no:" /etc/ssh/sshd_config
+
+ doman contrib/ssh-copy-id.1
+ dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
+
+ diropts -m 0700
+ dodir /etc/skel/.ssh
+}
+
+pkg_postinst() {
+ enewgroup sshd 22
+ enewuser sshd 22 -1 /var/empty sshd
+
+ # help fix broken perms caused by older ebuilds.
+ # can probably cut this after the next stage release.
+ chmod u+x "${ROOT}"/etc/skel/.ssh >& /dev/null
+
+ ewarn "Remember to merge your config files in /etc/ssh/ and then"
+ ewarn "restart sshd: '/etc/init.d/sshd restart'."
+ if use pam ; then
+ echo
+ ewarn "Please be aware users need a valid shell in /etc/passwd"
+ ewarn "in order to be allowed to login."
+ fi
+}