summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-01-10 20:43:53 +0000
committerPacho Ramos <pacho@gentoo.org>2013-01-10 20:43:53 +0000
commitc9b69bea68e415f1ad91156e682f8e12c77862f4 (patch)
treefa231c117f76fc7a332e9ed3f84cf9dce431dd34 /net-misc
parentUse configure flags to install doc files and fix EAPI=4 handling of $ED. (diff)
downloadgentoo-2-c9b69bea68e415f1ad91156e682f8e12c77862f4.tar.gz
gentoo-2-c9b69bea68e415f1ad91156e682f8e12c77862f4.tar.bz2
gentoo-2-c9b69bea68e415f1ad91156e682f8e12c77862f4.zip
Fix overflow (bug #450990 by Diego Elio Pettenò and fix by Richard Grenville), remove old.
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/pavuk/ChangeLog14
-rw-r--r--net-misc/pavuk/files/pavuk-0.9.36_pre20120215-tl_selectr-overflow-fix.patch13
-rw-r--r--net-misc/pavuk/pavuk-0.9.36_pre20120215-r2.ebuild (renamed from net-misc/pavuk/pavuk-0.9.36_pre20120215-r1.ebuild)12
-rw-r--r--net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild103
4 files changed, 31 insertions, 111 deletions
diff --git a/net-misc/pavuk/ChangeLog b/net-misc/pavuk/ChangeLog
index e3dae5f15ed8..5d0b300b7a80 100644
--- a/net-misc/pavuk/ChangeLog
+++ b/net-misc/pavuk/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-misc/pavuk
-# Copyright 2002-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/ChangeLog,v 1.38 2012/02/25 12:31:13 pacho Exp $
+# Copyright 2002-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/ChangeLog,v 1.39 2013/01/10 20:43:52 pacho Exp $
+
+*pavuk-0.9.36_pre20120215-r2 (10 Jan 2013)
+
+ 10 Jan 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/pavuk-0.9.36_pre20120215-tl_selectr-overflow-fix.patch,
+ +pavuk-0.9.36_pre20120215-r2.ebuild, -pavuk-0.9.36_pre20120215-r1.ebuild,
+ -pavuk-0.9.36_pre20120215.ebuild:
+ Fix overflow (bug #450990 by Diego Elio Pettenò and fix by Richard Grenville),
+ remove old.
*pavuk-0.9.36_pre20120215-r1 (25 Feb 2012)
@@ -176,4 +185,3 @@
10 Feb 2003; Seth Chandler <sethbc@gentoo.org>: pavuk-0.9.28.ebuild
added pavuk to portage thx to Emil Mikulic <emikulic@optushome.com.au>
-
diff --git a/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-tl_selectr-overflow-fix.patch b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-tl_selectr-overflow-fix.patch
new file mode 100644
index 000000000000..ec3655f1468c
--- /dev/null
+++ b/net-misc/pavuk/files/pavuk-0.9.36_pre20120215-tl_selectr-overflow-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/src/absio.orig.c b/src/absio.c
+index 7be9255..e19d7cd 100644
+--- a/src/absio.orig.c
++++ b/src/absio.c
+@@ -181,7 +181,7 @@ int tl_selectr(int sock, long int timeout)
+ {
+ if ((rv == 0) && !cfg.stop && !cfg.rbreak && !FD_ISSET(sock, &readfds))
+ {
+- char buf[32];
++ char buf[64];
+ int r;
+ char buf2[64];
+
diff --git a/net-misc/pavuk/pavuk-0.9.36_pre20120215-r1.ebuild b/net-misc/pavuk/pavuk-0.9.36_pre20120215-r2.ebuild
index e5b5f05b6172..ec0325e4105b 100644
--- a/net-misc/pavuk/pavuk-0.9.36_pre20120215-r1.ebuild
+++ b/net-misc/pavuk/pavuk-0.9.36_pre20120215-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/pavuk-0.9.36_pre20120215-r1.ebuild,v 1.1 2012/02/25 12:31:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/pavuk-0.9.36_pre20120215-r2.ebuild,v 1.1 2013/01/10 20:43:52 pacho Exp $
-EAPI=4
+EAPI=5
S="${WORKDIR}/${PN}"
@@ -38,11 +38,13 @@ PATCHES=(
# Fixes a segfault in the GTK+2 interface on amd64, bug #262504#c40
"${FILESDIR}/${P}-fix-gtkmulticol-segfault.patch"
+
+ # Fixed overflow, bug #450990
+ "${FILESDIR}/${P}-tl_selectr-overflow-fix.patch"
)
DOCS=( README CREDITS NEWS AUTHORS BUGS TODO MAILINGLIST wget-pavuk.HOWTO
- ChangeLog wget-pavuk.HOWTO pavuk_authinfo.sample pavukrc.sample
- )
+ ChangeLog wget-pavuk.HOWTO pavuk_authinfo.sample pavukrc.sample )
src_prepare() {
# Fixes a bug in Makefile.am that causes aclocal to fail
diff --git a/net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild b/net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild
deleted file mode 100644
index ff5fac00974e..000000000000
--- a/net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/pavuk-0.9.36_pre20120215.ebuild,v 1.3 2012/02/19 13:20:37 pacho Exp $
-
-EAPI=4
-
-S="${WORKDIR}/${PN}"
-
-inherit eutils autotools-utils
-
-DESCRIPTION="Web spider and website mirroring tool"
-HOMEPAGE="http://www.pavuk.org/"
-SRC_URI="http://dev.gentoo.org/~pacho/maintainer-needed/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="debug gtk hammer ipv6 nls pcre profile ssl"
-
-RDEPEND="virtual/libintl
- gtk? ( x11-libs/gtk+:2 )
- pcre? ( dev-libs/libpcre )
- ssl? ( dev-libs/openssl )"
-
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- sys-devel/gettext"
-
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-DOCS=( README CREDITS NEWS AUTHORS BUGS TODO MAILINGLIST wget-pavuk.HOWTO
- ChangeLog wget-pavuk.HOWTO pavuk_authinfo.sample pavukrc.sample
- )
-
-src_prepare() {
- # Fixes a bug in Makefile.am that causes aclocal to fail
- sed -i 's/^\(ACLOCAL_AMFLAGS[[:space:]]*=[[:space:]]*-I[[:space:]]*\)\$(top_srcdir)\//\1/' "${S}/Makefile.am" || die
-
- # Fixes a bug in configure.in that breaks non-debug builds
- sed -i 's/\([[:space:]]C\(PP\)*FLAGS=`\)/true; # \1/' "${S}/configure.in" || die
-
- # Fixes a bug in re.c for PCRE support
- epatch "${FILESDIR}/${P}-pcre-fix.patch"
-
- # Fix for building with ~dev-lang/spidermonkey-1.8.5
- # sed -i 's/mozjs/mozjs185/g' "${S}/configure.in" || die
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local regex="auto"
- use pcre && regex="pcre"
-
- local myeconfargs=(
- --enable-threads
- --enable-socks
- --enable-utf-8
- --disable-js
- "--with-regex=${regex}"
- $(use_enable gtk)
- $(use_enable gtk gtk2)
- $(use_enable gtk gnome)
- $(use_with gtk x)
- $(use_enable debug debugging)
- $(use_enable debug debug-build)
- # $(use_enable debug debug-features)
- $(use_enable ssl)
- $(use_enable nls)
- $(use_enable ipv6)
- # $(use_enable javascript js)
- $(use_enable profile profiling)
- )
-
- # JavaScript bindings: Broken!
- # ============================
- # Currently could pass configure phase with ~dev-lang/spidermonkey-1.8.5
- # yet apparently incompatible with recent versions of spidermonkey
-
- # if use javascript; then
- # local jspkg='mozjs185'
- # local jsinclude=$(pkg-config --cflags "$jspkg")
- # local jslibs='/dev/null '$(pkg-config --libs-only-l "$jspkg")
- # myeconfargs+=(
- # "--with-js-include=${jsinclude}"
- # "--with-js-libraries=${jslibs}"
- # )
- # fi
-
- autotools-utils_src_configure
-}
-
-src_install() {
- if use gtk; then
- newicon src/pavuk_logo.xpm pavuk.xpm
- domenu pavuk.desktop
- fi
-
- doman "${S}/doc/pavuk.1"
-
- autotools-utils_src_install
-}