summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-04-15 17:51:41 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-04-15 17:51:41 +0000
commitb665705a84b9950504e7df4cc441d3249ec673be (patch)
treeaf05b8fdfed72f33018eb6b55e9771df4c8c8c58 /net-misc
parentAdd back ia64 love #349020 by Dennis Schridde. (diff)
downloadgentoo-2-b665705a84b9950504e7df4cc441d3249ec673be.tar.gz
gentoo-2-b665705a84b9950504e7df4cc441d3249ec673be.tar.bz2
gentoo-2-b665705a84b9950504e7df4cc441d3249ec673be.zip
Add missing patch
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/ChangeLog6
-rw-r--r--net-misc/curl/files/curl-fix-gnutls-nettle.patch27
2 files changed, 32 insertions, 1 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index f1ccb2f532eb..2a0b4ae245d1 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/curl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.213 2012/04/15 17:05:03 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.214 2012/04/15 17:51:41 blueness Exp $
+
+ 15 Apr 2012; Anthony G. Basile <blueness@gentoo.org>
+ +files/curl-fix-gnutls-nettle.patch:
+ Add missing patch
*curl-7.25.0-r1 (15 Apr 2012)
diff --git a/net-misc/curl/files/curl-fix-gnutls-nettle.patch b/net-misc/curl/files/curl-fix-gnutls-nettle.patch
new file mode 100644
index 000000000000..fbacb7748bdc
--- /dev/null
+++ b/net-misc/curl/files/curl-fix-gnutls-nettle.patch
@@ -0,0 +1,27 @@
+diff -Naur curl-7.25.0.orig//configure.ac curl-7.25.0/configure.ac
+--- curl-7.25.0.orig//configure.ac 2012-04-04 17:24:48.000000000 -0400
++++ curl-7.25.0/configure.ac 2012-04-04 17:23:07.000000000 -0400
+@@ -1823,20 +1823,9 @@
+
+ if test "$GNUTLS_ENABLED" = "1"; then
+ USE_GNUTLS_NETTLE=
+- # First check if we can detect either crypto library via transitive linking
+- AC_CHECK_LIB(gnutls, nettle_MD5Init, [ USE_GNUTLS_NETTLE=1 ])
+- if test "$USE_GNUTLS_NETTLE" = ""; then
+- AC_CHECK_LIB(gnutls, gcry_control, [ USE_GNUTLS_NETTLE=0 ])
+- fi
+- # If not, try linking directly to both of them to see if they are available
+- if test "$USE_GNUTLS_NETTLE" = ""; then
+- AC_CHECK_LIB(nettle, nettle_MD5Init, [ USE_GNUTLS_NETTLE=1 ])
+- fi
+- if test "$USE_GNUTLS_NETTLE" = ""; then
+- AC_CHECK_LIB(gcrypt, gcry_control, [ USE_GNUTLS_NETTLE=0 ])
+- fi
+- if test "$USE_GNUTLS_NETTLE" = ""; then
+- AC_MSG_ERROR([GnuTLS found, but neither gcrypt nor nettle found])
++ AC_ARG_WITH(nettle)
++ if test "x$withval" = "xyes"; then
++ USE_GNUTLS_NETTLE=1
+ fi
+ if test "$USE_GNUTLS_NETTLE" = "1"; then
+ AC_DEFINE(USE_GNUTLS_NETTLE, 1, [if GnuTLS uses nettle as crypto backend])