summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-06-27 13:26:34 +0000
committerJeroen Roovers <jer@gentoo.org>2013-06-27 13:26:34 +0000
commitae9368819b69bcfc6ed225d54480544feb5d5531 (patch)
treebe205d43c5a63dd653e5c7f63b16acc6a959e223 /net-misc
parentremove old (diff)
downloadgentoo-2-ae9368819b69bcfc6ed225d54480544feb5d5531.tar.gz
gentoo-2-ae9368819b69bcfc6ed225d54480544feb5d5531.tar.bz2
gentoo-2-ae9368819b69bcfc6ed225d54480544feb5d5531.zip
Version bump.
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/ChangeLog7
-rw-r--r--net-misc/youtube-dl/youtube-dl-2013.06.34.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/net-misc/youtube-dl/ChangeLog b/net-misc/youtube-dl/ChangeLog
index baa2e7e31e21..743a25996075 100644
--- a/net-misc/youtube-dl/ChangeLog
+++ b/net-misc/youtube-dl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/youtube-dl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v 1.182 2013/06/26 12:16:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v 1.183 2013/06/27 13:26:34 jer Exp $
+
+*youtube-dl-2013.06.34 (27 Jun 2013)
+
+ 27 Jun 2013; Jeroen Roovers <jer@gentoo.org> +youtube-dl-2013.06.34.ebuild:
+ Version bump.
*youtube-dl-2013.06.33 (26 Jun 2013)
diff --git a/net-misc/youtube-dl/youtube-dl-2013.06.34.ebuild b/net-misc/youtube-dl/youtube-dl-2013.06.34.ebuild
new file mode 100644
index 000000000000..d98ca527094f
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2013.06.34.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/youtube-dl-2013.06.34.ebuild,v 1.1 2013/06/27 13:26:34 jer Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python{2_5,2_6,2_7})
+
+inherit bash-completion-r1 eutils python-single-r1
+
+DESCRIPTION="Download videos from YouTube.com (and mores sites...)"
+HOMEPAGE="http://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="test? ( dev-python/nose[coverage(+)] )"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if use test; then
+ use offensive || epatch "${FILESDIR}"/${PN}-2013.06.21-offensive.patch
+ fi
+}
+
+src_install() {
+ rm -vf youtube_dl/*.py[co]
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc CHANGELOG README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}