summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-06-30 15:17:15 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-06-30 15:17:15 +0000
commitad5412aff6a4bd129f3c8454dc4b10f97aa0745c (patch)
treea36ec8e3a5484b939d3fb1b9fb69133fdd6d4140 /net-misc
parentFix; next time make sure the box you test and the box you commit are the same. (diff)
downloadgentoo-2-ad5412aff6a4bd129f3c8454dc4b10f97aa0745c.tar.gz
gentoo-2-ad5412aff6a4bd129f3c8454dc4b10f97aa0745c.tar.bz2
gentoo-2-ad5412aff6a4bd129f3c8454dc4b10f97aa0745c.zip
Version bump, first 0.2.3.x release candidate
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tor/ChangeLog7
-rw-r--r--net-misc/tor/tor-0.2.3.18_rc.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index 2675ee077336..22ba6685964e 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.335 2012/06/16 08:07:24 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.336 2012/06/30 15:17:15 blueness Exp $
+
+*tor-0.2.3.18_rc (30 Jun 2012)
+
+ 30 Jun 2012; Anthony G. Basile <blueness@gentoo.org> +tor-0.2.3.18_rc.ebuild:
+ Version bump, first 0.2.3.x release candidate
*tor-0.2.3.17_beta (16 Jun 2012)
diff --git a/net-misc/tor/tor-0.2.3.18_rc.ebuild b/net-misc/tor/tor-0.2.3.18_rc.ebuild
new file mode 100644
index 000000000000..fd16ed44ad63
--- /dev/null
+++ b/net-misc/tor/tor-0.2.3.18_rc.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.3.18_rc.ebuild,v 1.1 2012/06/30 15:17:15 blueness Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic versionator
+
+MY_PV="$(replace_version_separator 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+bufferevents nat-pmp tor-hardening transparent-proxy threads upnp selinux web"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ >=dev-libs/libevent-2.0.14
+ nat-pmp? ( net-libs/libnatpmp )
+ upnp? ( net-libs/miniupnpc )
+ selinux? ( sec-policy/selinux-tor )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.3.14_alpha-torrc.sample.patch
+}
+
+src_configure() {
+ # Upstream isn't sure of all the user provided CFLAGS that
+ # will break tor, but does recommend against -fstrict-aliasing.
+ # We'll filter-flags them here as we encounter them.
+ filter-flags -fstrict-aliasing
+ econf \
+ --enable-asciidoc \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable bufferevents) \
+ $(use_enable nat-pmp) \
+ $(use_enable tor-hardening gcc-hardening) \
+ $(use_enable tor-hardening linker-hardening) \
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable threads) \
+ $(use_enable upnp) \
+ $(use_enable web tor2web-mode)
+}
+
+src_install() {
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r6 tor
+
+ emake DESTDIR="${D}" install
+
+ keepdir /var/lib/tor
+
+ dodoc README ChangeLog ReleaseNotes \
+ doc/{HACKING,TODO} \
+ doc/spec/README
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r1 torrc
+}
+
+pkg_postinst() {
+ elog
+ elog "We created a configuration file for tor, /etc/tor/torrc, but you can"
+ elog "change it according to your needs. Use the torrc.sample that is in"
+ elog "that directory as a guide. Also, to have privoxy work with tor"
+ elog "just add the following line"
+ elog
+ elog "forward-socks4a / localhost:9050 ."
+ elog
+ elog "to /etc/privoxy/config. Notice the . at the end!"
+ elog
+}